Jump to content











Photo
- - - - -

Can't boot after using HD on seperate computer


  • Please log in to reply
7 replies to this topic

#1 Slammer

Slammer
  • Members
  • 4 posts
  •  
    United States

Posted 14 May 2012 - 04:21 AM

First of all, let me just say I'm brand new to this site. I have this problem I haven't been able to solve, and posts in these forums have been a big help with solving past problems I've had. So I figured I'd join and see if I canget some of that help! I did my best to find and read all the rules and whatnot, so I appologize if I started this thread in the wrong section or something.

The situation: Several months ago, I finally found this awesome post located on this site (which I think is affiliated with this site, but don't know for sure): http://www.rmprepusb...rials/win7onusb And used it to install Windows 7 Ultimate x64 directly onto a partition on my Seagate 2TB external USB 3.0 drive. I set it up on a HP Pavilion Desktop model (not sure which one). But I couldn't get the sysprep shortcut to work properly so I just shut it down and plugged it into my laptop (specs at the end). It booted fine, and I installed all the necessary drivers for my laptop and it worked great from that point forward.

A couple weeks ago, the backlight in my laptop screen started going bad, and the screen would essentially shut off every minute or so. Sadly, I didn't have an external monitor available. So I finally got fed up with the problem and decided to just plug the hard drive into a different laptop (belonging to my father) and use it like that for a while. But I was feeling pretty "adventurous" I guess, and instead of shutting down my computer before removing it, I put it in sleep mode and then unplugged it. It booted fine on the other computer, but Windows reported that it hadn't automatically installed the network or chipset drivers. So I manually downloaded and installed them. At that point my father needed his computer back, so I shut it down and plugged the HD back into my laptop and it resumed from sleep mode perfectly and I didn't have any issues.

The problem: the next day I tried to boot it on my laptop as usual. But as soon as it got to the point after that little boot logo where it should show the login screen, it flashed a BSOD for a fraction of a second and restarted. No form of safe mode would boot either. It would get the point where it showed that it loaded the CI.dll file, then would pause for a few seconds, flash that BSOD, and restart. No other BIOS startup options would give me any other behavior either. I even tried plugging it back into my father's laptop and booting, but got the exact same results.

Startup repair didn't help, nor did chkdsk or sfc. I figured the BSOD that was too fast to see would probably be helpful, so I recorded it and grabbed the best screenshot I could: https://www.dropbox....3taqcj/BSOD.png

A couple of weeks of research later, and I've decided that the chipset drivers I installed for the other laptop contained storage controller drivers that are conflicting with the ones that were installed for my laptop. It's the most likely scenario since that's what that BSOD code usually refers to (the 0x0000007B one from the screenshot), and those were the last things I installed before this mess happened.

Some more research, and I discover that Hiren's BootCD has a utility that can supposedly fix this problem (sometimes) by replacing the storage controller driver with a generic one or some magic like that. Here's the forum I got that info from (specifically the post by dcoetzee about a third of the way down): http://www.daniweb.c...-old-hard-drive So I went ahead and ran that tool. And although it still didn't boot, it made progress! Now it displays this a couple seconds into the boot animation: http://dl.dropbox.co...56/IASTORE9.jpg

Meanwhile, I set up an identical OS on another partition on that same HD so that I'd have an OS with all the proper drivers installed for comparison. I also ran across this helpful link supposedly detailing how to disable essential drivers that are causing problems with bootup: http://support.microsoft.com/kb/927525 However, I haven't been able to identify exactly which driver needs to be disabled. But I used that IASTOR9 error to find three subkeys in the registry (in the area referenced by the KB article) of the messed up installation that are probably related to this problem: iastorv, iastor, and iastor9. I compared it to the registry entries in the installation I set up for comparison (which I'm using temporarily until this problem gets fixed) and the only one that's in the working installation is the "iastorv" subkey. I don't know what this means or what to do with that info, but it probably has something to do with the booting issues.

Next, I compared all the files that are related to "iastor" in some way in the %systemroot%\system32\drivers folders of the messed up installation and the working one. The working one only contains an "iastorv.sys" file, while the messed up installation contains "iastorv.sys" "iastor.sys" and "iastor9.sys".

My Thoughts: I think the messed up OS is trying to load both the iastor9.sys and iastorv.sys driver files, which I'm fairly certain are both storage controller drivers; iastorv.sys should be the appropriate driver for my laptop, and the iastore9.sys should be the one for my father's laptop. I don't know about the iastor.sys file/ One way or another, I'd bet the problem is somehow related to the storage controller driver not loading correctly at boot. But I have no idea how to fix that. Ideally, there would be a way for me to delete all the storage controller drivers on that OS so that it'll be forced to reload the correct ones when it boots (or let me reinstall the correct one before it boots). Or even just a way to delete ALL the drivers in that installation and make it think it's being set up for the first time (forcing a new load of all the necessary drivers), without deleting all the programs I have installed. Because that's what's keeping me from just reinstalling the OS: I dread having to go back and reinstall half a terabyte of programs, and reconfigure all of them to the perfect customized way I had them before. I'll do it if I have to, but I REALLY DON'T want to. Personally files can be backed up without an issue if that has to happen.

I'm going to image the whole partition tonight so I can make changes to things without fear of messing it up worse.

I think that's all the relevant information I've collected over the last couple weeks. Sorry for the jumbled mess. I don't know how to arrange it more effectively. I don't know what information is relevant and what isn't, so I just put it all! But too much info is better than not enough, right? Thanks to anyone who takes the time to read that monster of a post and try to help me get my computer back up and running. I consider myself to be pretty darn computer literate, but I just don't know enough about how these blasted drivers work (what registry entries tell which ones to load, where any config files for them are, what places they're stored in, etc.) So I'm not comfortable just going around and deleting things I think are unnecessary, just to get it to work again. I have a feeling that if I delete one of those iastor system files that I think doesn't belong, and miss something that points to it in the registry or something, I'll end up in an even bigger mess. Hopefully one of you nice people does know about this stuff and can help. Thanks!

Computer specs:

My laptop:
Dell Inspiron 1545
Windows 7 Ultimate x64
4GB RAM
Intel Core 2 Duo CPU (2GHz)
Integrated graphics (chipset)
Internal 320GB HD, External 2TB USB HD

My father's laptop:
Acer Aspire 7750Z
Windows Home Premium x64
8GB RAM
Intel Core 2GHz processor

#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15029 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 14 May 2012 - 09:14 AM

Using Warez (Hiren's BootCD) is not supported (by me) :(, though the new policies of the board do somehow allow it.
In any case you shouldn't use them.

Get this:
http://www.911cd.net...topic=24245&hl=
it should work allright :).

:cheers:
Wonko

#3 cdob

cdob

    Gold Member

  • Expert
  • 1440 posts

Posted 14 May 2012 - 11:59 AM

Here's the forum I got that info from

No warez support.

It's a bad idea to include a 32 bit driver to a 64 bit OS.

Fix the mess:
disable both iastor drivers: start=4
and enable msahci start=0
http://support.micro....com/kb/922976/

#4 Slammer

Slammer
  • Members
  • 4 posts
  •  
    United States

Posted 14 May 2012 - 10:11 PM

Hiren's BootCD is considered warez?! Wow, it's like my number 1 favorite tool for fixing big problems like this! I had no idea.

Thanks for the speedy responses. The backup of my hard drive last night failed (something about a cyclic redundancy error) but I found the setting to ignore that and finish the backup from now on. I also ran chkdsk again for good measure. Should I still make a backup before proceeding? I don't know how drastic your suggested changes will be, and don't want to make it worse if something goes wrong. But I don't want to wait another day for a backup to complete if it's not really needed either.

cdob- which 32 bit driver are you referring to?

Thanks again for your help.

#5 cdob

cdob

    Gold Member

  • Expert
  • 1440 posts

Posted 15 May 2012 - 04:16 AM

The backup of my hard drive last night failed (something about a cyclic redundancy error)

Replace the half broken hard disk.

which 32 bit driver are you referring to?

iastor9.sys with status 0xc359

#6 Slammer

Slammer
  • Members
  • 4 posts
  •  
    United States

Posted 16 May 2012 - 04:32 AM

Ok I gave up on backing it up. It's an almost brand new hard drive, so if there are problems with it already, they must be small. And it's too expensive for me to replace even if it were significantly broken.

cdob, I tried disabling all instances of "iastor" and "iastor9" (leaving only iastorV alone, since that's the one that's supposed to be the correct driver) in both ControlSet001 and ControlSet002. Also, msachi is already set to 0 everywhere it appears. Now I'm just getting that really fast BSOD again (same error codes) instead of the screen saying that the iastor9 driver is missing or corrupt.

I looked into how the Windows boot process works a little bit so I could somewhat understand what is going on, and have found that the ControlSet001 is set as the default, and ControlSet002 is set for the lastknowngood (LKG). The weird thing is that the ControlSet001 only has like 5 entries in it, (which is being loaded at normal boot) and ControlSet002 has A LOT more (like it should). I don't know if that tells you guys anything, all it tells me is that something is definitely going wrong. Here's what it looks like:
http://dl.dropbox.co...256/Regedit.JPG

Wonko, that tool looks really promising but I can't really understand what that page is telling me to do with it....

Sorry guys, I can do anything from inside the Windows OS, but I'm pretty much a noob at anything that happens pre-boot. I feel a bit like a fish out of water with this problem. Thanks for putting up with me :) I can tell we're getting close.

#7 cdob

cdob

    Gold Member

  • Expert
  • 1440 posts

Posted 16 May 2012 - 09:33 PM

if there are problems with it already, they must be small. And it's too expensive for me to replace even if it were significantly broken.

Hardware can be the real issue. Half broken hardware cause a BSOD too. A cable can cause issues too.

The weird thing is that the ControlSet001 only has like 5 entries in it

ControlSet001 is havily truncated, reason is unknown. Can be hardware.

And it's a bad idea to resume from hibernate at another machine.
OS dosn't expect a new motherboard after wake up.

Restore file \windows\system32\config\system from a previous back up.

Do you boot from USB 2TB drive or from internal 320GB drive?

#8 Slammer

Slammer
  • Members
  • 4 posts
  •  
    United States

Posted 16 May 2012 - 09:47 PM

I boot from the 2TB USB hard drive (I made a new partition to boot to until I get the old one working again). It works fine, so it's not a cable issue. I guess some of the files in the other partition could be corrupt, but chkdsk doesn't find any problems on it and it appears to be ok.

Sadly, I was stupid and didn't make any backups that I can restore to. Although I could try restoring it using the "system" file on the OS that I'm temporarily booting to now. I assume that would probably get it to boot, but I'm not sure what would happen to all the programs that don't have registry entries for their drivers on this one... I'll try a few more combinations of disabling drivers there and keep that in mind if I can't make any progress that way.

Is the ControlSetxxx entry the only place that the important drivers' locations are stored in? I'm just afraid of creating conflicting entries if I restore a different system file, and there are still faulty entries elsewhere.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users