Jump to content











Photo
* * * * * 1 votes

LiveXP 2012


  • Please log in to reply
17 replies to this topic

#1 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 05 April 2012 - 03:46 PM

Posted Image

File Name: LiveXP 2012
File Submitter: pscEx
File Submitted: 05 Apr 2012
File Updated: 07 Apr 2012
File Category: Projects

This project is a rebirth of the classic LiveXP project.

The classic LiveXP projects runs only on WinBuilder versions 77 RC 2 and 80 Rev 3.

The adapted project runs also on WinBuilder versions 82 and later.

One of the advantages of LiveXP 2012 is the build speed. The build under 82 needs only 40% of the time of the 080 build.

Older versions:
LiveXP-154.zip

Click here to download this file
  • Nuno Brito and Holger like this

#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 05 April 2012 - 03:46 PM

Some additional information:
LiveXP 2012 has been generated by
  • Download and unzip the classic LiveXP into an empty directory
  • Certify the project by 'pscEx'
  • Add PE1_4WB82 script to the project
  • Run PE1_4WB82 script
  • Zip the project and upload
No changes with script selections / options have been done.

PE1_4WB82 control file:
Spoiler


#3 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4135 posts

Posted 06 April 2012 - 06:20 AM

Thanks! Will be downloading. Can go wrong with faster build.

#4 Atari800XL

Atari800XL

    Member

  • Members
  • 74 posts
  •  
    Netherlands

Posted 06 April 2012 - 07:42 AM

Thank you! I'm new to WinBuilder, so far I only made one "Win7 PE SE 20120107" build. Around that time, I also tried an XP build, but it didn't work. As far I can see right now, it might have had something to do with a compatibility issue between LiveXP and the WinBuilder version I used? (As you described in your current LiveXP 2012 version).

Anyway: This version works beautifully!!! so thank you very much!!!

#5 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4135 posts

Posted 06 April 2012 - 08:16 AM

Received two errors.
Attached File  log.rar   650.58KB   373 downloads


WebGet -  [http://download.sysinternals.com/Files/PageDefrag.zip] to directory: [%BaseDir%\Workbench\Common\PageDefrag_File\PageDefrag.zip] HTTP/1.1 403 Forbidden




FileCopy - Failed to copy [%BaseDir%\Temp\LiveXP\Lsi_Logic_Driver_Copy\symmpi.sys] to: [%BaseDir%\Target\LiveXP\I386\System32\Drivers\symmpi.sys]: The system cannot find the file specified.



#6 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 06 April 2012 - 05:03 PM

Received two errors.

My primary intention here is to reanimate LiveXP for WinBuilder 82.
As long as I'm optimizing the result, I do not try to fix issues of individual scripts. But I check whether the issue is perhaps introduced by the 82 version.

Here: The Webget - issue is a broken link. The FileCopy issue I do not have on my system. Maybe a question of source CD. Let's check later.

Pete

EDIT: The FileCopy issue depends on a download issue in the Lsi Logic Driver script. The *.zip files seem to be *.html files. Currently I do not have the time to solve that.

Edited by pscEx, 07 April 2012 - 05:21 PM.
New knowledge


#7 RoyM

RoyM

    Frequent Member

  • .script developer
  • 415 posts
  • Interests:"Booting and Owning".
  •  
    United States

Posted 07 April 2012 - 02:19 AM

I recently had a need for an XP build
so I download LiveXP through winbuilder
and applied your script, "Thank You Very Much Peter"
I'm all set up now for LiveXP and 082


I will be available this weekend, if any
help is needed, I would be glad to provide
assistance, testing, etc.
Just PM me before board goes down.


Thanks Again to Everybody involved.
RoyM

#8 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4135 posts

Posted 07 April 2012 - 02:23 AM

Here: The Webget - issue is a broken link. The FileCopy issue I do not have on my system. Maybe a question of source CD. Let's check later.

Peter

In the build the iso was created and seemed to bootup.
LiveXP 2012.jpg


I dont know what script is causing the Webget error.
The FileCopy file it mentions. Is is necessary for something. If so. How can it be added.

#9 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 07 April 2012 - 05:17 PM

Version 155 is uploaded
  • Removed use of %variables% as macro. This avoids corresponding warnings.
  • Fixed broken URL in JKDefrag.script.
Peter

#10 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 07 April 2012 - 06:24 PM

New Version upladed? :confused1:
The new server is not yet up and running, just the inbetween replacement.
All posts done since Friday will selfdestruct, once the new server goes live!

:cheers:

#11 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 07 April 2012 - 06:43 PM

The different versions are on my server at http://nativeex.exec...P-{version}.zip

I hope that the links will survive ...

Peter :clap:

#12 Nuno Brito

Nuno Brito

    Platinum Member

  • Team Reboot
  • 10441 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 07 April 2012 - 10:28 PM

Hello,

Posts are only lost when the title of window says offline. We will do another db copy before the final transfer.

#13 TheHive

TheHive

    Platinum Member

  • .script developer
  • 4135 posts

Posted 08 April 2012 - 08:38 AM

Suggestions fo updates
I meant to put 82+
1.jpg
2.jpg

The new build built with no errors.

#14 bee4u

bee4u

    Frequent Member

  • Advanced user
  • 172 posts
  •  
    United Kingdom

Posted 17 July 2012 - 03:17 PM

THX man for this update... :1st: :1st: :1st: :clap:
Its so far THE BEST LIVE XP PROJECT....without any errors ,everything worked as smooth and sweet as butter and honey...!!! :1st: :clap:
Keep up the good work...!! :1st:
  • Nuno Brito likes this

#15 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12688 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 17 July 2012 - 03:29 PM

Thanks for the flowers!
Sometimes some developer needs some recognition.

(And what about the 'Like this' in the first post?)

Peter :cheers:
  • bee4u likes this

#16 bee4u

bee4u

    Frequent Member

  • Advanced user
  • 172 posts
  •  
    United Kingdom

Posted 17 July 2012 - 03:52 PM

Yes


Thanks for the flowers!
Sometimes some developer needs some recognition.

(And what about the 'Like this' in the first post?)

Peter :cheers:


Yes it deserve to be in THE FIRST POST.... :cheerleader: :1st: :1st: :1st: :1st: :clap:

#17 JanuszChmiel

JanuszChmiel

    Frequent Member

  • Advanced user
  • 201 posts
  •  
    Czech_ Republic

Posted 21 July 2013 - 10:01 AM

Dear liveXP 155 developers.

I have tried Yours perfect project, Winbuilder can really build it very fast.

I have one plea to You.

How complex would be to add NVDA support also to this project?

I have tried to use sound drivers and i have tried to start NVDA from USB stick, but it can not work.

Newest MULTIPE live .iso image can not work with Toshiba notebook, some think is crashing. So my onlyone chance is to modiffi Live XP 155 project to support sound and NVDA.

My most complex task is to force live PE to run NVDA automatically at startup.

There is strange issue related to memory allocation.

Peter, do You think, that You would at this?

This project is supporting SATA hard disks reliably, even new USB chips.

Amalux live XP can not work for me, because there is some issues with detection of USB chip on The Toshiba satellite notebook, so USB audio sound cart can not work.

 

I think, that it would be very nice to have one Live XP project, which would support NVDA fully automatically, for now, it would require only to copy drivers folder with USB audio related Windows Xp driver files.

Any help will be strongly welcomed.

Thank You very much.



#18 JanuszChmiel

JanuszChmiel

    Frequent Member

  • Advanced user
  • 201 posts
  •  
    Czech_ Republic

Posted 21 July 2013 - 10:02 AM

Dear liveXP 155 developers.

I have tried Yours perfect project, Winbuilder can really build it very fast.

I have one plea to You.

How complex would be to add NVDA support also to this project?

I have tried to use sound drivers and i have tried to start NVDA from USB stick, but it can not work.

Newest MULTIPE live .iso image can not work with Toshiba notebook, some think is crashing. So my onlyone chance is to modiffi Live XP 155 project to support sound and NVDA.

My most complex task is to force live PE to run NVDA automatically at startup.

There is strange issue related to memory allocation.

Peter, do You think, that You would at this?

This project is supporting SATA hard disks reliably, even new USB chips.

Amalux live XP can not work for me, because there is some issues with detection of USB chip on The Toshiba satellite notebook, so USB audio sound cart can not work.

 

I think, that it would be very nice to have one Live XP project, which would support NVDA fully automatically, for now, it would require only to copy drivers folder with USB audio related Windows Xp driver files.

Any help will be strongly welcomed.

Thank You very much.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users