Jump to content

- - - - -

32 bit vs 64 bit conflict?

booting architecture glitch

  • Please log in to reply
No replies to this topic

#1 Marcos Marin

Marcos Marin
  • Members
  • 1 posts

Posted 06 March 2012 - 02:28 PM

Hello unetbootin community,

I've a quick question but I elaborate below:

If I create a unetbootin USB drive under a 32bit system, would a 64bit BIOS have trouble booting it?

Curiously, this might even relate to some of the problems other people has being reporting here.

Here is why, I created such a drive originally with a 32bit distro, then modified it to ALSO include a 64bit distro. I wouldn't even imagine any surprises awaited since bootable dvds/cds etc don't need any different specifications for working in either system(right?). I realize now that unetbootin process MIGHT need it.

The drive boots fine under the 32bit box, loads unetbootin, shows the menus normally including my added entries, even loads BOTH distros normally! Of course the 64bit distro complains it can't continue on a 32bit system BUT it loads the image just as expected (otherwise it could not even complain =))

Unfortunately this mobo bios is EXTREMELY unhelpful on error messages (no message at all!), I don't think there would be any options to turn verbose on =/ but I tried booting another hd which has no OS installed and it freezes just as with the USB, so the error might be similar. (and maybe it is not an actual freeze, I think I can reset it through the keyboard, let me know if this info is important for diagnosis)

Also, I tried all 6 usb ports and same thing happens. On the specs screen, after bios boot, it shows "USB mass storage" together with both HDDs on each case, and vanishes if I unplug it (so it is detected and all)

After all that, I'm out of options, I can only conclude that yes, I would need to use unetbootin 64bit version, right? Is there maybe a tweak I could do to make it work? Also this might be the cause of some of the problems other people are reporting, if they are creating the drive under one system and trying to use it in another.

Thanks for any help.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users