Jump to content











Photo
- - - - -

What's up with mkisofs?


  • Please log in to reply
1 reply to this topic

#1 Krum

Krum

    Newbie

  • Members
  • 11 posts
  •  
    United States

Posted 26 February 2012 - 04:47 AM

Using ubu 10 I invoked mkisofs at the commandline; it said that it is subsumed by 'genisoimage' , and the options are the same. I tried:
genisoimage -b /root/t.img -o an.iso /root/tuts, where t.img is a 2.88 img(bootable) image and tuts contained the files to burn i.e.
an eltorito emulation bootable cd. The genisoimage had no trouble finding the /root/tuts, but at the end said:
"uh oh! I cannot find bootable image '/root/t.img". The man says: " you must specify path to the img as relative to the source path to mkisofs"
Finding that incomprehensible, I simply copied both t.img and tuts into /usr/bin, where genisoimage/mkisofs are located. I then cd'ed to
/usr/bin at the commandline and did: genisoimage -b t.img -o an.iso tuts; same result; found tuts, but "uhoh!...", not the img! I also tried
another .img file with same result. What am I doing wrong? Krum.

#2 cdob

cdob

    Gold Member

  • Expert
  • 1449 posts

Posted 26 February 2012 - 07:36 AM

Does exist a file /root/tuts/t.img ?

Try mkisofs -b t.img -o an.iso /root/tuts
  • Nuno Brito likes this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users