Jump to content











Photo
- - - - -

Cannot boot from big USB HDD

usb hdd bios bootable

  • Please log in to reply
9 replies to this topic

#1 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 18 February 2012 - 08:05 PM

Hello all!

I am trying to boot from an usb hdd "Silicon Power Armor a80 500GB" but it is not seen as bootable from BIOS.

What I have tryied:
- to plug in both USB 2.0 and USB 3.0 ports on 2 different machines (desktop on Gigabyte GA-X58-UD3R rev 2 motherboard, and an Dell N5110 laptop).
- mount as physical disk in VirtualBox
- different partition sizes and combinations: 4GB single partition, 8GB, several partitions, etc.
- windows bootloader (both NTLDR and BOOTMGR) and Grub4dos, installed in different combinations
- after each try - wiped first ~10MB of HDD (dd command from Linux OS)
- all BIOS'es, including VirtualBox are able to boot from USB - tested with an 4GB Transcend flash disk (Grub4dos on NTFS).
- waiting until drive spins-on in bios, then reset the computer (ctrl+alt+del from bios)

The HDD works perfectly from both Windows and Linux OSes, but is not bootable in any way.

Have someone encountered such situations with external USB Hard Disk Drives? Maybe some has experience with this particular model?

On manufacturer site found an firmware update utility ("MS1009033-A80FWUpdateTool_v01.zip") - but it doesn't see my HDD.

Please share your experience in troubleshooting usb hdd booting, what else I can try to make it detectable in BIOS?
Until then I assume that it is not bootable :(

PS: sorry for bad english - it is not my native language.

#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13745 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 18 February 2012 - 08:33 PM

It may be connected with the "green" nature of the hard disk inside the case.
I have seen reports of "green" disks simply not being "fast enough" to get listed in the BIOS.
If, as I presume, the thingy is new, you cannot open the case to see which particular drive is in it unless you are going to forfait the device warranty, maybe - even if through the USB adapter - some data is shown about it?

You could try PLoP that may allow for giving the device enough time (if it works on your specific hardware):
http://www.plop.at/e...otmanagers.html

:cheers:
Wonko

#3 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 18 February 2012 - 08:55 PM

Thanks for reply.

Sysinfo tools are showing that the physical HDD is "TOSHIBA MK5059GSXP (Z1MKC0E8T)" (specs: http://storage.toshi...p?productid=382 ).
I don't have experience with PLoP boot manager, but will try to play with it and post here the results.

not being "fast enough" to get listed in the BIOS.

I have tried to enter to BIOS with connected HDD, then reboot (in hope that it will spin-on quicker on second boot) - but, again, bios doesn't see it as bootable.

#4 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 18 February 2012 - 09:37 PM

By mount as physical disk in VirtualBox - do you mean you have tried to boot from it in VirtualBox?

Have you tried QEMU (install QEMU Manager or RMPrepUSB and hit F11)?
Can you format it as NTFS and type fsutil fsinfo ntfsinfo x: where X: is usb drive letter and post result?
P.S. Or type wmic DISKDRIVE get bytespersector, caption and report output

#5 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 19 February 2012 - 07:35 AM

Here are the results:

1. Installed PLoP (v5.0.14) on usb stick and loaded via Grub4dos - but it doesn't see my HDD :(

2. QEMU fails to boot with error "Boot failed: not a bootable disk" (btw QEMU doesn't start with default RAM size suggested by RMPrepUSB - 1280MB, need to specify manually 512MB)

3. Drive information results:

hdd currently has only one 30GB NTFS partition:


C:\Windows\system32>fsutil fsinfo ntfsinfo h:

NTFS Volume Serial Number :	   0xb642588842584eed

Version :						 3.1

Number Sectors :				  0x000000000077ffff

Total Clusters :				  0x000000000077ffff

Free Clusters  :				  0x00000000006f1028

Total Reserved :				  0x0000000000000000

Bytes Per Sector  :			   4096

Bytes Per Cluster :			   4096

Bytes Per FileRecord Segment	: 4096

Clusters Per FileRecord Segment : 1

Mft Valid Data Length :		   0x0000000000100000

Mft Start Lcn  :				  0x00000000000c0000

Mft2 Start Lcn :				  0x0000000000000002

Mft Zone Start :				  0x00000000000c0100

Mft Zone End   :				  0x00000000000cc900

RM Identifier:		17B1F757-5A39-11E1-9855-001BDC004D89



C:\Windows\system32>wmic DISKDRIVE get bytespersector, caption

BytesPerSector  Caption

512			 ST9750423AS ATA Device

				Generic- Multi-Card USB Device

4096			PHD 3.0 Silicon-Power USB Device


"PHD 3.0 Silicon-Power USB Device" - this is my external hdd.

4. RMPrepUSB v2.1.630 gives warning "very large device" then fails with the error "Error accessing sector 0 on drive 2" / "error 6 operation failed returned by RMPARTUSB"

I started it from Windows 7 x64 OS, on a dell laptop (N5110, intel HM67 platform).

I suppose the issue is in USB-to-SATA controller from the external hdd, but did not found yet any information about this.

#6 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 19 February 2012 - 09:21 AM

The problem has been solved!

WARNING! these oprations may void warranty of the device, please read all post before trying to reproduce!

Here is what I did:

1. Disassembled the HDD and found it's usb controller name: ASMEDIA 1051 (USB3 to SATA bridge)
2. Downloaded firmware and flash tool from here: http://www.station-d...age/asmedia.htm
Under category "Asmedia ASM 1051 USB3/SATA Controller Firmware" (it is the last on page):
- Download firmware "Version 101026.00.68 Pour Windows Xp/Vista/7 32/64bits" (with comment "Support 3TB HDD").
- Download flash tool: "Version 1.07 Pour Windows Xp/Vista/7 32/64bits"
3. Run the downloaded MPTool
4. Check that device is detected and click the button "Unlock MP Tool" -> as password enter "asmedia" (without quotes).
5. Select the downloaded flash bin (button "FW Browse", then select file "101026_00_68_00.bin")
6. Press "Start"
7. After successful flashing - reconnected the device to computer (btw this has broken the partition table).

After these operations, I have created an 30GB NTFS primary partition, installed Grub4Dos via RMPrepUSB and the drive has been recognized successfuly as boot device.
Tested platforms: Desktop on intel x58 chipset (Award BIOS), laptop, VirtualBox machine (connected as raw VMDK drive), QEMU (grub menu shows up).

Encountered problems: I didn't uncheck the "Update configuration" checkbox in MPTool.exe - so this has rewritten all device names, and it has been detected by OS as "0123456789012345678901234567890123456789" :(
unfortunately, I didn't saved its original manufacturer name, device name and serial number - so this was lost. I have repeated the firmware update process to update the data - used serial number from device package, as manufacturer name "PHD 3.0 Silicon-Power USB Device" and as device name "Silicon Power Armor A80" - which looks much cooler in USB devices list in windows :)

I suppose warranty was lost, but the device now works correctly instead ;)
Will check how it works with big data volumes, and report here if I will encouter any issues.

#7 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 19 February 2012 - 11:27 AM

I think the issue was 4096 byte sectors (raw 4K mode). If you repeat the fsutil command now it should report 512 bytes.
Install hotfix KB982018 first so it reports Bytes per Physical Sector.





Bytes Per Sector  :               512   << this means the disk is in Advanced Format 512e mode



Bytes Per Physical Sector :       4096  << this means you have a 4K disk


#8 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 19 February 2012 - 12:26 PM

I haven't done low-level formatting, so not sure if this was caused by sector size.
Anyways, the problem is now solved.


C:\Windows\system32>fsutil fsinfo ntfsinfo h:

NTFS Volume Serial Number :	   0xca9c93099c92eee7

Version :						 3.1

Number Sectors :				  0x0000000003bfffff

Total Clusters :				  0x0000000003bfffff

Free Clusters  :				  0x00000000038cc021

Total Reserved :				  0x0000000000000000

Bytes Per Sector  :			   512

Bytes Per Physical Sector :	   <Not Supported>

Bytes Per Cluster :			   512

Bytes Per FileRecord Segment	: 1024

Clusters Per FileRecord Segment : 2

Mft Valid Data Length :		   0x0000000000040000

Mft Start Lcn  :				  0x0000000000600000

Mft2 Start Lcn :				  0x0000000000000010

Mft Zone Start :				  0x0000000000600200

Mft Zone End   :				  0x0000000000664200

RM Identifier:		788B113B-5ACD-11E1-9409-001BDC004D89


It is strange that after installing the hotfix - it still cannot report the physical sector size. (I am using Windows 7 x64 without SP1 - maybe this is the cause).

#9 karyonix

karyonix

    Frequent Member

  • Advanced user
  • 453 posts
  •  
    Thailand

Posted 19 February 2012 - 12:41 PM

I think you should use 4096-byte or larger cluster in this disk for best performance. Also make sure the partition start position is 4096-byte aligned.

#10 artiom

artiom
  • Members
  • 6 posts
  •  
    Moldova

Posted 19 February 2012 - 12:55 PM

I have split the disk in 2 partitions using diskpart, nothing special was used for partition aligning:
- Partition 1: 30GB, 512 byte per cluster, starting at offset 1024KB, primary, active
- Partition 2: 435GB, 4096 byte per cluster, starting at offset 30GB, primary

partition 1 will be used only for booting different OS'es (grub4dos - tested to load an WinPE build, Windows XP recovery console, latest UBCD, PLoP and latest Kubuntu Live CD)
partition 2 will be used for backup and data storage tasks.





Also tagged with one or more of these keywords: usb hdd, bios, bootable

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users