Jump to content











Photo
- - - - -

[BUILD] cmd.exe cannot be copied to ...


  • This topic is locked This topic is locked
1 reply to this topic

#1 deajan

deajan
  • Members
  • 3 posts
  •  
    France

Posted 22 December 2011 - 05:17 PM

Hello,

I've spent some time trying to get why Winbuilder did not work on my nice Windows 2008 R2 Server which our admin staff uses as developpment platform.
I had an error on BUILD stage RETRIEVE TOOLS telling that cmd.exe cannot be copied to [your project location].

While reading logs i found out that my %WINDOWSDIR% variable pointed to c:usersadministratorWINDOWS, folder that obviously exists and is a chrooted WINDOWS folder when using terminal server.

Once i found this out, i figured out what to do to run WinBuilder on my Terminal Server, here's the script:



@echo off

:: Getting current user session in install modus

change user /install

:: Loading Winbuilder

start /wait winbuilder.exe

:: Getting current user session back in execute modus

change user /execute



Hope it helps :)

PS: if you ask why i run winbuilder on a terminal server, there's a simple reason: The server is our IT staff server.

Edited by deajan, 22 December 2011 - 05:18 PM.

  • Nuno Brito likes this

#2 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10547 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 24 February 2012 - 10:43 AM

deajan, thank you for sharing this tip.

I hope it helps to make project developers more aware of this limitation. With some luck we might see this nuisance better handled in the future.

As for the previous posts, they were made non-visible to members as they are not related to this topic.

With my best regards,
Nuno Brito




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users