Jump to content











Photo
- - - - -

Install fails


  • Please log in to reply
3 replies to this topic

#1 RobG

RobG
  • Members
  • 2 posts
  •  
    United States

Posted 03 November 2011 - 05:59 PM

I'm having an issue getting ImDisk installed. Running imdiskinst.exe as administrator, I get a message telling me "This will install ImDisk Virtual.... Continue? " I click Yes, then a dialog box with a progress bar pops up and goes away, then a dialog with the message "Setup Failed!" Click Ok and it goes away. Are there any log files to find the issue or is there another way to install it so I can figure out what is failing?

This is on Windows 7 pro x64.

Thanks,
Rob

#2 Olof Lagerkvist

Olof Lagerkvist

    Gold Member

  • Developer
  • 1,053 posts
  • Location:Borås, Sweden
  •  
    Sweden

Posted 04 November 2011 - 12:48 AM

I would suggest that you try two things. First, try to right-click on the setup package and select "Run as administrator". If that does not help, try to extract the setup package (using 7-zip) to a temporary directory, and in there right-click on imdisk.inf and select "Install". This will show you more detailed error messages in case something still goes wrong.

#3 RobG

RobG
  • Members
  • 2 posts
  •  
    United States

Posted 04 November 2011 - 05:02 AM

Thanks for the suggestions. I had already tried the Run as administrator, but that failed. I just tried extracting the package and installing the inf. This worked. Thank you.

#4 Thracx

Thracx

    Newbie

  • Members
  • 18 posts
  •  
    United States

Posted 20 December 2011 - 04:48 PM

I have also had problems with the latest ImDisk installer, at both my home and work machines. It wasn't worth creating a new thread for since I have workarounds that are good enough for me, but I thought I'd document my troubles in case someone else searches the forums for answers.

For my work machine, I manually unmounted all my RamDisks then tried the installer - error. I uninstalled the previous version (and stopped the services), which worked, but then the installer still failed (only the inf failed - but the files actually got copied into the System32 folder and the installer reported success). Not quite sure about this, but after a reboot, the installer worked and the ImDisk services & Control Panel applet are present.

For my home machine, I was unable to get the installer to work - and in fact, I wasn't able to get the uninstaller to work! My original thought was that my TEMP location is on the (no longer active) RamDisk, but fixing that didn't seem to matter. My solution, sadly, was to simply copy the appropriate files into System32, replacing the old (v1.4.2?) files. Everything seems to work fine, although I think I still cannot install/uninstall ImDisk (through cpl feature or manually via inf). Not sure what's wrong, but my ramdisk is running again and it's using the newer files so I'm happy.

Edited by Thracx, 20 December 2011 - 04:49 PM.