Jump to content











Photo

WinXP Set up Crushing


  • Please log in to reply
7 replies to this topic

#1 al-jo72

al-jo72

    Member

  • Members
  • 37 posts
  •  
    United States

Posted 31 October 2011 - 04:56 PM

Hello there. I am having problem with Windows XP set up using GRUB4DOS. Here's my winsetup.lst (edited):


title Windows XP SP3\nWindows XP Professional with Service Pack 3
find --set-root /ISO/WINSETUP/WINXPPROSP3.iso
map /ISO/WINSETUP/WINXPPROSP3.iso (hd32)
map --hook
chainloader (hd32)
title \n
root

The problem is when it's time for the XP ISO starts the menu were you will install (XP) or repair your PC, the BSOD appears. *** STOP 0x0000007B (0x7C79524,0xC0000034,0X00000000,0X00000000).

I tried booting my (USB thinking that QEMU is having a problem) to a PC but the same thing happened. But, when I used the XP CD itself it run ok no BSOD. I used Roxio to create an ISO of XP. Could that be the problem? Any info is very much appreciated. Thank you.

#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 31 October 2011 - 07:14 PM

Well, you missed the whole (or most of) the plot. :w00t:

Go back to square #1:
http://reboot.pro/8944/
in other words what you attempted is IMPOSSIBLE without a RAMDISK driver. :frusty:

Then, go here:
http://www.msfn.org/...ndows-from-usb/

Currently there is a nice app:
http://www.msfn.org/...omusb-with-gui/
and a couple "manual" tutorials:
http://www.msfn.org/...aded-iso-image/
http://www.msfn.org/...rom-a-iso-file/

that will allow you to do that using firadisk driver.

Please also note how you posted your question/request for help in:
http://reboot.pro/forum/114/
Grub4dos
Tutorials

Next time you start a new thread, please ask yourself:

Am I going to post a Tutorial?

If your answer is yes, then post it in Tutorials. section, otherwise post it like all other people do in
http://reboot.pro/forum/66/
Grub4dos

More generally, stickies (pinned topics) are there in the hope that people will have a look at them before posting.

Wonko

#3 al-jo72

al-jo72

    Member

  • Members
  • 37 posts
  •  
    United States

Posted 31 October 2011 - 09:13 PM

Thanks for your reply.


This is the original winsetup.lst for the XP:

title title Windows XP SP3nWindows XP Professional with Service Pack 3

find --set-root /ISO/WINSETUP/WINXPPROSP3.iso
map /ISO/WINSETUP/WINXPPROSP3.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)



My apologies. Thank you.
The reason I modified it because it takes too long for it too start to reach the 320M. I didn't know that you need a ramdisk driver :1st:
Ok, how can I make the load faster?

#4 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 November 2011 - 09:15 AM

Thanks for your reply.


This is the original winsetup.lst for the XP:

The reason I modified it because it takes too long for it too start to reach the 320M. I didn't know that you need a ramdisk driver :1st:
Ok, how can I make the load faster?

Well, IF this "original" one works :dubbio: (I mean not from CD, but from USB), it means that you already have firadisk or a similar driver inside the .iso.

What you modified was just removing the hard disk swap and changing (0xFF) to (hd32) WHY? :w00t:, it won't change anything.

Due to the current problems with my crystal ball, I have no idea what you are up to, maybe if you re-start from the beginning actually explaining what you want to do, what the heck is the 320M, etc., etc. someone might be able to help you.

:cheers:
Wonko

#5 al-jo72

al-jo72

    Member

  • Members
  • 37 posts
  •  
    United States

Posted 01 November 2011 - 03:18 PM

Well, IF this "original" one works :dubbio: (I mean not from CD, but from USB), it means that you already have firadisk or a similar driver inside the .iso.

Yeah the original works using the USB but I forgot to mention that I replaced the Win98.ISO with the one straight from the CD WINXPPROSP3.iso :cheerleader:
When I checked the original ISO there is no firadisk inside.

What you modified was just removing the hard disk swap and changing (0xFF) to (hd32) WHY? :w00t:, it won't change anything.

I thought I will load faster if Idid Disk Mapping.

The 320M that's what I see when I did the original version. The Windows set up will starts when the count up reach this number [320/320M].
What I want to happen when I choose SP3 from the menu it will load right away without going to this:
[0/320M] then [2/320M] untill [320/320].

Is there other way? Thank you.

#6 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 November 2011 - 05:26 PM

I guess it is of no use. :(

What has a "Win98.iso" (which I presume is a .iso containing some form of Windows 98) has to do with WINXPPROSP3.iso (a .iso containing a SETUP of Windows XP)?

Different .iso's are DIFFERENT (and they may need DIFFERENT settings (this is basically what I tried to tell you).

But there is a language barrier that is evidently insurmountable.

But I am tough, so I will try again.

I am NOT near you.
I cannot see what you see on your screen.
I cannot know what you did before.
I cannot know from WHAT (the heck) "original" you started modifying.

AGAIN, maybe if you DESCRIBE what you did EXACTLY, with as much DETAIL as possible and state WHAT "original" it is, someone may be able to help you.

Every piece of info that you do not reveal, or that you misrepresent, will make the possibility of receiving some useful assistance less probable.

http://homepages.tes...ard-litany.html

You were ALREADY given two different approaches to solve the problem, one with memory mapping, one with direct mapping, besides the link to WinsetupfromUSB.


:cheers:
Wonko

#7 al-jo72

al-jo72

    Member

  • Members
  • 37 posts
  •  
    United States

Posted 01 November 2011 - 06:17 PM

I guess it cannot be helped. This is the original winsetup.lst that I was using before:

default 5
debug 0
splashimage=/boot/grub_face.xpm.gz
write (md)0x220+1 !BATnecho -n -P:0000 $[0107] mOBSCENE21's MULTI-BOOT USB#0 && initscript (md)0x220+1
title n
root
title ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿n
root
title ³ +++ Windows Installation Media +++ ³n
root
title ÀÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÙn
root
title n
root
title ... Back to Main Menun
configfile /menu.lst
title n
root
title n
root
title Windows 98 SE UKnWindows '98 Second Edition - English. Product key not required.
find --set-root /ISO/WINSETUP/W98SEUK.iso
map /ISO/WINSETUP/W98SEUK.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)
title Windows 98 SE NLnWindows '98 Second Edition - Dutch. Product key not required.
find --set-root /ISO/WINSETUP/W98SENL.iso
map /ISO/WINSETUP/W98SENL.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)
title n
root
title Windows XP SP3 VL UKnWindows XP Professional with Service Pack 3 integrated - Volume License - English. Product key not required. Use "AntiWAT" to make it genuine (USB/activators/WindowsXP).
find --set-root /ISO/WINSETUP/XPSP3UK.iso
map --mem /ISO/DOSFLOP/XPINSTUK.IMA (fd0)
map /ISO/WINSETUP/XPSP3UK.iso (0xfe)
map --hook
map --mem (0xfe)+182759 (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)/I386/SETUPLDR.BIN
title Windows XP SP3 VL NLnWindows XP Professional with Service Pack 3 integrated - Volume License - Dutch. Product key not required. Use "AntiWAT" to make it genuine (USB/activators/WindowsXP).
find --set-root /ISO/WINSETUP/XPSP3NL.iso
map --mem /ISO/DOSFLOP/XPINSTNL.IMA (fd0)
map /ISO/WINSETUP/XPSP3NL.iso (0xfe)
map --hook
map --mem (0xfe)+180174 (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)/I386/SETUPLDR.BIN
title n
root
title Windows 7 SP1-u AIO x86/x64 UK/NLnWindows 7 with Service Pack 1-u integrated - Starter / Home Basic / Home Premium / Professional / Enterprise / Ultimate - 32-bits/64-bits - English & Dutch. Product key not required during installation. Use "Windows Loader" or "mini-KMS Activator" (Enterprise only) to make it genuine (USB/activators/Windows7).
chainloader /boot/bootmgr

And this the one that I am using and try to load the Windows set up which is having a BSOD from my previous post:

default 5
debug 0
splashimage=/boot/grub_face.xpm.gz
write (md)0x220+1 !BATnecho -n -P:0000 $[0107] KAME HAME HA!!! MULTI-BOOT USB#0 && initscript (md)0x220+1
title n
root
title ÚÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄ¿n
root
title ³ +++ Windows Installation Media +++ ³n
root
title ÀÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÄÙn
root
title n
root
title ... Back to Main Menun
configfile /menu.lst
title n
root
title n
root
title Windows XP SP3nWindows XP Professional with Service Pack 3
find --set-root /ISO/WINSETUP/WINXPPROSP3.iso
map /ISO/WINSETUP/WINXPPROSP3.iso (hd32)
map --hook
chainloader (hd32)
title n
root
title Windows 7 SP1-u AIO x86/x64 UK/NLnWindows 7 with Service Pack 1-u integrated - Starter / Home Basic / Home Premium / Professional / Enterprise / Ultimate - 32-bits/64-bits - English & Dutch. Product key not required during installation. Use "Windows Loader" or "mini-KMS Activator" (Enterprise only) to make it genuine (USB/activators/Windows7).
chainloader /boot/bootmgr


So basically I removed:

title Windows 98 SE UKnWindows '98 Second Edition - English. Product key not required.
find --set-root /ISO/WINSETUP/W98SEUK.iso
map /ISO/WINSETUP/W98SEUK.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)
title Windows 98 SE NLnWindows '98 Second Edition - Dutch. Product key not required.
find --set-root /ISO/WINSETUP/W98SENL.iso
map /ISO/WINSETUP/W98SENL.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)
title n
root
title Windows XP SP3 VL UKnWindows XP Professional with Service Pack 3 integrated - Volume License - English. Product key not required. Use "AntiWAT" to make it genuine (USB/activators/WindowsXP).
find --set-root /ISO/WINSETUP/XPSP3UK.iso
map --mem /ISO/DOSFLOP/XPINSTUK.IMA (fd0)
map /ISO/WINSETUP/XPSP3UK.iso (0xfe)
map --hook
map --mem (0xfe)+182759 (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (0xff)/I386/SETUPLDR.BIN

and replace it with this:

title Windows XP SP3nWindows XP Professional with Service Pack 3
find --set-root /ISO/WINSETUP/WINXPPROSP3.iso
map /ISO/WINSETUP/WINXPPROSP3.iso (hd32)
map --hook
chainloader (hd32)
title n
root

But it's experiencing BSOD issues as you already know and you already told me the reason why.

Basically, you are telling me to build a seperate .lst and some required drivers or files if I want to use WINXPPROSP3.iso for direct mapping?
If I were to use memory mapping, how can I make it to load fast like using a physical CD? I know I am hard to understand and I thank you for your patience :1st:

I would like to post a pic but don't see any attachment selection.

#8 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 13749 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 01 November 2011 - 07:27 PM

I see. :smiling9:

WAREZ. :ph34r:

I won't help with them :(, but good luck anyway. :)


:cheers:
Wonko




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users