Jump to content











Photo
* * * * * 1 votes

[solved] I Can't use WinBuilder


  • Please log in to reply
33 replies to this topic

#26 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 24 August 2011 - 03:01 AM

I have a Question: What does the AutoKeyboard script? It's on Amalux LiveXP build

Hey, forgot all about that one, why not give it a try? Seems self-explanatory...

Posted Image
  • enciktangankidal likes this

#27 Michele13

Michele13

    Frequent Member

  • Tutorial Writer
  • 167 posts
  •  
    Italy

Posted 24 August 2011 - 09:44 AM

Hey, forgot all about that one, why not give it a try? Seems self-explanatory...

Posted Image


in the lightweight project it is disabled. should I enable it? Now I'll install the big project that one that is more complete (and that has auto keyboard enabled) :)
Homeware if you want to build a keyboard switcher you can read the keyboard.inf file that there's on the BartPE builder. You can convert it easily. Now I'll past the code here :)


; PE Builder v3 plug-in INF file to change the keyboard layout

;

; keyboard.inf

; Created by Boris Mebarek

[Version]

Signature= "$Windows NT$"

[PEBuilder]

Name="Keyboard Layout (read PluginHelp)"

Enable=1

Help="keyboard.htm"

[Default.AddReg]

0x0, "Keyboard Layout"

0x0, "Keyboard Layout\Preload"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Czech

; 0x1, "Keyboard Layout\Preload", "1", "00000405"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Danish

; 0x1, "Keyboard Layout\Preload", "1", "00000406"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Dutch (Standard)

; 0x1, "Keyboard Layout\Preload", "1", "00000413"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: English (United States)

; 0x1, "Keyboard Layout\Preload", "1", "00000409"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: English (United Kingdom)

; 0x1, "Keyboard Layout\Preload", "1", "00000809"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Finnish

; 0x1, "Keyboard Layout\Preload", "1", "0000040B"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: French (Standard)

; 0x1, "Keyboard Layout\Preload", "1", "0000040C"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: French (Belgian)

; 0x1, "Keyboard Layout\Preload", "1", "0000080C"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: French (Swiss)

; 0x1, "Keyboard Layout\Preload", "1", "0000100C"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: French (Canadian)

; 0x1, "Keyboard Layout\Preload", "1", "00000C0C"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: German (Standard)

; 0x1, "Keyboard Layout\Preload", "1", "00000407"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: German (Swiss)

; 0x1, "Keyboard Layout\Preload", "1", "00000807"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Hungarian

; 0x1, "Keyboard Layout\Preload", "1", "0000040E"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Icelandic

; 0x1, "Keyboard Layout\Preload", "1", "0000040F"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Italian (Standard)

; 0x1, "Keyboard Layout\Preload", "1", "00000410"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Norwegian (Bokmal)

; 0x1, "Keyboard Layout\Preload", "1", "00000414"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Polish

; 0x1, "Keyboard Layout\Preload", "1", "00000415"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Portuguese (Portugal)

; 0x1, "Keyboard Layout\Preload", "1", "00000816"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Portuguese (Brazil)

; 0x1, "Keyboard Layout\Preload", "1", "00000416"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Russian

; 0x1, "Keyboard Layout\Preload", "1", "00000419"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Slovak

; 0x1, "Keyboard Layout\Preload", "1", "0000041B"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Slovenian

; 0x1, "Keyboard Layout\Preload", "1", "00000424"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Spanish (Mexican)

; 0x1, "Keyboard Layout\Preload", "1", "0000080A"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Spanish (Traditional Sort)

; 0x1, "Keyboard Layout\Preload", "1", "0000040A"

; Remove the semicolon at the beginning of the following line to set the default keyboard to: Swedish

; 0x1, "Keyboard Layout\Preload", "1", "0000041D"

[SourceDisksFiles]

keyboard.exe=2,,1

KBDBE.DLL=2

KBDUK.DLL=2

KBDCZ.DLL=2

KBDDA.DLL=2

KBDNE.DLL=2

KBDFI.DLL=2

KBDFR.DLL=2

KBDGR.DLL=2

KBDHU.DLL=2

KBDIC.DLL=2

KBDIT.DLL=2

KBDNO.DLL=2

KBDPL.DLL=2

KBDPO.DLL=2

KBDRU.DLL=2

KBDSL.DLL=2

KBDSP.DLL=2

KBDSW.DLL=2

KBDSF.DLL=2

KBDSG.DLL=2

KBDUS.DLL=2

KBDBR.DLL=2

KBDLA.DLL=2

KBDFC.DLL=2

KBDCR.DLL=2

[SetupReg.AddReg]

0x0, "ControlSet001\Control\Keyboard Layout"

0x0, "ControlSet001\Control\Keyboard Layout\DosKeybCodes"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000080C", "be"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000809", "uk"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000405", "cz"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000406", "dk"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000413", "nl"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000040B", "su"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000040C", "fr"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000407", "gr"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000040E", "hu"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000040F", "is"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000410", "it"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000414", "no"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000415", "pl"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000816", "po"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000419", "ru"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000041B", "sl"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000040A", "sp"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000041D", "sv"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000100C", "sf"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000807", "sg"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000409", "us"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000416", "br"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "0000080A", "la"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000C0C", "cf"

0x1, "ControlSet001\Control\Keyboard Layout\DosKeybCodes", "00000424", "yu"

0x0, "ControlSet001\Control\Keyboard Layouts"

0x0, "ControlSet001\Control\Keyboard Layouts\0000080C"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080C", "Layout Text", "French (Belgian)"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080C", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5002"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080C", "Layout File", "KBDBE.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000809"

0x1, "ControlSet001\Control\Keyboard Layouts\00000809", "Layout Text", "English (United Kingdom)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000809", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5025"

0x1, "ControlSet001\Control\Keyboard Layouts\00000809", "Layout File", "KBDUK.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000405"

0x1, "ControlSet001\Control\Keyboard Layouts\00000405", "Layout Text", "Czech"

0x1, "ControlSet001\Control\Keyboard Layouts\00000405", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5031"

0x1, "ControlSet001\Control\Keyboard Layouts\00000405", "Layout File", "KBDCZ.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000406"

0x1, "ControlSet001\Control\Keyboard Layouts\00000406", "Layout Text", "Danish"

0x1, "ControlSet001\Control\Keyboard Layouts\00000406", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5007"

0x1, "ControlSet001\Control\Keyboard Layouts\00000406", "Layout File", "KBDDA.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000413"

0x1, "ControlSet001\Control\Keyboard Layouts\00000413", "Layout Text", "Dutch (Standard)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000413", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5008"

0x1, "ControlSet001\Control\Keyboard Layouts\00000413", "Layout File", "KBDNE.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000040B"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040B", "Layout Text", "Finnish"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040B", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5009"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040B", "Layout File", "KBDFI.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000040C"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040C", "Layout Text", "French (Standard)"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040C", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5010"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040C", "Layout File", "KBDFR.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000407"

0x1, "ControlSet001\Control\Keyboard Layouts\00000407", "Layout Text", "German (Standard)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000407", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5011"

0x1, "ControlSet001\Control\Keyboard Layouts\00000407", "Layout File", "KBDGR.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000040E"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040E", "Layout Text", "Hungarian"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040E", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5033"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040E", "Layout File", "KBDHU.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000040F"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040F", "Layout Text", "Icelandic"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040F", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5013"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040F", "Layout File", "KBDIC.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000410"

0x1, "ControlSet001\Control\Keyboard Layouts\00000410", "Layout Text", "Italian (Standard)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000410", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5015"

0x1, "ControlSet001\Control\Keyboard Layouts\00000410", "Layout File", "KBDIT.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000414"

0x1, "ControlSet001\Control\Keyboard Layouts\00000414", "Layout Text", "Norwegian (Bokmal)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000414", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5018"

0x1, "ControlSet001\Control\Keyboard Layouts\00000414", "Layout File", "KBDNO.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000415"

0x1, "ControlSet001\Control\Keyboard Layouts\00000415", "Layout Text", "Polish"

0x1, "ControlSet001\Control\Keyboard Layouts\00000415", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5035"

0x1, "ControlSet001\Control\Keyboard Layouts\00000415", "Layout File", "KBDPL.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000816"

0x1, "ControlSet001\Control\Keyboard Layouts\00000816", "Layout Text", "Portuguese (Portugal)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000816", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5019"

0x1, "ControlSet001\Control\Keyboard Layouts\00000816", "Layout File", "KBDPO.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000419"

0x1, "ControlSet001\Control\Keyboard Layouts\00000419", "Layout Text", "Russian"

0x1, "ControlSet001\Control\Keyboard Layouts\00000419", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5055"

0x1, "ControlSet001\Control\Keyboard Layouts\00000419", "Layout File", "KBDRU.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000041B"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041B", "Layout Text", "Slovak"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041B", "Layout Display Name", "@%SystemRoot%\system32\input.dll,-5039"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041B", "Layout File", "KBDSL.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000040A"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040A", "Layout Text", "Spanish (Traditional Sort)"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040A", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5020"

0x1, "ControlSet001\Control\Keyboard Layouts\0000040A", "Layout File", "KBDSP.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000041D"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041D", "Layout Text", "Swedish"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041D", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5022"

0x1, "ControlSet001\Control\Keyboard Layouts\0000041D", "Layout File", "KBDSW.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000100C"

0x1, "ControlSet001\Control\Keyboard Layouts\0000100C", "Layout Text", "French (Swiss)"

0x1, "ControlSet001\Control\Keyboard Layouts\0000100C", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5023"

0x1, "ControlSet001\Control\Keyboard Layouts\0000100C", "Layout File", "KBDSF.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000807"

0x1, "ControlSet001\Control\Keyboard Layouts\00000807", "Layout Text", "German (Swiss)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000807", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5024"

0x1, "ControlSet001\Control\Keyboard Layouts\00000807", "Layout File", "KBDSG.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000409"

0x1, "ControlSet001\Control\Keyboard Layouts\00000409", "Layout Text", "English (United States)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000409", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5000"

0x1, "ControlSet001\Control\Keyboard Layouts\00000409", "Layout File", "KBDUS.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000416"

0x1, "ControlSet001\Control\Keyboard Layouts\00000416", "Layout Text", "Portuguese (Brazil)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000416", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5003"

0x1, "ControlSet001\Control\Keyboard Layouts\00000416", "Layout File", "KBDBR.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\0000080A"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080A", "Layout Text", "Spanish (Mexican)"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080A", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5017"

0x1, "ControlSet001\Control\Keyboard Layouts\0000080A", "Layout File", "KBDLA.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000C0C"

0x1, "ControlSet001\Control\Keyboard Layouts\00000C0C", "Layout Text", "French (Canadian)"

0x1, "ControlSet001\Control\Keyboard Layouts\00000C0C", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5005"

0x1, "ControlSet001\Control\Keyboard Layouts\00000C0C", "Layout File", "KBDFC.DLL"

0x0, "ControlSet001\Control\Keyboard Layouts\00000424"

0x1, "ControlSet001\Control\Keyboard Layouts\00000424", "Layout Text", "Slovenian"

0x1, "ControlSet001\Control\Keyboard Layouts\00000424", "Layout Display Name", "@%SystemRoot%\\system32\\input.dll,-5041"

0x1, "ControlSet001\Control\Keyboard Layouts\00000424", "Layout File", "KBDCR.DLL"

[Append]

nu2menu.xml, keyboard_nu2menu.xml


the keyboard.exe can be found in the plugin directory and the dlls (KBD**.dll where ** is the keyboard layout) on the Windows CD. Can you build this "plugin"? I think it would be very usefoul in your live cd Amalux :)

does your LiveXP contains SATA Drivers?

Edited by Michele13, 24 August 2011 - 09:44 AM.


#28 amalux

amalux

    Platinum Member

  • Tutorial Writer
  • 2813 posts
  •  
    United States

Posted 24 August 2011 - 04:27 PM

Thank you for the information; I could add a multi-language selection for the keyboard layout but isn't that what the script is supposed to do automatically? Why is Auto Keyboard script not working? Since I only have EN sources to test it's difficult to know what the problem is. Hopefully, someone with Italian (or other non-EN) source can test if this script does what it's supposed to do.

There is a SATA support script (default=disabled) which usually isn't necessary since DriverPacks Mass Storage script includes SATA already.

:cheers:

#29 Michele13

Michele13

    Frequent Member

  • Tutorial Writer
  • 167 posts
  •  
    Italy

Posted 24 August 2011 - 04:43 PM

Thank you for the information; I could add a multi-language selection for the keyboard layout but isn't that what the script is supposed to do automatically? Why is Auto Keyboard script not working? Since I only have EN sources to test it's difficult to know what the problem is. Hopefully, someone with Italian (or other non-EN) source can test if this script does what it's supposed to do.

There is a SATA support script (default=disabled) which usually isn't necessary since DriverPacks Mass Storage script includes SATA already.

:cheers:


Is there anything that I Can do?

#30 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10547 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 24 August 2011 - 04:55 PM

Hi Michele, aren't you using an English CD as source?

If so, then the project is working as expected by default when the English keyboard is selected.

To change the keyboard to Italian you need to:
- Enable the Auto Keyboard script inside your project
- Select the box "Overwrite source CD's with local PC's keyboard"
- Rebuild the project
- See if it works.

:)

#31 Michele13

Michele13

    Frequent Member

  • Tutorial Writer
  • 167 posts
  •  
    Italy

Posted 24 August 2011 - 10:06 PM

Hi Michele, aren't you using an English CD as source?

If so, then the project is working as expected by default when the English keyboard is selected.

To change the keyboard to Italian you need to:
- Enable the Auto Keyboard script inside your project
- Select the box "Overwrite source CD's with local PC's keyboard"
- Rebuild the project
- See if it works.

:)


It works perfectly :)

#32 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10547 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 August 2011 - 07:48 AM

Ok, so all is working as intended?

If so, I'm really glad to hear it. Perhaps it would be a good idea to change the topic title to "[solved] I Can't use WinBuilder".

:cheers:

#33 Michele13

Michele13

    Frequent Member

  • Tutorial Writer
  • 167 posts
  •  
    Italy

Posted 25 August 2011 - 10:50 AM

Ehm How can I change the tilte of this topic?

#34 Nuno Brito

Nuno Brito

    Platinum Member

  • .script developer
  • 10547 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 25 August 2011 - 10:57 AM

My apologies, I forgot that your account does not allow to change the title of the topic until you make at least 100 posts.

This is a restriction that prevents spammers from changing their postings to include spam links and the sort.

I will do it for you, don't worry.

:)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users