Jump to content











Photo

Hirens CD v14


  • Please log in to reply
37 replies to this topic

#26 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 02 August 2011 - 04:54 PM

I keep screwing up the menu colors.
I was hoping to go back to the v9.5 aqua color scheme where the menus appeared properly on my notebook.

Would his be correct do you think?
Unfortunately, can't see the code like Neal in the Matrix.

"isolinux.cfg" change for v14, perhaps?

menu color border 0 #00000000 #00000000
menu color sel 7 #ffffffff #ff60CA00
menu color title 0 #00000000 #00000000
menu color unsel 0 #ff60CA00 #00000000
menu color disabled 0 #ffffffff #00000000
menu color timeout_msg 0 #aaaaaaaa #00000000
menu color timeout 0 #ffaaaaff #00000000

Basica,lly - yes - this is what you have to adjust. For a lot more on this, go to the syslinux/isolinux docs - and specifically, the page on the menu stuff at http://syslinux.zyto...omboot/menu.c32

Or go over to the syslinux forum, and ask for more help / info...

#27 Michael*

Michael*

    Frequent Member


  • Advanced user
  • 210 posts
  •  
    United States

Posted 24 August 2011 - 08:40 PM

Posted Image

Hiren just released Hiren's BootCD 14.1
http://www.hiren.info/pages/bootcd

I did notice a few things, but I'm sure there are other improvements.

* Malwarebytes Anti-Malware 1.51.1 (22-08-2011)
* Avira AntiVir Personal (22-08-2011)
* ComboFix (22-08-2011)
* Dr.Web CureIt! Antivirus (22-08-2011)
* RKill (22-08-2011)
* Spybot - Search & Destroy 1.6.2 (22-08-2011)
* SuperAntispyware 4.53.1000 (22-08-2011)
* PCI 32 Sniffer 1.4 (29-07-2011)
* UnknownDevices 1.4.20 (29-07-2011)
* PCI and AGP info Tool (29-07-2011)

Here is the latest/greatest, with some minor optimizations. My guess is that ChrisR will also update on the basic Win7PE_SE package/site...



#28 ChrisR

ChrisR

    Silver Member


  • .script developer
  • 784 posts
  •  
    France

Posted 25 August 2011 - 11:16 AM

Here is the script HirensBootCD modified for version 14.1

Here the changes From Version 14.0 to 14.1 http://www.hirensbootcd.org/download/

Attached File  HirensBootCD.script   16.19KB   84 downloads
  • Michael* likes this

#29 Michael*

Michael*

    Frequent Member


  • Advanced user
  • 210 posts
  •  
    United States

Posted 25 August 2011 - 06:40 PM

Thank you ....
btw, this line in the script is no longer neccessary, as Hiren choose to remove Mini98 from v14.1

If,EXISTFILE,%HBCDTempFolder%\HBCD\DOS\Mini98.uha,FileDelete,%HBCDTempFolder%\HBCD\DOS\Mini98.uha

Here is the script HirensBootCD modified for version 14.1

Attached File  HirensBootCD.script   16.19KB   84 downloads



#30 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 25 August 2011 - 09:17 PM

Thank you ....
btw, this line in the script is no longer neccessary, as Hiren choose to remove Mini98 from v14.1

If,EXISTFILE,%HBCDTempFolder%\HBCD\DOS\Mini98.uha,FileDelete,%HBCDTempFolder%\HBCD\DOS\Mini98.uha

Thanks - this is why it was coded with the exist check - :smiling9: But, will clean it up when I get a chance.

#31 hason

hason

    Member


  • Members
  • 50 posts
  •  
    Vietnam

Posted 13 September 2011 - 03:48 AM

Hi every body. I use minixp on hbcd. I try mode minixp. Now, i can use acronis disk director server 2010 (adds.uha), acronis disk director home 2011 portable (addh.exe) on minixp. File xp.wim only 47Mb, file add place on usb or any partition. I try it with acronis true image (it only work in dos, version 8) 2012 portable but it do not work. Please help me about service and file need run ATIH2012 portable, or buil atih.uha same seagate disk winzard in minixp.

Edited by hason, 13 September 2011 - 03:49 AM.


#32 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 13 September 2011 - 05:06 PM

I am not sure (language issue probably) what you are asking for. First off, the mini-XP was a type of WAREZ (I don't really want to get into a debate about it, but it wasn't exactly "legal" in all areas of the world). I don't know exactly what "acronis true image 2012 portable" is, but Acronis doesn't "sell" or have it on their web site...So it may be a form of WAREZ as well, and we don't support or discuss those things here.

#33 hason

hason

    Member


  • Members
  • 50 posts
  •  
    Vietnam

Posted 14 September 2011 - 09:14 AM

It only trial version. :dubbio:

#34 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 14 September 2011 - 05:12 PM

AFAIK, there are scripts to build new PE's and support Acronis...But, maybe go search the forum for Acronis, and post a question there.

#35 j6scjo

j6scjo

  • Members
  • 1 posts
  •  
    Germany

Posted 05 November 2011 - 06:11 PM

Hello sbaeder,

I found something when I tried to use your script with the winbuilder project ccmultiboot (on a cd in a german computer magazin c't called "Notfall Windows 2011"):
In your script you use two variables %BootSector% and %BootMenu% without setting these variables in the variables section of your script.
Therefore the building of the multiboot-iso failed because %BootSector% wasn't defined by other (basic) scripts of this project.
Because of the other unknown variable %BootMenu% there is no entry for Hiren's Bootdisk in the main menu of the multiboot-dvd.
When I set these two variables manually in the variables section of your script (%BootSector%=Grub4Dos and %BootMenu%=%TargetDir%menu.lst) the iso-building succeed and the entry is in the menu.

#36 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 06 November 2011 - 08:58 PM

Yes, this is true...that project doesn't follow the very loose standard we have been following for "other OS" type scripts. I have been working on a derivitive of that multi-boot project. For you , the simplest fix is to just define those as "hard-coded" values.

In the variables section, ADD the following lines


%BootMenu%=%targetdir%menu.lst

%BootSector%=Grub4Dos


This is because that project only supports the ONE bootloader (GRUB4DOS) and so it has the menu file hard-coded inside most scripts as well as not allowing a choice of bootloaders.

p.s. should work OK with the latest version (15) that was just released...HOWEVER, also be aware (as mentioned above) this doesn't process the MiniXP, and it will also try to process shortcuts (unless disabled, and that also has issues today)...But with a few mods, you should be able to make it all work...and down the road, there will be an improved version as well.

#37 AHRIMANSEFID

AHRIMANSEFID

    Newbie


  • Members
  • 13 posts

Posted 02 February 2012 - 07:32 AM

Hi All.
Plz Help For Remove Error In Hirens Boot CD 15.1.
Thanks A Lot.


	  Scripts

This project is running, please wait until it is completed. Hirens Boot CD (for v 14.1 and possibly later)   6.802 seconds



	  Errors

  DirDelete - Failed to delete directory [%TempFolder%\Hirens\HBCD\DOS\]



	  Warnings

  Error - [DirMake %TempFolder%\Hirens ]   Halt

2 warning messages





	   %BaseDir% = C:\EasyBoot\balder\WinBuilder_Complete\

(winbuilder's path is replaced by the variable %basedir% to make the log easier to read)

WinBuilder version [075 beta 5] 



	    This project is running, please wait until it is completed. Hirens Boot CD (for v 14.1 and possibly later)

  File [%BaseDir%\Projects\LiveXP\EasyBoot\HirensBootCD.script] Version

  IF - Section does not exist [%BootSector%] evaluated string: [If,Not,ExistVar,%BootSector%,If,ExistSection,%projectdir%\script.project,SetOtherOS,Run,%projectdir%\script.project,SetOtherOS]

  IF - Section does not exist [SetOtherOS] evaluated string: [If,ExistSection,%projectdir%\script.project,SetOtherOS,Run,%projectdir%\script.project,SetOtherOS]

  IF - [%BootSector%] is not equal to: [BCDW] evaluated string: [If,%BootSector%,Equal,BCDW,Exit,"NO BCDW Entry for %MenuTitle% at this time"]

  SetVar - Sucessfuly changed the value of [%Local_DosTools_CheckBox%] to: [False]

  SetVar - Sucessfuly changed the value of [%Local_MiscTools_CheckBox%] to: [False]

  SetVar - Sucessfuly changed the value of [%Local_PMagic_CheckBox%] to: [False]

  IF - [False] is equal to: [False] evaluated string: [If,%Local_DosTools_CheckBox%,Equal,False,Begin]

	    IF - [False] is not equal to: [True] evaluated string: [If,%Local_MiscTools_CheckBox%,EQUAL,True,Begin]

			  [Beep,ASTERISK]

			  [If,QUESTION,"Can't enable Hiren's stand-alone tools without also selecting the DOS tools. Enable DOS tool and continue? (Y)",10,True,Set,%Local_DosTools_CheckBox%,True]

			  [Else,Halt,"User Abort"]

	    [End]

  [End]

  IF - [False] is equal to: [False] evaluated string: [If,%Local_DosTools_CheckBox%,Equal,False,Begin]

	    IF - [False] is not equal to: [True] evaluated string: [If,%Local_PMagic_CheckBox%,EQUAL,True,Begin]

			  [Beep,ASTERISK]

			  [If,QUESTION,"Can't enable Hiren's stand-alone Parted Magic without also selecting the DOS tools. Enable DOS tool and continue (Y)",10,True,Set,%Local_DosTools_CheckBox%,True]

			  [Else,Halt,"User Abort"]

	    [End]

  [End]

  IF - [False] is not equal to: [True] evaluated string: [If,%Silently_CheckBox%,Equal,True,Set,%ShowHide%,Hide]

  ELSE - executing command: [Set,%ShowHide%,Open]

  SetVar - Sucessfuly changed the value of [%ShowHide%] to: [Open]

  IF - [%ChooseLocation_RadioGroup%] is not equal to: [0] evaluated string: [If,%ChooseLocation_RadioGroup%,Equal,0,Begin]

	    [If,%pAlwaysUpdate%,Equal,True,Run,%ScriptFile%,Download]

	    [Else,If,Not,ExistFile,%GlobalTemplates%\%FolderName%\*.iso,Run,%ScriptFile%,Download]

	    [If,Not,Existfile,%GlobalTemplates%\%FolderName%\*.iso,Message,"%MenuTitle% iso not found in %GlobalTemplates%\%FolderName%. Check Source location for proper ZIP file"]

	    [If,Not,Existfile,%GlobalTemplates%\%FolderName%\*.iso,Exit,"%MenuTitle% iso not found in %GlobalTemplates%\%FolderName%. Check Source location for proper ZIP file"]

  [End]

  IF - [%ChooseLocation_RadioGroup%] is not equal to: [1] evaluated string: [If,%ChooseLocation_RadioGroup%,Equal,1,Begin]

	    [If,Not,Existfile,%IsoImage_FileBox%,Message,"Could not find %IsoImage_FileBox%, please check specified location."]

	    [If,Not,Existfile,%IsoImage_FileBox%,Exit,"Could not find %IsoImage_FileBox%, please check specified location."]

  [End]

  IF - Directory does not exist: [%TempFolder%\Hirens] evaluated string: [If,ExistDir,%HBCDTempFolder%,DirDelete,%HBCDTempFolder%]

Error - [DirMake %TempFolder%\Hirens ]

  Unpacking iso file...

  IF - [%ChooseLocation_RadioGroup%] is not equal to: [0] evaluated string: [If,%ChooseLocation_RadioGroup%,Equal,0,ShellExecute,%ShowHide%,%Tools%\7z.exe,"x -y #$q%GlobalTemplates%\%FolderName%\*.iso#$q -o#$q%HBCDTempFolder%#$q"]

  IF - [%ChooseLocation_RadioGroup%] is not equal to: [1] evaluated string: [If,%ChooseLocation_RadioGroup%,Equal,1,ShellExecute,%ShowHide%,%Tools%\7z.exe,"x -y #$q%IsoImage_FileBox%#$q -o#$q%HBCDTempFolder%#$q"]

  Cleaning up temp area (%TempFolder%\Hirens\HBCD)

  IF - Directory does not exist: [%TempFolder%\Hirens\HBCD\XP] evaluated string: [If,EXISTDIR,%HBCDTempFolder%\HBCD\XP,DirDelete,%HBCDTempFolder%\HBCD\XP\,FAST]

  IF - File does not exist: [%TempFolder%\Hirens\HBCD\DOS\Mini98.uha] evaluated string: [If,EXISTFILE,%HBCDTempFolder%\HBCD\DOS\Mini98.uha,FileDelete,%HBCDTempFolder%\HBCD\DOS\Mini98.uha]

  IF - [False] is equal to: [False] evaluated string: [If,%Local_DosTools_CheckBox%,Equal,False,Begin]

	   DirDelete - Failed to delete directory [%TempFolder%\Hirens\HBCD\DOS\]

	   Halt

	    Hirens Boot CD (for v 14.1 and possibly later)

	    Script time: 6 seconds and 802 milliseconds

	    Script has been sucessfully processed!



#38 sbaeder

sbaeder

    Gold Member


  • .script developer
  • 1335 posts
  • Location:usa - massachusettes
  •  
    United States

Posted 02 February 2012 - 10:16 PM

Well, you posted a lot of information, but without a real "log file", it is hard to tell.

BUT, did you try it a second time? It looks like this is a timing glitch (reported in many other places as well) on trying to delete the directory (and for some reason getting an error code back from the OS). ***IF*** it is repeatable, then capture a DEBUG setting log file, and post it somewhere we can look at it.

Scott




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users