Jump to content











Photo

Make a multi-install USB Flash drive using grub4dos and Windows ISO files


  • Please log in to reply
95 replies to this topic

#51 rebootfan

rebootfan
  • Members
  • 2 posts
  •  
    India

Posted 04 February 2013 - 09:01 AM

Is it possible to make a multiboot usb flash drive containing Win 7 AIO and Win 8 AIO 32 bit only?



#52 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 February 2013 - 10:19 AM

yes



#53 rebootfan

rebootfan
  • Members
  • 2 posts
  •  
    India

Posted 04 February 2013 - 02:18 PM

yes

Is it possible using your rmprepusb  tutorial 43 for Win 7 AIO and Win 8 AIO 32 bit only?Please keep in mind that Win 8 AIO ISO is an unofficial one containing Core,Pro,Pro with WMC&Enterprise editions.Does rmprepusb support manually created AIO ISOs?

 

Is it necessary to add key in AutoUnattend xml file if i already have ei.cfg file in Win 8 AIO ISO?

 

What are the changes that i have to make in menu lst file so that i have the entries of Install WIn 7 AIO,Install Win 8 AIO,Boot from first hard drive when booting from USB?



#54 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 February 2013 - 02:55 PM

The ei.cfg should be ignored (in that you should be prompted for what SKU you want).

Why not try it and see what you get? I can't predict what will happen with some AIO that you have made yourself!

For Win8 you need a key or modify the ei.cfg as explained in #43.



#55 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 06 April 2013 - 09:29 PM

Hello,

I prepared a USB flash drive with 2 iso files (Win 8 x86 and Win8 x64) following the tutorial #43.

Each iso file are customized with $OEM$ folder (which contain SetupComplete.cmd file located in \Sources\$OEM$\$$\Setup\Scripts) and Autounattend.xml file located in the root of each iso.

I can run windows setup successfully from both iso, but Autounattended.xml located in iso file it's not loaded. Any attempt to modify the Autounattend.xml file located in the root of the usb flash drive will result in a complete restore of the original content, but the file size will be kept.

So, where should I put my customized Autounattend.xml so Windows setup can use it.

 

Files modified by me:

auWin8.xml:

<?xml version="1.0" encoding="utf-8" ?>
 <unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
<Description>Detecting usb drive</Description>
</RunSynchronousCommand>
</RunSynchronous>

<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
</ProductKey>
</UserData>

</component>

<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
<Description>Detecting usb drive</Description>
</RunSynchronousCommand>
</RunSynchronous>

<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
</ProductKey>
</UserData>

</component>
</settings>
</unattend>

Menu.lst:

title INSTALL Windows 8 32-bit\nThis will install Windows 8 32-bit to your hard disk
debug off
set MYISO=HRM_CENA_X86FREV_EN-US_DV5.iso
dd if=()/firadisk/auWin8.xml of=()/AutoUnattend.xml
dd if=()/firadisk/spaces.txt of=()/firadisk/ISONAME.CMD
write ()/firadisk/ISONAME.CMD SET MYISO=\\iso\\%MYISO%\r\n
map --mem (md)0x800+4 (99)
map /ISO/%MYISO% (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/ISO/%MYISO%;\n\0
chainloader (0xff)/BOOTMGR || chainloader (0xff)

title INSTALL Windows 8 64-bit\nThis will install Windows 8 64-bit to your hard disk
debug off
set MYISO=HRM_CENA_X64FREV_EN-US_DV5.iso
dd if=()/firadisk/auWin8.xml of=()/AutoUnattend.xml
dd if=()/firadisk/spaces.txt of=()/firadisk/ISONAME.CMD
write ()/firadisk/ISONAME.CMD SET MYISO=\\iso\\%MYISO%\r\n
map --mem (md)0x800+4 (99)
map /ISO/%MYISO% (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/ISO/%MYISO%;\n\0
chainloader (0xff)/BOOTMGR || chainloader (0xff)

title Boot from 1st Hard Disk \nBoot from MBR of first hard disk and remove the USB drive
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
chainloader (hd0)+1
rootnoverify (hd0)

AutoUnattend.xml located in the root of Win8x86 iso:

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SystemLocale>en-us</SystemLocale>
<UserLocale>en-us</UserLocale>
<UILanguage>en-US</UILanguage>
<UILanguageFallback>en-us</UILanguageFallback>
<InputLocale>0409:00000409</InputLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserData>
<ProductKey>
<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<Organization>M$</Organization>
<FullName>Power User</FullName>
<AcceptEula>true</AcceptEula>
</UserData>
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<Value>Windows 8 ENTERPRISE</Value>
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Power User</Name>
<Group>Administrators</Group>
<Password>
<PlainText>true</PlainText>
<Value></Value>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>
</component>
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UILanguage>en-US</UILanguage>
<UserLocale>ro-RO</UserLocale>
<InputLocale>0409:00000409</InputLocale>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<AutoLogon>
<Enabled>true</Enabled>
<Username>Power User</Username>
<Password>
<Value />
</Password>
<LogonCount>9999999</LogonCount>
</AutoLogon>
<TimeZone>GTB Standard Time</TimeZone>
<ComputerName>PowerUser-PC</ComputerName>
</component>
</settings>
<!-- The next five lines will disable UAC in Windows 8 and on the first -->
<!-- desktop you will not need elevated privileges to run or install something -->
<settings pass="offlineServicing">
<component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
<EnableLUA>false</EnableLUA>
</component>
</settings>
</unattend>

SetupComplete.cmd:

cwnd /HIDE @
@Echo Off
:: Find the CD-ROM drive letter
FOR %%i in (C D E F G H I J K L M N O P Q R S T U V W X Y Z) do if exist %%i:\sources\install.wim set CDROM=%%i:
:: Add a reg key that will run applications installation
REG ADD HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run /V "001" /D "%CDROM%\Applications\Install.cmd" /f

Edited by conan, 06 April 2013 - 10:13 PM.


#56 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 09:46 PM

What do you think this line does

 

 

dd if=()/firadisk/auWin8.xml of=()/AutoUnattend.xml

 

if = input file

of = output file

 

 

so copy your xml to /firadisk folder and edit the menu.lst line to use your own file

 

P.S.

 

OR to use the one in the ISO directly...

 

after the

map --hook line add

 

 

root (0xff)
dd if=(0xff)/AutoUnattend.xml of=(hd1,0)/AutoUnattend.xml
 


#57 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 06 April 2013 - 10:04 PM

P.S.

 

OR to use the one in the ISO directly...

 

after the

map --hook line add

 

 

root (0xff)
dd if=(0xff)/AutoUnattend.xml of=(hd1,0)/AutoUnattend.xml

This didn't work.



#58 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 10:16 PM

sorry, I haven't tried it, maybe it needs to use a shortname 8.3?

 

The first solution should work OK.  i.e. put your own file in usb drive \firadisk folder and modify the menu to use it.



#59 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 06 April 2013 - 10:27 PM

Sorry to use another post.

The first solution reset the AutoUnattended.xml file copied in FiraDisk folder to default (like the one from your package).

The second solution gives an error.

Thanks for your support.

I'll come back later today it's 1 AM here.



#60 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 06 April 2013 - 10:39 PM

Then you have edited the menu wrongly!

 

The original line was

 

dd if=()/firadisk/auWin8.xml of=()/AutoUnattend.xml

this overwrites the file /Autounattend.xml using the file /firadisk/auWin8.xml.

 

So what you need to do is

 

1. Copy your ISO file AutoUnattend.xml to the USB and name the file \firadisk\new8.xml

2. Edit the menu.lst file line to

 

dd if=()/firadisk/new8.xml of=()/AutoUnattend.xml

 

make sure the file on the USB drive \Autounattend.xml is at least as big as your new8.xml file.



#61 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 07 April 2013 - 10:25 AM

Now, the setup prompt for a missing media driver.



#62 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 April 2013 - 10:27 AM

OK, that's good!

What you need to do is combine the contents of auwin8.xml with your new8.xml. This will then cause the blue console window to appear and load the ISO before Setup GUI runs.



#63 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 07 April 2013 - 10:38 AM

I copied this code:

 

<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
<Description>Detecting usb drive</Description>
</RunSynchronousCommand>
</RunSynchronous>

under this line in \FiraDisk\new8.xml:

 

<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

and leave auwin8.xml untouched.

The blue console appears, but the \FiraDisk\new8.xml is not used, since the window with keyboard and locale still appears.


Edited by conan, 07 April 2013 - 10:38 AM.


#64 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 07 April 2013 - 10:54 AM

Should be Ok??? Double-check the XML bracketting?? What happens if you carry on with the install - are any of the other sections seen? Does the file in the root of the USb look OK?



#65 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 07 April 2013 - 11:46 AM

I went with installation until personalize window appears, made restart and restore partition from image.



#66 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 08 April 2013 - 09:33 PM

Thanks Steve, your method works! I had some errors in AutoUnattend.xml I think.

 

I succeded with these:

\FiraDisk\auWin8.xml:

<?xml version="1.0" encoding="utf-8" ?> 
 <unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
<Description>Detecting usb drive</Description>
</RunSynchronousCommand>
</RunSynchronous>

<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
</ProductKey>
</UserData>

</component>

<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<RunSynchronous>
<RunSynchronousCommand wcm:action="add">
<Order>1</Order>
<Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
<Description>Detecting usb drive</Description>
</RunSynchronousCommand>
</RunSynchronous>

<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
</ProductKey>
</UserData>

</component>
</settings>
</unattend>

\FiraDisk\new8.xml (this will work for both 32 and 64 bit OS):

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
	<settings pass="windowsPE">
		<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<SystemLocale>en-us</SystemLocale>
			<UserLocale>en-us</UserLocale>
			<UILanguage>en-US</UILanguage>
			<UILanguageFallback>en-us</UILanguageFallback>
			<InputLocale>0409:00000409</InputLocale>
		</component>
		<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<SystemLocale>en-us</SystemLocale>
			<UserLocale>en-us</UserLocale>
			<UILanguage>en-US</UILanguage>
			<UILanguageFallback>en-us</UILanguageFallback>
			<InputLocale>0409:00000409</InputLocale>
		</component>
		<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
		    <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Order>1</Order>
                    <Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
                    <Description>Detecting usb drive</Description>
                </RunSynchronousCommand>
            </RunSynchronous>
			<UserData>
				<ProductKey>
					<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
					<WillShowUI>OnError</WillShowUI>
				</ProductKey>
				<Organization>M$</Organization>
				<FullName>Power User</FullName>
				<AcceptEula>true</AcceptEula>
			</UserData>
			<ImageInstall>
				<OSImage>
					<InstallFrom>
						<MetaData wcm:action="add">
								<Key>/IMAGE/NAME</Key>
								<Value>Windows 8 ENTERPRISE</Value>
						</MetaData>
					</InstallFrom>
				</OSImage>
			</ImageInstall>
		</component>
		<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
		    <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Order>1</Order>
                    <Path>cmd /q /c "FOR %i IN (C D E F G H I J K L N M O P Q R S T U V W X Y Z) DO IF EXIST %i:\FIRADISK\LOADISO.CMD cmd /k %i:\FIRADISK\LOADISO.cmd"</Path>
                    <Description>Detecting usb drive</Description>
                </RunSynchronousCommand>
            </RunSynchronous>
			<UserData>
				<ProductKey>
					<Key>D4F6K-QK3RD-TMVMJ-BBMRX-3MBMV</Key>
					<WillShowUI>OnError</WillShowUI>
				</ProductKey>
				<Organization>M$</Organization>
				<FullName>Power User</FullName>
				<AcceptEula>true</AcceptEula>
			</UserData>
			<ImageInstall>
				<OSImage>
					<InstallFrom>
						<MetaData wcm:action="add">
								<Key>/IMAGE/NAME</Key>
								<Value>Windows 8 ENTERPRISE</Value>
						</MetaData>
					</InstallFrom>
				</OSImage>
			</ImageInstall>
		</component>
	</settings>
	<settings pass="oobeSystem">
		<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<UserAccounts>
				<LocalAccounts>
					<LocalAccount wcm:action="add">
						<Name>Power User</Name>
						<Group>Administrators</Group>
						<Password>
							<PlainText>true</PlainText>
							<Value></Value>
						</Password>
					</LocalAccount>
				</LocalAccounts>
			</UserAccounts>
			<OOBE>
				<HideEULAPage>true</HideEULAPage>
				<NetworkLocation>Home</NetworkLocation>
				
<ProtectYourPC>1</ProtectYourPC>
				<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
			</OOBE>
		</component>
		<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<UserAccounts>
				<LocalAccounts>
					<LocalAccount wcm:action="add">
						<Name>Power User</Name>
						<Group>Administrators</Group>
						<Password>
							<PlainText>true</PlainText>
							<Value></Value>
						</Password>
					</LocalAccount>
				</LocalAccounts>
			</UserAccounts>
			<OOBE>
				<HideEULAPage>true</HideEULAPage>
				<NetworkLocation>Home</NetworkLocation>
				
<ProtectYourPC>1</ProtectYourPC>
				<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
			</OOBE>
		</component>
		<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<UILanguage>en-US</UILanguage>
			<UserLocale>ro-RO</UserLocale>
			<InputLocale>0409:00000409</InputLocale>
		</component>
		<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<UILanguage>en-US</UILanguage>
			<UserLocale>ro-RO</UserLocale>
			<InputLocale>0409:00000409</InputLocale>
		</component>
	</settings>
	<settings pass="specialize">
		<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<AutoLogon>
				<Enabled>true</Enabled>
				<Username>Power User</Username>
				<Password>
					<Value />
				</Password>
				<LogonCount>9999999</LogonCount>
			</AutoLogon>
			<TimeZone>GTB Standard Time</TimeZone>
			<ComputerName>PowerUser-PC</ComputerName>
		</component>
		<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
			<AutoLogon>
				<Enabled>true</Enabled>
				<Username>Power User</Username>
				<Password>
					<Value />
				</Password>
				<LogonCount>9999999</LogonCount>
			</AutoLogon>
			<TimeZone>GTB Standard Time</TimeZone>
			<ComputerName>PowerUser-PC</ComputerName>
		</component>
	</settings>
	<!-- The next lines will disable UAC in Windows 8 and on the first -->
	<!-- desktop you will not need elevated privileges to run or install something -->
	<settings pass="offlineServicing">
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
    <EnableLUA>false</EnableLUA>
    </component>
    <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS">
    <EnableLUA>false</EnableLUA>
    </component>
    </settings>
</unattend>

The file on the USB drive \Autounattend.xml must be at least as big as \FiraDisk\new8.xml file.

 

\ISO\HRM_CENA_X64FREV_EN-US_DV5.iso

\ISO\HRM_CENA_X86FREV_EN-US_DV5.iso

 

\menu.lst:

title INSTALL Windows 8 32-bit\nThis will install Windows 8 32-bit to your hard disk
debug off
set MYISO=HRM_CENA_X86FREV_EN-US_DV5.iso
dd if=()/firadisk/new8.xml of=()/AutoUnattend.xml
dd if=()/firadisk/spaces.txt of=()/firadisk/ISONAME.CMD
write ()/firadisk/ISONAME.CMD SET MYISO=\\iso\\%MYISO%\r\n
map --mem (md)0x800+4 (99)
map /ISO/%MYISO% (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/ISO/%MYISO%;\n\0
chainloader (0xff)/BOOTMGR || chainloader (0xff)

title INSTALL Windows 8 64-bit\nThis will install Windows 8 64-bit to your hard disk
debug off
set MYISO=HRM_CENA_X64FREV_EN-US_DV5.iso
dd if=()/firadisk/new8.xml of=()/AutoUnattend.xml
dd if=()/firadisk/spaces.txt of=()/firadisk/ISONAME.CMD
write ()/firadisk/ISONAME.CMD SET MYISO=\\iso\\%MYISO%\r\n
map --mem (md)0x800+4 (99)
map /ISO/%MYISO% (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/ISO/%MYISO%;\n\0
chainloader (0xff)/BOOTMGR || chainloader (0xff)

# Ignore boot device and boot to Windows 9x/Me/NT/2K/XP/Vista/7/8 from the internal hard disk
# This works by mapping the boot device (bd) which may have bootmgr, ntldr, cmldr or io.sys
# on it, to a virtual memory drive so that files on it are not found by the find command
title Boot to Windows from an internal hard disk
map --mem (md)+8 (bd)
map --hook
find --set-root --ignore-floppies --ignore-cd /bootmgr || find --set-root --ignore-floppies --ignore-cd /ntldr || find --set-root --ignore-floppies --ignore-cd /cmldr || find --set-root --ignore-floppies --ignore-cd /io.sys
map (bd) (bd)
map --rehook
chainloader /bootmgr || chainloader /ntldr || chainloader /cmldr || chainloader /io.sys

Windows 8 setup used the configuration file \FiraDisk\new8.xml, so I had 2 prompts: 1 for the recovery option and after the setup begins another prompt for partition.

 

You should update the tutorial #43 for noobs like me :D

Thanks again!


Edited by conan, 08 April 2013 - 09:45 PM.


#67 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 08 April 2013 - 10:36 PM

Thanks for getting back.

You can also try Easy2Boot V1 and use a bootable USB Hard disk (with all Windows ISOs) plus a flash drive.

You will need to edit the Win8 menu file and add your xml files as before. The flash drive just needs to have two files on it.



#68 conan

conan

    Newbie

  • Members
  • 21 posts
  •  
    Romania

Posted 09 April 2013 - 11:36 AM

OK, thanks!



#69 GURPREET

GURPREET

    Newbie

  • Members
  • 13 posts
  •  
    India

Posted 01 May 2013 - 06:42 AM

please give advice . how to install window 7 and 8 , (two) windows from same pen/flash drive  ..  for eg xp and windows 7 from same pen/flash drive with WinSetup or other softwares ... Is there any software to install windows 7 AND 8 from same pen/flash drive .....



#70 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 01 May 2013 - 07:31 AM

Easy2boot

#71 GURPREET

GURPREET

    Newbie

  • Members
  • 13 posts
  •  
    India

Posted 04 May 2013 - 04:57 AM

Thank`s man ...

 

I had checked it ..i had to paste all iso`s in auto folder  . (xp,windows 7,windows 8) .all process runs well but with error . the error is when i boot from usb windows 7 & winndows 8 setup runs .when i click install button on installation screen of both windows .the both windows shows ``Windows could not parse or process unattend answer file [ J:\autounattend.xml ].The answer file is invalid.`` ...i want to know that i had to manually built the file . if manually built file please explain what to write for window 7 &windows 8 setup to run without entruption  .. & also when xp setup runs . it shows blue screen.

 

          Please reply



#72 steve6375

steve6375

    Platinum Member

  • Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 04 May 2013 - 07:23 AM

Please follow instructions on the web site or watch the videos.



#73 GURPREET

GURPREET

    Newbie

  • Members
  • 13 posts
  •  
    India

Posted 04 May 2013 - 10:59 AM

ok ,, will try ..



#74 GURPREET

GURPREET

    Newbie

  • Members
  • 13 posts
  •  
    India

Posted 10 May 2013 - 01:38 AM

I had tried the usb process /.means i had made bootable usb .yesterday i installed window 7 from usb first it works fine but when computer reboots it stuck on "compleating installition" screeen .why it sow , secondly when i want to install windows xp  by preesing f6 ,s,s it doesnot load any drivers .

  any soloution... bro.



#75 guimenez

guimenez

    Frequent Member

  • Advanced user
  • 168 posts
  •  
    Portugal

Posted 16 January 2014 - 11:59 AM

Hi Steve,

i'm getting trouble to make this work.

i followed all the tutorial, but all my isos(winvista,win7 and win8.1), after open the first setup and when it goes to disk manager, it always says "No harddisk" and ask me for the hdd driver :(

 

Attached File  fotografia.JPG   128.14KB   1 downloads

 

I want this tutorial because i've my personalized boot pen.

 

Thank you

 

 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users