Jump to content











Photo

XBoot vs 1.0.0.0 beta6 has been released.


  • Please log in to reply
9 replies to this topic

#1 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 21 January 2011 - 09:24 PM

XBoot vs 1.0.0.0 beta6.
Latest version of XBoot has been released.
Go to thread Introduction to XBoot for downloading latest version

Changelog for XBoot vs 1.0.0.0 beta6 :
- Added support for Tails live cd(The Amnesic Incognito Live System)
- Added support for Backtrack
- Added support for ERD, MSDART ,PE (windows vista and 7 only)
- Added support for ERD, MSDART ,PE (windows XP only)
- Added support for ubcd4win.
- syslinux bootloader can also be installed on USB HardDrives.
- Menu Configuration files(isolinux.cfg , syslinux.cfg ,menu.lst etc.) now open in dafault application (instead of choosing application each time).
- Fixed support for Knoppix.
- Upgraded the support for latest Avira antivirus rescue cd.
- Adding menu entries in Main Menu are possible now( by changing the category to blank space).
- Added support for adding multiple edition(amd64,i486 etc.) of clonezilla to Multiboot USB/ISO.
- User can choose where he wants to save the Multiboot ISO file.

Note:I forget to update the version number on XBoot vs1.0.0.0 beta6 . so it will show itself as XBoot vs1.0.0.0 beta5 .But in actual it is XBoot vs1.0.0.0 beta6 , so ignore it and continue as usual.

NOTE: XBootvs1.0.0.0 beta6 is not compatible with previous version of XBoot.so if you have made a Mutliboot USB using previous versions of XBoot , then do not add new ISO file to it using XBoot vs 1.0.0.0 beta6.

#2 Stereodude

Stereodude
  • Members
  • 9 posts
  •  
    United States

Posted 23 January 2011 - 07:17 PM

Thanks for the improvements!

#3 elnacho

elnacho
  • Members
  • 3 posts
  •  
    Spain

Posted 28 January 2011 - 11:55 AM

Thanks shamurshamur for the updates. Much appreciated !! :-)

#4 whairs01

whairs01

    Newbie

  • Members
  • 25 posts
  •  
    United States

Posted 03 February 2011 - 05:26 PM

Hello shamurshamur,


I am getting the following error after installing new xboot release Beta6 after building the USB with either syslinux or grub4dos neither would boot. after it would not boot with grub4dos I try to edit the usb and install grub4dos and got the following error message.

- error
[b]syslinux didn't install peoperly.

grubinst: ioen: Permission denied
.[/b

I tried many way and cannot get a successful build of the usb. I did not have this problem when building under XP Pro SP3 but now I am running Windows 7 Pro 64bits. Also the QEMU will not work. Is there a problem running XBOOT in Windows 7 Pro 64-bits

#5 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 03 February 2011 - 07:07 PM

Most probably syslinux.exe and grubinst.exe are not able to access MBR of you USB device.This may because they don't have enough privilege OR antivirus is not allowing them.

same reason is for QEMU.

Also i think error message given by Xboot is more then that can you please post the whole error message.

#6 whairs01

whairs01

    Newbie

  • Members
  • 25 posts
  •  
    United States

Posted 07 February 2011 - 07:59 PM

Hello shamurshamur,

I am trying to create a bootable USB 16GB Stick (using syslinux) with 13 items total 6GB which I have divide into 5 titles menus as follow:

- http://www.laughabit...ot_PrtScrn_.gif

which it said run to a successful build:

- http://www.laughabit...uc_PrtScrn_.gif

But when I boot the USB everything work except the last menu group Windows Repair Utilities. When I went to boot/syslinux I found that the cfg
(bdihghfejj.cfg) was empty. My question is there a limit of how many item or menus that you can have and if not could you tell me how to fix this problem. All the other 4 works just find. Also I know it not the iso because I build another USB where I use the first two menu and the "windows Repair Utilities" menu and it work find. ONLY when I have the Fifth menu it does not work it is alway empty but yet I got a successful build msg. Please Help. Follow are the menu.lst, and syslinux.cfg

Here is the menu.lst:

color magenta/white white/magenta black/white black/white


### MENU END
title Backup & Restore Utilities
configfile /boot/grub4dos/bahbiidagd.lst
### MENU END


### MENU END
title HDD Repair Utilities
configfile /boot/grub4dos/iaajbcjca.lst
### MENU END


### MENU END
title Utility
configfile /boot/grub4dos/utility.lst
### MENU END


### MENU END
title Windows Installation & Setup
configfile /boot/grub4dos/hfhebhdif.lst
### MENU END


### MENU END
title Windows Repair Utilities
configfile /boot/grub4dos/bdihghfejj.lst This file was build empty
### MENU END


### MENU START
title Help!\n
ls /images/help.iso || find --set-root /images/help.iso
map --heads=0 --sectors-per-track=0 /images/help.iso (0xff) || map --heads=0 --sectors-per-track=0 --mem /images/help.iso (0xff)
map --hook
chainloader (0xff)
### MENU END


Here is the syslinux.cfg:

MENU title XBOOT DVD
INCLUDE /boot/syslinux/theme.cfg

### MENU START
LABEL -
MENU LABEL Backup & Restore Utilities
KERNEL /boot/syslinux/vesamenu.c32
APPEND /boot/syslinux/bahbiidagd.cfg
TEXT HELP
ENDTEXT
### MENU END


### MENU START
LABEL -
MENU LABEL HDD Repair Utilities
KERNEL /boot/syslinux/vesamenu.c32
APPEND /boot/syslinux/iaajbcjca.cfg
TEXT HELP
ENDTEXT
### MENU END


### MENU START
LABEL -
MENU LABEL Utility
KERNEL /boot/syslinux/vesamenu.c32
APPEND /boot/syslinux/utility.cfg
TEXT HELP
ENDTEXT
### MENU END


### MENU START
LABEL -
MENU LABEL Windows Installation & Setup
KERNEL /boot/syslinux/vesamenu.c32
APPEND /boot/syslinux/hfhebhdif.cfg
TEXT HELP
ENDTEXT
### MENU END


### MENU START
LABEL -
MENU LABEL Windows Repair Utilities
KERNEL /boot/syslinux/vesamenu.c32
APPEND /boot/syslinux/bdihghfejj.cfg
TEXT HELP
ENDTEXT
### MENU END


### MENU START
LABEL -
MENU LABEL Help!
LINUX /boot/syslinux/grub.exe
APPEND --config-file="ls /images/help.iso || find --set-root /images/help.iso;map --heads=0 --sectors-per-track=0 /images/help.iso (0xff) || map --heads=0 --sectors-per-track=0 --mem /images/help.iso (0xff);map --hook;chainloader (0xff)"
TEXT HELP

ENDTEXT
### MENU END


Please, let me know if you need me to send or post any of the other file.


William

#7 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 11 February 2011 - 10:13 AM

@whairs01

Theres no limit in number of menus you can add.
Also xboot doesn't support windows install disk for xp,vista or 7.

I tried to reproduce your error you mentioned, but i was not succesfull.

I added 7 items and changed the categories of last two item to Windows Repair Utilities , everything worked fine and file name bdihghfejj.cfg has the entries for two items.

may be error was due to some other reasons.Or you can tell me how to reproduce the error.

Regards.

#8 whairs01

whairs01

    Newbie

  • Members
  • 25 posts
  •  
    United States

Posted 23 February 2011 - 07:50 PM

Hello shamurshamur

I want to give you an updated on the problem that I was having with the 16GB USB where I could not access the last menup group when the size of the entries/items exceed 6GB. The problem was due to a bad USB. I bought a new 8GB it worked great. Thank you update for trying to recreate it.

What I need to know now and I asked you earlier about was that I need the xboot USB to show up as device 2 or the last device and be able to give it any drive letter. What I have is a new drive and it will consist of 3 partitions (Drive C: FAT32 and Extended Partition broken up into 2 Logical NTFS drives letter D: & E: As I stated earlier I need the USB to be Device 2 and anydrive letter after F: Could you please tell and show me if possible what file I need to modify and when. Thank YOU

#9 shamurshamur

shamurshamur

    Frequent Member

  • Developer
  • 322 posts
  •  
    India

Posted 06 March 2011 - 02:53 PM

What I need to know now and I asked you earlier about was that I need the xboot USB to show up as device 2 or the last device and be able to give it any drive letter. What I have is a new drive and it will consist of 3 partitions (Drive C: FAT32 and Extended Partition broken up into 2 Logical NTFS drives letter D: & E: As I stated earlier I need the USB to be Device 2 and anydrive letter after F: Could you please tell and show me if possible what file I need to modify and when. Thank YOU

Drive letter of xboot USB wil be decided by the application you are booting.So please mention which application you are facing problem with.

There are two cases in general:
1) Application is using Bios routines to access drives.
in this case we can remap the harddrives in grub4dos using

map (hd0) (hd1)

map (hd1) (hd0)

map --hook



2) Application is using its own drivers.
in this case we can not do much.


Tell me the application you are facing problem with , i will look in to it.

Regards.

ps: whenever you ask a new question , always create a new topics.Do not mix various topics in one thread.

#10 whairs01

whairs01

    Newbie

  • Members
  • 25 posts
  •  
    United States

Posted 06 March 2011 - 03:38 PM

Hello shamurshamur,

It is cass 1. I need to map the USB stick to be the last physical drive. I want to make my internal Hard Drive to be hd0 and my USB stick be hd1 and be able to assign it my own letter. I am first booting the USB up and running FreeDos or Windows 98 fdisk or Acronis Director home 11 to partition the internal Hard Drive.

What I have is a new drive and it will consist of 3 partitions (Drive C: FAT32 and Extended Partition broken up into 2 Logical NTFS drives letter D: & E: As I stated earlier I need the USB to be Device 2 and anydrive letter after F: Could you please tell and show me if possible what file I need to modify and when. Thank YOU




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users