Jump to content

- - - - -

Wierd partition detection and hiding - Solved

  • Please log in to reply
1 reply to this topic

#1 BobxT



  • Members
  • 82 posts

Posted 09 January 2011 - 05:12 AM

As I reported in passing, in another thread (that I can't currently find) where I was trying to sort out my Acronis TI build problems.

I had noticed some weird effects on my real PC that appeared to not detect partitions correctly. But these effect were NOT able to be duplicated in VirtualBox at that time. I thought this weirdness was possibly the cause of my Acronis TI script problems but it was not the case.

First the physical hard drive layout description:-

First drive has 3 Primary partitions:-
1= Win7 Ultimate x86 (100gb) booted as drive C:
2= Win7 Ultimate x64 (100gb) booted as drive C:
3= WinXP x86 (100gb) booted as drive C:

followed by Logical Partitions as follows:-
4= Fat32 (78gb)
5= NTFS (553gb)

then three other 1TB hard drives with a single partition each.

I boot the Primary partitions with a bootmanager, GAG from SourceForge.

GAG has been set to "Hide Primary Partitions", which means that when I boot into Win7 x86, it will hide both Win7 x64 and WinXP x86 etc.

I eventually discovered that the MountStorePE script when active, had strange effects on the detection of partitions. Not only did MountStorePE allow access to the hidden Primary partitions and assign a drive letter after all the unhidden partitions, but it hid the first Logical partition as well, that is - it hid the Fat32 Logical partition yet the following NTFS partition was accessible as normal.

The first Logical partition was therefore inaccessible and no drive letter was assigned with the default setting of the MountStorePE script.

The solution was to either disable completely the MountStorePE script or to - Set "USB Only" so the effects of this script will be limited only to USB drives and not the Physical installed computer hard drives.

I have tried BOTH options, totally disabling the script and Usb Only, and both achieve the desired effect.

I assume the hiding of the Logical Fat32 partition is a bug of MountStorePE.

I hope this helps anyone else and I post this here because any search I did could not find anything that indicated my particular symptoms.

9 January 2011 16:11

#2 BobxT



  • Members
  • 82 posts

Posted 09 January 2011 - 05:19 AM

The other thread I referred above to was:

"With BartPE program, how do I add Icon to Desktop"


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users