Jump to content











Photo
- - - - -

Installing .NET Framework 2.0 in NativeEx


  • Please log in to reply
2 replies to this topic

#1 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 244 posts

Posted 05 December 2010 - 01:52 PM

Hi,

I built a NativeEx image with the Windows installer support. Trying to install .NET Framework 2.0 stops after a while and I get the error message below :

25007.Error occurred while initializing fusion. Setup could not load fusion with LoadLibraryShim(). Error: The handle is invalid.


The NativeEx iso is based on Windows XP SP2 English disc. The whole image is running in RAM. Free space in system partition X = 298 Mb

I know there are .NET Framework plugins but I would like install the FW 2.0 package in the NativeEx environment to do some testings.

Is there a way to solve the problem above?

Edited by Vortex, 05 December 2010 - 01:53 PM.


#2 Brito

Brito

    Platinum Member

  • .script developer
  • 10566 posts
  • Location:boot.wim
  • Interests:I'm just a quiet simple person with a very quiet simple life living one day at a time..
  •  
    European Union

Posted 05 December 2010 - 03:24 PM

Hi,

I've moved your topic to the nativeEx section.

Good luck finding a solution.

:worship:

#3 Vortex

Vortex

    Frequent Member

  • Advanced user
  • 244 posts

Posted 05 December 2010 - 03:56 PM

Hi Nuno,

My apologies for creating the topic in the wrong section.

Good news : I solved the problem. Reading the article below was very helpful.

http://blogs.msdn.co.../06/591694.aspx

In the NativeEx environment,the default value of HKEY_LOCAL_MACHINE\SYSTEM\Setup\SystemSetupInProgress is 1. Changing it to 0 before the .NET Framework 2.0 installation fixes all everything.

I was able to run EasyBCD 2.02 after the installation of FW 2.0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users