Jump to content











Photo

PBR & MBR problems with Hirens Boot


  • Please log in to reply
4 replies to this topic

#1 Technotika

Technotika

    Frequent Member


  • Advanced user
  • 419 posts
  • Location:United Kingdom
  •  
    United Kingdom

Posted 14 September 2010 - 09:16 PM

Hello Again Team,
Never long before more trauma hit's my USB.
Well for a split second I was close to ripping my own arms off and feeding them to a duck! :hyper:

Sorry for WAREZ mention but this test is taken with version 11 (WAREZ FREE) I gather.

SUMMARY OF PROBLEM DISCOVERED.
Today I Went to use the DOS PROGRAMS in hiren's to test a HDD in a laptop. Didn't work! error "HBCD folder not found". It was there and as far I can remember I have NEVER had a problem with HIRENS, it's one of the easiest things to get on USB ever and even it started my whole quest to make MULTI usb's.

I started to doubt my work.
So I took my 2gb test USB and flattened it with RMPREP and prepared as MSDOS disk
with no over rides (as I now do with all my projects) and then copied GRLDR from RMPREP and installed Grub4Dos to PBR! Same problem..........

WTF...so what's going on.........

here is the error in action!

Posted Image

It hangs at the CD driver part then errors with message on the right.

So I eventually going through all the changes I tried to remember I went back to PREPARING the drive as usual and this time installed G4D to the MBR and it works!!!

For the record I have tested a different formatting tool (bootice) and the same thing happens with that too, always has to be from a fresh format;
format disk, pbr install fail........format disk, mbr install works, can't just load between mbr/pbr without any format previous otherwise it wont clear the problem.
I also tested on three machines.

Posted Image

Uploaded with ImageShack.us

MAIN QUESTION
You may say, just use MBR then!
No can do as some of the machines I need to boot USB from will only allow me to boot when MBR grub4dos is in use.
I could boot the ISO I suppose but would rather not as I often use the WINTOOLS feature so need the flat folder structure.
Is the anything that can be done about this at all?
Fingers crossed gang

#2 muggles

muggles

    Newbie


  • Members
  • 24 posts
  • Location:New Orleans
  •  
    United States

Posted 14 September 2010 - 09:43 PM

Sorry for WAREZ mention but this test is taken with version 11 (WAREZ FREE) I gather.

Forget Hirens (still warez)...

Grab latest Seatools ISO:
http://www.seagate.c...S221ALL.576.ISO

Extract SeaTools.ima to root

# append to menu.lst

title SeaTools 2.21
find --set-root /SeaTools.ima
map --mem /SeaTools.ima (fd0)
map --hook
chainloader (fd0)+1
rootnoverify (fd0)

#3 Technotika

Technotika

    Frequent Member


  • Advanced user
  • 419 posts
  • Location:United Kingdom
  •  
    United Kingdom

Posted 15 September 2010 - 09:33 AM

You know what - it's a good idea - Alot of these "util" cd's are overkill, half the time you dont need most the things. I always used it for HDD tests as it had the manufacture specific tools all in one place.

I'm going to drop HIRENS and get all the tools myself updated and use them instead.
Will free up 270 mb in the stick too! Thanks"

#4 Icecube

Icecube

    Gold Member


  • Team Reboot
  • 1062 posts
  •  
    Belgium

Posted 16 September 2010 - 10:23 AM

Or you just use UBCD.

#5 steve6375

steve6375

    Platinum Member




  • Amount:

    Developer
  • 6629 posts
  • Location:UK
  • Interests:computers, programming (masm,vb6,C,vbs), photography,TV,films,guitars
  •  
    United Kingdom

Posted 02 August 2011 - 11:09 PM

Hello Again Team,
Never long before more trauma hit's my USB.
Well for a split second I was close to ripping my own arms off and feeding them to a duck! :dubbio:

Sorry for WAREZ mention but this test is taken with version 11 (WAREZ FREE) I gather.

SUMMARY OF PROBLEM DISCOVERED.
Today I Went to use the DOS PROGRAMS in hiren's to test a HDD in a laptop. Didn't work! error "HBCD folder not found". It was there and as far I can remember I have NEVER had a problem with HIRENS, it's one of the easiest things to get on USB ever and even it started my whole quest to make MULTI usb's.

I started to doubt my work.
So I took my 2gb test USB and flattened it with RMPREP and prepared as MSDOS disk
with no over rides (as I now do with all my projects) and then copied GRLDR from RMPREP and installed Grub4Dos to PBR! Same problem..........

WTF...so what's going on.........

here is the error in action!

Posted Image

It hangs at the CD driver part then errors with message on the right.

So I eventually going through all the changes I tried to remember I went back to PREPARING the drive as usual and this time installed G4D to the MBR and it works!!!

For the record I have tested a different formatting tool (bootice) and the same thing happens with that too, always has to be from a fresh format;
format disk, pbr install fail........format disk, mbr install works, can't just load between mbr/pbr without any format previous otherwise it wont clear the problem.
I also tested on three machines.

Posted Image

Uploaded with ImageShack.us

MAIN QUESTION
You may say, just use MBR then!
No can do as some of the machines I need to boot USB from will only allow me to boot when MBR grub4dos is in use.
I could boot the ISO I suppose but would rather not as I often use the WINTOOLS feature so need the flat folder structure.
Is the anything that can be done about this at all?
Fingers crossed gang



This is an old post but just in case... I found this bug in grubinst and it is due to the install code corrupting bytes in the PBR which DOS relies on.
This is fixed by compiling a new version of grubinst (2 Jan 2011) which is now included in later versions of RMPrepUSB, so it should be fixed if you use a newer version.

Bug is reported at http://code.google.c...all/issues/list Bug#8 (but not fixed by chenall/tinybit !).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users