Jump to content











Photo
- - - - -

Autostart PENetwork Manager


  • Please log in to reply
5 replies to this topic

#1 Deek

Deek
  • Members
  • 3 posts
  •  
    United States

Posted 26 August 2010 - 04:15 PM

I'm 2 days in to creating a win7 boot cd using Make_PE3. I'm struggling to figure out how to autostart programs, specifically PENetwork Manager. Optionally, I would like PENetwork manager to run silently, but that's not a deal breaker.

I've searched everywhere for a solution. Should I be using a different program to install my network drivers and load dhcp settings?

Please help! :)

#2 Virtual-R

Virtual-R

    Frequent Member

  • Advanced user
  • 145 posts
  • Location:Stockholm, Sweden
  •  
    Sweden

Posted 26 August 2010 - 11:20 PM

Hello! :)

I also wanted PENetwork manager to autostart and not force me to select anything.
My PENetwork autostarts, finds the network adapter and tries to give the NIC a dynamic IP-adress.
When it it finished with this, it automaticcly closes and windows PE continues to load without any interaction from me.

To do this? Oh well, haha, I am not at work right now, so I will send you the code tomorrow.
Reply to this so I get reminded tomorrow.

Greetings from Robert

#3 wimb

wimb

    Platinum Member

  • Developer
  • 2550 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 27 August 2010 - 07:18 AM

You can modify startnet.cmd in Make_PE3\PE3_mod\PE3_add\x86\Windows\System32

See also Customize_Info.txt in Make_PE3\Help_Info

You can add autostart of PENetwork .exe to startnet.cmd

.......



:: start "Driver Fix PE3 - Wait ...." /wait "%SystemRoot%\System32\driver_fix.cmd"



:: start "Audio Fix PE3 - Wait ...." /wait "%SystemRoot%\System32\audio_fix.cmd"



"%programfiles%\PENetwork\PENetwork.exe"



rem Pre-Default Group



.......

To auto close PENetwork after booting needs may be some setting in PENetwork.ini :)
May be someone else knows how to do this ....

Otherwise:
driver_fix.cmd can also be used to auto start the network
Just remove the leading :: to activate the command

#4 Deek

Deek
  • Members
  • 3 posts
  •  
    United States

Posted 27 August 2010 - 12:34 PM

Awesome. I'll give it a try and report back.

Thanks!

#5 Deek

Deek
  • Members
  • 3 posts
  •  
    United States

Posted 27 August 2010 - 02:45 PM

Running the driver_fix.cmd did not start networking services automatically, however adding "%programfiles%\PENetwork\PENetwork.exe" to the startnet.cmd file works great.

If I could get PENetwork to close after it does its business I'd be set.

Thanks guys

#6 Virtual-R

Virtual-R

    Frequent Member

  • Advanced user
  • 145 posts
  • Location:Stockholm, Sweden
  •  
    Sweden

Posted 27 August 2010 - 07:31 PM

Hello, sorry I was too busy at work today.

But the solution is here in the forum.

It's a registry-setting that you shall add in penetwork.script. Wait... Searching forum...

Here it is:

http://www.boot-land...=110#entry91685




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users