Jump to content











Photo
- - - - -

PrePE - fast boot PE


  • Please log in to reply
82 replies to this topic

#76 smx06

smx06

    Member

  • Members
  • 41 posts

Posted 02 April 2012 - 10:35 AM

ps Plz advise how to make grldr find MENU.LST when it is uppercased and not found in that case.

#77 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15106 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 April 2012 - 11:16 AM

ps Plz advise how to make grldr find MENU.LST when it is uppercased and not found in that case.

Which version of grub4dos are you using? :dubbio:
The issue has been solved some time ago, if you need ot use an old version, you will need to edit the "embedded menu.lst" in grub.exe or grldr (near the end of the file) see:
http://reboot.pro/9696/page__st__6

:cheers:
Wonko

#78 smx06

smx06

    Member

  • Members
  • 41 posts

Posted 02 April 2012 - 11:41 AM

http://reboot.pro/14...post__p__125391
seems describes good this booting phase

#79 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15106 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 April 2012 - 12:03 PM

http://reboot.pro/14...post__p__125391
seems describes good this booting phase

Yes :thumbsup: but it doesn't "touch" the case of removable device or CD-ROM. :(

Another test to be made IMHO is the use of a "isohybrid" build, see here:
http://reboot.pro/9916/
(as always, just semi-random ideas, I really dont know if it can be of any use or if it will resolve in yet another "red herring" :ph34r:)

JFYI:
http://en.wikipedia....iki/Red_herring

:cheers:
Wonko

#80 smx06

smx06

    Member

  • Members
  • 41 posts

Posted 02 April 2012 - 12:27 PM

this description above seems covers our case
i tried to run setupldr excluding in setupreg.hiv setupdd.sys
and it got the exactly same bsod in exactly same function..

and inside setupdd.sys there is "arcname" string
so it seems prepares arcanme namespace for later stage
so this functionality must be reproduced in case of booting with ntldr
(setupdd.sys is absent on installed OS afaik)

#81 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15106 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 02 April 2012 - 03:22 PM

You mean you removed key:
HKEY_LOCAL_MACHINESystemControlSet001Servicessetupdd
from SETUPREG.HIV?
And what happens if you re-add this to %SystemRoot%System32ConfigSystem?

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINESystemControlSet001Servicessetupdd]
@=hex:00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
"group"="drivers"
"start"=dword:00000000
"tag"=dword:00000001
"type"=dword:00000001


:unsure:
Seemingly it is a service like anyone else, having it Start=0 it should start allright:
http://support.micro...kb/103000/en-us
(though cannot say if NTLDR has code "hooking it", like you found out SETUPLDR.BIN has)


:cheers:
Wonko

#82 smx06

smx06

    Member

  • Members
  • 41 posts

Posted 03 April 2012 - 08:57 AM

maybe shall try later; for my task is not acceptable as setupdd is absent in installed XP
about reg key - yes

Edited by smx06, 03 April 2012 - 08:58 AM.


#83 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15106 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 03 April 2012 - 07:04 PM

maybe shall try later; for my task is not acceptable as setupdd is absent in installed XP
about reg key - yes

But -again - it is included in the downloadable XP RC files....:whistling:

:cheers:
Wonko




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users