Jump to content











Photo
- - - - -

fsredir v1.0.1


  • Please log in to reply
35 replies to this topic

#26 Aye Htay

Aye Htay

    Frequent Member

  • Advanced user
  • 163 posts
  •  
    Myanmar

Posted 22 February 2011 - 09:06 PM

Can anyone upload the file in Mediafire, please?
I tried to download it 2 days ago.
But not succeeded yet.

Thanks.

ah

#27 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 22 February 2011 - 09:28 PM

http://www.mediafire...32hhoh1o61d2mo2

#28 Aye Htay

Aye Htay

    Frequent Member

  • Advanced user
  • 163 posts
  •  
    Myanmar

Posted 22 February 2011 - 11:02 PM

Thank you. :dubbio: MedEvil.
I've got it now.

Regards.

ah

#29 Aye Htay

Aye Htay

    Frequent Member

  • Advanced user
  • 163 posts
  •  
    Myanmar

Posted 23 February 2011 - 02:56 PM

Hi Syahmi,

First, I want to say thank you for your driver.
It partialy works for me.
It shrinked my ramdisk from 2.0gb to 1.6 when I tested the first time.
I moved DotNet folder + Assembly folder into fsredir\Windows folder.
While running windows, I found 2 folders of same name "Windows" in root.
When I moved Program Files into fsredir folder second time testing, it can't recornise Program Files at all. So I think it is Folder namespace issue but not sure.
Or the driver redirect only 1 folder???? :dubbio:
If I get time, I'll try more and more again.

Regards,

ah

#30 Syahmi

Syahmi

    Newbie

  • Members
  • 15 posts
  •  
    Malaysia

Posted 23 February 2011 - 03:21 PM

Hi Aye Htay, thanks for reporting this issue.

It is a bug in the driver, I will see what can I do.

While running windows, I found 2 folders of same name "Windows" in root.

The driver doesnt handling duplicate file name yet. I completely forgot about this :dubbio:

When I moved Program Files into fsredir folder second time testing, it can't recornise Program Files at all. So I think it is Folder namespace issue but not sure.

Do you mean that you cannot open program files?

#31 Aye Htay

Aye Htay

    Frequent Member

  • Advanced user
  • 163 posts
  •  
    Myanmar

Posted 23 February 2011 - 05:18 PM

Yes, none of the software in Program Files are working.
From Adobe readery to MS Office application, error shows up "there is no specific file or folder bla bal"

Regards,

ah

#32 VV2006

VV2006

    Member

  • Members
  • 43 posts
  • Location:Russia
  •  
    Russian Federation

Posted 24 February 2011 - 10:45 AM

Actually, the idea is very interesting. This is a convenient thing for the rapid expansion of the PE functional.
But sorry, there are bugs with duplicate folders. Sometime Explorer does not load as shell - stopped with Memory Errors.

#33 Aye Htay

Aye Htay

    Frequent Member

  • Advanced user
  • 163 posts
  •  
    Myanmar

Posted 25 February 2011 - 12:57 AM

Hi Syahmi,

Tried some more time.
Noticed that if the program doesn't depend on Windows system files, it works well.
For example, Acrobat Reader, vlc player, wordpad.exe, 7zip, ....
Like Office2007, it showed well but doesn't work at all.
Other installer files like .msi files are not working at all.
I tried with MSOCache, seems all files are in root folder. But when office reinstalls, it doesn't work. Error shows .msi file is currupted.
And also, duplicate folders appear. If files are duplicated with fsredir, it doesn't work.
I have to delete the duplicated in fsredir.
Please consider for system files and duplicate folders. Others seem to work for me.

Regards.

ah

#34 Syahmi

Syahmi

    Newbie

  • Members
  • 15 posts
  •  
    Malaysia

Posted 28 March 2011 - 07:05 AM

Hi, sorry for taking too long. I released a new version which fix duplicate file folder and new configuration file format. See: http://write-code.bl...redir-v110.html

Download:
[fsredir_x86_v110.zip] [mirror]

Other installer files like .msi files are not working at all.

I'm unable to test this right now :thumbsup: Hope this version will fix it.

Edited by Syahmi, 28 March 2011 - 07:06 AM.


#35 VV2006

VV2006

    Member

  • Members
  • 43 posts
  • Location:Russia
  •  
    Russian Federation

Posted 03 April 2011 - 01:00 PM

I tried fsredir with BartPE. Unsuccessfully. BSoD 0x7E after a short time after the appearance of the desktop. If I change the startup type to 0x4, "ControlSet001 \ services \ fsredir", "Start", 0x00000003, then the boot is ok, but when I start the driver manually get the same BSoD. ((
Spoiler

Edited by VV2006, 03 April 2011 - 01:02 PM.


#36 Syahmi

Syahmi

    Newbie

  • Members
  • 15 posts
  •  
    Malaysia

Posted 03 April 2011 - 01:47 PM

Thanks for reporting, I will release new version shortly for you to test.

EDIT: Please try this test version http://www.mediafire...d45fh6qosp68qan thanks

Edited by Syahmi, 03 April 2011 - 01:50 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users