Jump to content











Photo
* * * * * 4 votes

Make-PE3 Program to Create Portable Windows 7 PE

7pe tutorial

  • Please log in to reply
867 replies to this topic

#76 magic12kenneth

magic12kenneth

    Member

  • Members
  • 79 posts
  •  
    United States

Posted 14 July 2010 - 09:58 PM

Wimb,

Does your WinPE project able to add programs to the build? If yes, how do you do that? I would like to add Acronis Home 2010 v13 and a virus scanner to the build. Thanks.

Ken

#77 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 17 July 2010 - 10:17 AM

*** Update of Make_PE3 package to Create Portable Windows 7 PE ***

  • Added - vwifibus.sys is copied to inf folder next to netvwifibus.inf which enables driver install needed for some WLAN - Ralink RT2860
  • Changed - Limited search for PStart and ASuite to avoid cardreader empty drive issue (press Continue)
  • Changed - Set system profile to X:\Users\Default instead of \system32\config\systemprofile
    This determines also the place for Desktop icons and will avoid x64 and x86 apps see a different profile.
  • Changed - Windows Explorer Shortcut such that USB-drives when connected after boot are recognised.
  • Changed - Program Version - latest version is now 1.4
Thanks to JFX for helpful support :thumbup:
http://www.911cd.net...o...23931&st=15

Most interesting x64 build is 312 MB 7pe_amd.iso made directly from winre.wim on Selected x64 Windows 7 drive
It has Wireless Internet with IE8 and Wordpad, Paint and Photo Viewer working



@magic12kenneth
Yes you can add your own programs.
Create folder to add files in Make_PE3\PE3_mod\PE3_add\x86\Program Files
Add registry in PE3-SYSTEM_CUSTOM.reg and PE3-SOFTWARE_CUSTOM.reg

Read also the given file Customize_Info.txt

And have a look at work of oriensol
http://www.boot-land...showtopic=11819

:thumbup:


#78 magic12kenneth

magic12kenneth

    Member

  • Members
  • 79 posts
  •  
    United States

Posted 18 July 2010 - 05:34 AM

Thanks Wimb, I'll take a look at it. I just need to acronis true image 2010 v13.0.

Ken

#79 hht168

hht168
  • Members
  • 1 posts
  •  
    China

Posted 19 July 2010 - 03:45 PM

Wimb,There are something wrong. I use your latest program "Make_PE3" to make a pe3_x86.iso. MY locale is chinese-cn.
I select "INCL" for "Reduce size of iso".I make the pe3_x86.iso file successfully. But unfortunately,I find
there are nothing chinese fonts in boot.wim,such as SIMSUN.ttc etc.
Please tell me why?

#80 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 22 July 2010 - 09:27 AM

Initially you should use the NO Reduce Size of iso setting.

The INCL Optimize files and EXCLude files PE3_del_files.txt and PE3_del_folders.txt in folder Optimize
are recorded and specified for en-US only.
So the INCL Optimize files need to be adapted to the files present in your pe3_x86.iso

You can make and use as source a dirlist of all files and folders present in boot.wim
You can use manual commands like this:

imagex.exe /mountrw C:\winpe3_x86\ISO\sources\boot.wim 1 C:\winpe3_x86\mount



dir /ad /b /on /s >x86_Fol_boot.txt



dir /b /on /s >x86_Fil_boot.txt



imagex.exe /unmount C:\winpe3_x86\mount

So INCL Optimization requires some manual steps in your case.
EXCL is rather easy to use: you just specify the files and folders that you want to remove.

#81 overburn

overburn
  • Members
  • 6 posts
  •  
    United States

Posted 26 July 2010 - 05:58 PM

I noticed that the ramdrive from BartPE will not work on Make_PE3. Is there another ramdrive that will work and install at bootup for the Make_PE3?

I need a B:\RAMDRIVE to run programs

#82 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 26 July 2010 - 11:27 PM

overburn

imdisk available to install inside Make-PE3 (there should be a shortcut around),
after installing imdisk, create ramdrive with size you want with the letter (B:) you like.

#83 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 01:38 PM

Wimb i'm not happy with your program.
I wanted to build a PE on a XPSP2 machine with WAIK installed.
No problem for all the other Win7 projects, but yours has a problem with finding wimserv.exe, no matter if i choose:
- Get Win7 files - and use AIK to Make pe3.iso
or
- Get Win7 files - and without AIK Make pe3.iso

Why doesn't it get the file from the Source, when i select without AIK? :cheers:

Why does Make_PE need 3GB of free space, even when the Source files are already copied to the HDD?
No other project asks for or needs so much free HDD space.

:)

#84 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 02:15 PM

Wimb i'm not happy with your program.
I wanted to build a PE on a XPSP2 machine with WAIK installed.
No problem for all the other Win7 projects, but yours has a problem with finding wimserv.exe, no matter if i choose:
- Get Win7 files - and use AIK to Make pe3.iso
or
- Get Win7 files - and without AIK Make pe3.iso

Why doesn't it get the file from the Source, when i select without AIK? :cheers:

Why does Make_PE need 3GB of free space, even when the Source files are already copied to the HDD?
No other project asks for or needs so much free HDD space.

:)

Why is everything going wrong for you ?

Is your WAIK properly selected ?
In that case the program will copy all the necessary tools from WAIK to Make_PE3\AIK_Tools\x86 and use these.

Is your Windows 7 Source selected ?
If your Windows 7 files are already in a folder on HDD then there is no need for 3 GB of free space.
Such free space is only required if your source is DVD and you need to have space for mounting install.wim

I really don't understand why you have such problems.
Please explain to me why it is happening this way for you.
Never got this type of problem reported before ....

The best way is Not to select DVD as source,
but Select as Source - Drive where 32-bits Windows 7 is Installed - Or Folder with content of such drive
Then no WAIK needed and no mounting of install.wim needed
Much easier this way.

#85 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 02:39 PM

Why is everything going wrong for you ?

I wish i knew.

Is your WAIK properly selected ?
In that case the program will copy all the necessary tools from WAIK to Make_PE3\AIK_Tools\x86 and use these.

Yes it is properly selected, however the wimserv.exe is not found.

If i select without AIK, MakePE expectets to find the file in system32?
Can i just copy the file there or is MakePE expecting a bunch of other files too?

Is your Windows 7 Source selected ?
If your Windows 7 files are already in a folder on HDD then there is no need for 3 GB of free space.
Such free space is only required if your source is DVD and you need to have space for mounting install.wim

I used to have only 2,8GB free and the MakePE.exe complained about that and did not continue.
I had to free up some more space before it would continue.

I really don't understand why you have such problems.
Please explain to me why it is happening this way for you.

Looks like you expect people to have Win7 as a host OS, at least for the build without AIK option.

:cheers:

#86 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 02:46 PM

Looks like you expect people to have Win7 as a host OS, at least for the build without AIK option.

No,
Make_PE3 does Not expect Win7 to be the host OS.
Most of my test were done with XP as OS.
But also in this case:

The best way is Not to select DVD as source,
but Select as Source - Drive where 32-bits Windows 7 is Installed - Or Folder with content of such drive
Then no WAIK needed and no mounting of install.wim needed
Much easier this way.



#87 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 03:06 PM

No,
Make_PE3 does Not expect Win7 to be the host OS.
Most of my test were done with XP as OS.
But also in this case:

Sorry misunderstood you there. I thought you've meant a folder with the contents of a Win7 DVD, but you really mean a folder with the contents of a installed Win7.

Sorry not possible. The build machine does not have a sufficient big HDD to install a Win7 without deleting all the other Win7 projects.

btw. Where is the difference between needing a Win7 as host OS and needing a folder with the contents of an installed Win7?
It's not like one can download the contents of an installed Win7 form the web. So i need to install it anyway. :cheers:

My tip, for future development, would be, to use 7zip to extract the needed tools from the source, no matter if it is the AIK or a Win7 DVD, instead of expecting the user to have his machine set up the way you expect.

:)

#88 vvurat

vvurat

    Frequent Member

  • Advanced user
  • 319 posts

Posted 29 July 2010 - 04:19 PM

Sorry misunderstood you there. I thought you've meant a folder with the contents of a Win7 DVD, but you really mean a folder with the contents of a installed Win7.

Sorry not possible. The build machine does not have a sufficient big HDD to install a Win7 without deleting all the other Win7 projects.

btw. Where is the difference between needing a Win7 as host OS and needing a folder with the contents of an installed Win7?
It's not like one can download the contents of an installed Win7 form the web. So i need to install it anyway. :cheers:

My tip, for future development, would be, to use 7zip to extract the needed tools from the source, no matter if it is the AIK or a Win7 DVD, instead of expecting the user to have his machine set up the way you expect.

:)


you can mount install.wim to a folder with imagex and show that folder. don't need especially "installed" one. but i can't succeed any of the newer builds after waikless options added.

#89 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 04:45 PM

you can mount install.wim to a folder with imagex and show that folder. don't need especially "installed" one. but i can't succeed any of the newer builds after waikless options added.

Yes, you can also use as source a folder of mounted install.wim

Does that mean that you cannot with WAIK build pe3_x86.iso anymore
(by using option 4 of Make_PE3.cmd or second radio-button of Make_PE3.exe) ?
That would be very strange, since there was AFAIK no important change in the routines for making pe3_x86.iso

Or do you mean that you cannot make 7pe_x86.iso where WAIK is not used ?
That is a separate new routine added to the program.

7pe_x86.iso = Win7 Recovery ISO with Windows 7 GUI , and made from Winre.wim or boot.wim and without AIK
pe3_x86.iso = AIK Windows PE 3.0 with Windows 7 GUI , and made from winpe.wim by using AIK

#90 vvurat

vvurat

    Frequent Member

  • Advanced user
  • 319 posts

Posted 29 July 2010 - 04:57 PM

pe3_x86.iso and 7pe_x86.iso are they different things? what is difference? just i interested in if anybody else then you can succesfully build it under xp host. your solution was my host operating system not works as expected. maybe i can build with waik didn't test that. i want to build without waik under xp.

Or do you mean that you cannot make 7pe_x86.iso where WAIK is not used ?
Yes. Problem is this. Exact problem is registry settings doesn't import to registry

#91 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 05:12 PM

pe3_x86.iso and 7pe_x86.iso are they different things? what is difference? just i interested in if anybody else then you can succesfully build it under xp host. your solution was my host operating system not works as expected. maybe i can build with waik didn't test that. i want to build without waik under xp.

Or do you mean that you cannot make 7pe_x86.iso where WAIK is not used ?
Yes. Problem is this. Exact problem is registry settings doesn't import to registry

pe3_x86.iso and 7pe_x86.iso are quite different, see previous post.

If you did not test to build with WAIK (the old routine),
then your statement should have been that you cannot make use of the newly added options to build without WAIK. :cheers:

Remains the question, why do the newly added routines don't work for you.
I remember you had Dism errors.
May be check if there is a difference in version of Dism in folder C:\Make_PE3\AIK_Tools\x86\Dism
as compared to Dism in C:\Program Files\Windows AIK\Tools\Servicing

#92 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 05:22 PM

Remains the question, why do the newly added routines don't work for you.

Could it be, because XP does not have a wimserv.exe in Windows\system32 like MakePE expects, like in my case?

:cheers:

#93 vvurat

vvurat

    Frequent Member

  • Advanced user
  • 319 posts

Posted 29 July 2010 - 05:23 PM

as i see it mounts registry to HKLM\PE3-SYSTEM it can be a mount registry problem, if it mounts as espected there can be a registry write problem. i need check. as i know you cant event make a new key to HKLM root because of permissions. other dism problem is importing wireless drivers with dism not so important after it work.

Could it be, because XP does not have a wimserv.exe in Windows\system32 like MakePE expects, like in my case?
dism was just working file only not at wireless.

will test with put a pause commands when i have errors. will see what wrong.

#94 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 05:26 PM

7pe_x86.iso = Win7 Recovery ISO with Windows 7 GUI , and made from Winre.wim or boot.wim and without AIK
pe3_x86.iso = AIK Windows PE 3.0 with Windows 7 GUI , and made from winpe.wim by using AIK

btw. Just like vvurat, i can't see the difference in the endresult from this description. Just that different wim were used as starting points.

:cheers:

#95 vvurat

vvurat

    Frequent Member

  • Advanced user
  • 319 posts

Posted 29 July 2010 - 05:38 PM

*** Dism is changing PE Locale Settings to en-US ***

LOAD HKLM\PE3-SYSTEM reg to add PE3-SYSTEM_WLAN.reg and PE3-SYSTEM_LANMAN.reg


Error: Unknown Return Code 317
PE3-SYSTEM_CUSTOM.reg added to HKLM\PE3-SYSTEM


Error: Parametre hatali.
*** LOAD HKLM\PE3-SOFTWARE registry and ADD PE3-SOFTWARE_WLAN.reg ***

*** LOAD HKLM\PE3-SOFTWARE registry and ADD PE3-SOFTWARE_CLID.reg ***


Error: Unknown Return Code 317
Devam etmek için bir tusa basin . . .

just same errors also locale should be tr-TR when file copy it was working ok with locale but here at registry part it says en-US

reg load HKLM\PE3-SYSTEM "%PEWork%\mount\Windows\System32\config\SYSTEM" >nul
is can not find my
C:\Make_PE3\win7pe_x86\mount\Windows\System32\config\SYSTEM

i manually try and

C:\Documents and Settings\vvurat>reg load HKLM\PE3-SYSTEM "C:\Make_PE3\win7pe_x86
\mount\Windows\System32\config\SYSTEM" >nul

Error: Unknown Return Code 317

there is C:\Make_PE3\win7pe_x86\mount\Windows\System32\config\SYSTEM hive in that location

any idea?

317 The system cannot find message text for message number 0x%1 in the message file for %2.


ECHO.
ECHO *** Dism is changing PE Locale Settings to %Lang% ***

IF "!Lang!" NEQ "en-US" (
%DISM_TOOL% /image:"%PEWork%\mount" /Set-InputLocale:%Lang%
%DISM_TOOL% /image:"%PEWork%\mount" /Set-SysLocale:%Lang%
%DISM_TOOL% /image:"%PEWork%\mount" /Set-UserLocale:%Lang%
)

why it need to change locale settings? if i build from my language dvd it will have all locale and languages in my language default. Nobody will want to build en-US localized tr-TR wim. useless codes

#96 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 05:53 PM

Could it be, because XP does not have a wimserv.exe in Windows\system32 like MakePE expects, like in my case?

:cheers:

What version of WAIK is installed in your case ?

Required for making pe3_x86.iso - AIK for Windows 7 - KB3AIK_EN.iso - Microsoft - Windows PE 3.0
http://www.microsoft...;displaylang=en
Dism.exe of AIK must be version 6.1.7600.16385 (earlier version 7000 gives Errors)



#97 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 07:32 PM

What version of WAIK is installed in your case ?

:cheers: Why would it be important which version is installed, when i choose option 'without AIK'?
'Without AIK' should mean 'no WAIK required' or 'WAIK ignored / not used'.
If it means something else please enlighten me.

Anyway, MakePE.exe gives in this case the error, that it can't find wimserv.exe in windows\system32, which is completely plausible, since the hostOS is a XP and a XP does not have this file.

Somehow the logic of that exe is strange or i simply don't understand the option right.


What i wanna do:
Build on a XP host, without need for WAIK, a 7pe_x86.iso from a folder containing the contents of a Win7 DVD.
Possible? If so, how?


:)

#98 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 08:00 PM

:cheers: Why would it be important which version is installed, when i choose option 'without AIK'?

Again what version of WAIK is installed in your case ?

All info was already in post #1 ......

32-bits Windows 7 Setup DVD can be used as well as Source, but requires for XP to auto-collect AIK_Tools,
by Running once Make_PE3 in Windows 7 Or in environment with Installed Windows 7 AIK
AIK_Tools folder in Make_PE3 is the place where used tools as Dism.exe and imagex.exe are collected.

The logic is that for XP OS you have to to auto-collect AIK_Tools and these tools must be the right version.

Make a fresh start.
Remove old Make_PE3 folder with already collected wrong tools.
Uninstall old WAIK and Install WAIK for Windows 7
Then run the downloaded Make_PE3.exe to extract as folder Make_PE3
Then run Make_PE3.exe or Make_PE3.cmd from Make_PE3 folder and use options to build 7pe_x86.iso
The needed Tools are collected in AIK_Tools folder on first run of the programs.

#99 MedEvil

MedEvil

    Platinum Member

  • .script developer
  • 7771 posts

Posted 29 July 2010 - 08:17 PM

Ok, now i get it. Sorry for being so dense.
You just call it 'without AIK' but in reality, AIK is still needed to collect the tools from.

If your project needs a different WAIK from the one i've got installed, i need to set up a different computer to test your project, cause the WAIK installed, is exactly the version the other projects do require.

Sorry for wasting your time.


:cheers:

#100 wimb

wimb

    Platinum Member

  • Developer
  • 2599 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 July 2010 - 08:44 PM

Ok, now i get it. Sorry for being so dense.
You just call it 'without AIK' but in reality, AIK is still needed to collect the tools from.

If your project needs a different WAIK from the one i've got installed, i need to set up a different computer to test your project, cause the WAIK installed, is exactly the version the other projects do require.

Sorry for wasting your time.


:cheers:


Only in case of XP OS and setup DVD as Source (your selected case),
then Make_PE3 needs to collect once tools from WAIK for Windows 7 or from drive where Windows 7 is installed

In case of XP OS and drive where Windows 7 is installed as source then WAIK is not needed
Also of course in case of Windows 7 OS then WAIK is not needed.
In these cases Dism tool is collected from drive where Windows 7 is installed.

:cheers:





Also tagged with one or more of these keywords: 7pe, tutorial

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users