Jump to content











Photo
- - - - -

Syslinux - normal boot from local hard drive?


  • Please log in to reply
10 replies to this topic

#1 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 08 June 2010 - 09:15 AM

Hi,

I was using Unetbootin to create the usb-flash Ubuntu 10.04. As far as i am aware, as loader syslinux's part - ldlinux is used along with syslinux.cfg configuration file.

Everything works good, but i d like to add to an entry to syslinux.cfg "boot from local hard drive".

Here the problem starts:

Reading the manual gave me directions to use "localboot" option. Problem is that its works only on 5 % of all pc's i ve been using. Anyone here maybe have a tip how to make 95% normal boot chance?

#2 mrt_doulaty

mrt_doulaty
  • Members
  • 7 posts
  •  
    Iran

Posted 08 June 2010 - 10:36 AM

Have you tried using com chain?

Modify your syslinux.cfg file and add this entry (also remember to copy chain.c32 to your bootable media):

LABEL Boot from hard disk
COM32 chain.c32
APPEND hd0 1

#3 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 09 June 2010 - 08:16 AM

Have you tried using com chain?

Modify your syslinux.cfg file and add this entry (also remember to copy chain.c32 to your bootable media):

LABEL Boot from hard disk
COM32 chain.c32
APPEND hd0 1

thx for reply :)

Yeah, i did with different configurations of hd (hd0 0, hd 0 1). And its complelety not working, saying something like "chainload failed".

#4 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 09 June 2010 - 12:24 PM

If your USB is hd0, I would recommend that you use hd1 to mean your computer's internal HDD. You will also wish to APPEND the swap parameter.

#5 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 10 June 2010 - 08:39 AM

If your USB is hd0, I would recommend that you use hd1 to mean your computer's internal HDD. You will also wish to APPEND the swap parameter.


u mean:

LABEL Boot from hard disk
COM32 chain.c32
APPEND hd1 0 //(hd1 1)

how the hell to append the swap if Append section is already in "use"?
Is there some logical "append this and this"?

#6 Sha0

Sha0

    WinVBlock Dev

  • Developer
  • 1682 posts
  • Location:reboot.pro Forums
  • Interests:Booting
  •  
    Canada

Posted 10 June 2010 - 12:31 PM

LABEL hdd

  COM32 chain.c32

  APPEND hd1 1 swap
Note that partitions are numbered starting from 1, not zero. So the above means second HDD (which BIOS has pushed your internal HDD as, when booted from USB), first partition. You may use zero or omit a partition number entirely to boot the MBR of that disk. You cannot include spaces in your LABEL.

#7 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 11 June 2010 - 07:55 AM

LABEL hdd

  COM32 chain.c32

  APPEND hd1 1 swap
Note that partitions are numbered starting from 1, not zero. So the above means second HDD (which BIOS has pushed your internal HDD as, when booted from USB), first partition. You may use zero or omit a partition number entirely to boot the MBR of that disk. You cannot include spaces in your LABEL.


thx,i ll check it and reply.

Addon.

Ok,this 2 options works for me:

LABEL btl
MENU LABEL Boot to Nearby Next Loader
localboot -1

LABEL btw
MENU LABEL Boot Direclty to Windows
com32 chain.c32
append hd1 1 swap

1-st option taken from syslinux docs. In this case, as far as i uderstood loader sends command to BIOS that it "failed", and control is taken by BIOS. In my case (i have ubuntu and win7 installed) GRUB2 loader appears.

2-nd proposed by Shao works great. In one change - it boots directly win7 avoiding the GRUB2 loader.

Anyway,it was a good job, good tips.

Thank you all :D

#8 Icecube

Icecube

    Gold Member

  • Team Reboot
  • 1062 posts
  •  
    Belgium

Posted 13 June 2010 - 09:34 AM

When you want to boot grub2 (installed in the MBR) with chain.c32, when you booted from USB, don't use "swap".
LABEL grub2_in_mbr

  COM32 chain.c32

  APPEND hd1
If you add "swap", grub2 will not boot completely (at least not on my PC), for some unknown reason==> bad grub2 :):
LABEL grub2_in_mbr

  COM32 chain.c32

  APPEND hd1 swap


#9 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 13 June 2010 - 10:05 AM

When you want to boot grub2 (installed in the MBR) with chain.c32, when you booted from USB, don't use "swap".

LABEL grub2_in_mbr

  COM32 chain.c32

  APPEND hd1
.....


Funny thing is that when i use this config line, grub2 is not working.. works only as i wrote before. lol?

#10 Icecube

Icecube

    Gold Member

  • Team Reboot
  • 1062 posts
  •  
    Belgium

Posted 13 June 2010 - 10:29 AM

Maybe it is fixed in grub2 that ships with Ubuntu 10.04 (which would be good news). I am still using 9.10.

#11 leshcat

leshcat

    Newbie

  • Members
  • 17 posts

Posted 13 June 2010 - 10:43 AM

Maybe it is fixed in grub2 that ships with Ubuntu 10.04 (which would be good news). I am still using 9.10.


my bad,just woke up and misunderstood... the 2-nd option i mentioned upper, (append hd1 1 swap) boots my win7 avoiding grub2 loader. The 1-st option (localboot -1) forces the grub loader menu appear.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users