Jump to content











Photo
- - - - -

FileCreateBlank


  • Please log in to reply
3 replies to this topic

#1 Virtual-R

Virtual-R

    Frequent Member

  • Advanced user
  • 145 posts
  • Location:Stockholm, Sweden
  •  
    Sweden

Posted 21 April 2010 - 10:42 AM

Getting this since running Winbuilder 081 Beta 1, i did not have this error in 080. I am running NativeEx_Win7:

Run - Processed section [Read_ENV2] in file: [%BaseDir%\Projects\nativeEx_Win7\Common_api.script]
[Success] IF - File does not exist: [%BaseDir%\Build\TargetNative\windows\system32\winpeshl.ini] evaluated string: [If,NotExistFile,%TargetDir%\windows\system32\winpeshl.ini,FileCreateBlank,%TargetDir%\windows\system32\winpeshl.ini]
[Success] FileCreateBlank - Created a new file: [%BaseDir%\Build\TargetNative\windows\system32\winpeshl.ini]
[Success] IF - File does not exist: ["%BaseDir%\Build\TargetNative\windows\system32\shortcut.inf"] evaluated string: [If,NotExistFile,%ES%,FileCreateBlank,%ES%]
[Failed] FileCreateBlank - Failed to create a new file: ["%BaseDir%\Build\TargetNative\windows\system32\shortcut.inf"] : The filename, directory name, or volume label syntax is incorrect.
[Warning] Halt
[Clock] Script time: 2 seconds and 118 miliseconds

#2 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 21 April 2010 - 11:01 AM

You do not make it easy for me to examine this behaviour.

Please, next time attach the log.
It contains information I need.

e.g. The path "Targetnative": Is this name created by a bug, or is that your personal target? etc. etc.

Can you tell me the script, where this occurs?

BTW: I created a new topic for this bug.

Peter

#3 paraglider

paraglider

    Gold Member

  • .script developer
  • 1729 posts
  • Location:NC,USA
  •  
    United States

Posted 21 April 2010 - 11:33 AM

You can see exactly the same error with win7pe_se:

www.paraglidernc.com/temp/log.7z

#4 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 21 April 2010 - 11:40 AM

Thanks Paraglider.

The issue seems to depend on the fact that the variable %ES% contains enclosing quotes.

In the definition in script.project these quotes are unnecessary, but WinBuilder should remove them.

I'm going to fix.

Peter




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users