Jump to content











Photo
- - - - -

[Fixed] AddInterface does not work when used with run


  • Please log in to reply
3 replies to this topic

#1 pecd.net

pecd.net

    Silver Member

  • .script developer
  • 947 posts
  •  
    Germany

Posted 08 March 2010 - 09:51 AM

This works

[process]
AddInterface,%ProjectDir%\script.project,Interface_settings1,settings1
Echo,%settings1_pScrollBox6%
Message,%settings1_pScrollBox6%,information


This not

[process]
run,%scriptfile%,test

[test]
AddInterface,%ProjectDir%\script.project,Interface_settings1,settings1
Echo,%settings1_pScrollBox6%
Message,%settings1_pScrollBox6%,information

In short: AddInterface does not work when ued by run, works when called by exec...

BTW: Please also add info to wand that a prefix is separated with a _ by addinterface...this is more or less undocumented

#2 Lancelot

Lancelot

    Frequent Member

  • .script developer
  • 5013 posts
  • Location:Turkiye/Izmir
  • Interests:*Mechanical stuff and Physics,
    *LiveXP, BartPE, SherpyaXPE,
    *Basketball and Looong Walking,
    *Buying outwear for my girlf (Reason: Girls are stupid about buying bad stuff to make themselves uglier :))
    *Girls (Lyric: Girl,...., You will be a womann, Soon)
    *Answering questions for "Meaning of life",
    *Helping people,

    Kung with LiveXP, Fu with Peter :)
  •  
    Turkey

Posted 08 March 2010 - 10:08 AM

I confirm both bugs.

First one is clear from ctmag's example. :whistling: :cheers: :unsure:

Second one is:

For AddInterface, wand says:
AddInterface,Filenam[,Interface],Prefix
following ctmag's example, normally one expect

AddInterface,%ProjectDir%\script.project,Interface_settings1,settings1

result with :cheers:

%settings1pScrollBox6%

NOT :cheers: :unsure: :)

%settings1_pScrollBox6%


Since it is not used anywhere yet, I hope it will be fixed soon. Or does winbuilder knows better than what user want :)
Else in some future wb willl need a new escape for the ones who do not want _ in final variable. B)

........

#3 pscEx

pscEx

    Platinum Member

  • Team Reboot
  • 12707 posts
  • Location:Korschenbroich, Germany
  • Interests:What somebody else cannot do.
  •  
    European Union

Posted 08 March 2010 - 05:46 PM

Fixed, Syntax updated.

@Lancelot, in "your language": B)
As I told LOOOOONG time ago, there is only ONE prefix, neither none nor two ones:

AddInterface,%ScriptFile%,m
Then all components of the main interface are added as variables with the prefix 'm_', e.g. %m_pTextBox1%

Peter

EDIT: No entry to magic wand. It should be a short template for usable syntax, mostly usable w/o changes, but no explanations.

#4 homes32

homes32

    Gold Member

  • .script developer
  • 1030 posts
  • Location:Minnesota
  •  
    United States

Posted 09 March 2010 - 02:47 PM

also a minor spelling mistake
AddInterface,Filenam[,Interface],Prefix
should be
AddInterface,Filename[,Interface],Prefix





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users