Jump to content











Photo
- - - - -

System_Info

system usb gpt mbr bios uefi

  • Please log in to reply
126 replies to this topic

#51 Blackcrack

Blackcrack

    Frequent Member

  • Advanced user
  • 446 posts
  •  
    Germany

Posted 09 June 2020 - 07:48 AM

:thumps up: oky

Screen 00002.jpg

 

this was defaut config..

and also as the textfile opened..



#52 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 28 October 2021 - 05:22 AM

Update System_Info-45

 

Download:  System_Info  from GitHub

 

File is is Encrypted with password = bootwimb

 

- System_Info List files are created in folder sys_info

- Hard Link List files are created in folder Hard_Link_List

 

2021-10-28.png == 2021-10-28 (1).png


  • alacran likes this

#53 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 28 October 2021 - 06:30 PM

This are my findings when testing v45 under 10x86 OS.

 

Folder location is under exclusions list on AV. Using AutoIt 3.3.14.5, I converted \System_Info\makebt\au3\System_Info_x86.au3 to \System_Info\System_Info_x86.exe.

 

On 10x86 OS the panel opens fine and almost all programs run fine with some exceptions:

 

Explorer++ and SwithSearch do not run.

 

Sys Info:  always says: Can't find \System_Info\sys_info\PC-X_MS_System_Info.txt, and asks to create a new file. Even if there is an empty \System_Info\sys_info\PC-X_MS_System_Info.txt, if acepting a new file appears PC-X_MS_System_Info_bak.txt, and it closes.

 

Drive info list: same as previous but the file in this case is PC-X_Drive_Info.txt

 

alacran


  • antonino61 likes this

#54 antonino61

antonino61

    Gold Member

  • Advanced user
  • 1229 posts
  •  
    Italy

Posted 28 October 2021 - 06:36 PM

explorer++ does not work for me too, whereas swift search does.



#55 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 28 October 2021 - 06:43 PM

Thanks alacran for testing the System_Info_x86.exe as made by you in 10x86 Windows OS.

 

I have never done such test and understand that more testing is needed by me to improve possibly the program code.

 

What are your test results for the original System_Info_x64.exe ?



#56 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 28 October 2021 - 06:48 PM

Not tested on 10x64 yet, but will do it ASAP.

 

alacran



#57 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 28 October 2021 - 07:23 PM

Tested under Mini-10x64-WB.vhd

Explorer++ and SwiftSearch working fine.

Sys info and Drive info list: same issue as on x86 test.

 

Tested under Win10XPE_x64-WB.vhd

Explorer++ and SwiftSearch working fine.

Sys info,  DirectX Diag, Resource Monitor, Windows Settings and FireWall App are greyed out (I assume greyed because not available under PE).

Drive info list: same issue as on x86 test.

 

alacran



#58 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 29 October 2021 - 08:50 AM

Update System_Info-46

 

Download:  System_Info  from GitHub

 

File is is Encrypted with password = bootwimb

 

- "Sys Info" and "Drive Info List"  - Errors removed that would occur in case of space in Program Path

- Added code to Run Explorer++ x86 version

- System_Info List files are created in folder sys_info

- Hard Link List option Disabled (needs more time to improve the code)

- Added HP System Diagnostics App


  • alacran and antonino61 like this

#59 antonino61

antonino61

    Gold Member

  • Advanced user
  • 1229 posts
  •  
    Italy

Posted 29 October 2021 - 12:11 PM

now, wimb, everything u have repaired works fine.


  • wimb likes this

#60 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 30 October 2021 - 06:30 PM

Testing v4.6 under 10x86 OS.

 

After building \System_Info\System_Info_x86.exe

 

Explorer++, Sys Info and Drive info list are working fine now.

 

SwiftSearch not working fine, it seems it tries to boot SwiftSearch_x64.exe

 

alacran



#61 antonino61

antonino61

    Gold Member

  • Advanced user
  • 1229 posts
  •  
    Italy

Posted 30 October 2021 - 08:47 PM

ah alright - I did not consider x86. so Alacrán must be right.



#62 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 31 October 2021 - 05:44 AM

Testing v4.6 under 10x86 OS.

 

SwiftSearch not working fine, it seems it tries to boot SwiftSearch_x64.exe

 

 

Strange that it does not work, since the code for SwiftSearch_x86.exe seems to be OK

If @OSArch = "X86" Then
	ShellExecute(@ScriptDir & "\SwiftSearch\SwiftSearch_x86.exe")
Else
	ShellExecute(@ScriptDir & "\SwiftSearch\SwiftSearch_x64.exe")
EndIf

What occurs if you don't use the System_Info_x86.exe program, but right-mouse click on and Run as Administrator \SwiftSearch\SwiftSearch_x86.exe program ?

Is SwiftSearch_x86.exe running normal or Not ?

What occurs in C:\Windows\Temp folder ?



#63 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 31 October 2021 - 06:43 AM

What occurs if you don't use the System_Info_x86.exe program, but right-mouse click on and Run as Administrator \SwiftSearch\SwiftSearch_x86.exe program ?

Is SwiftSearch_x86.exe running normal or Not ?

What occurs in C:\Windows\Temp folder ?

If running as Admin it does nothing, if running normal (but user is Admin) see attached picture please.

 

alacran

Attached Thumbnails

  • SwiftSearch_x86.png


#64 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 31 October 2021 - 06:58 AM

It seems you are using an old version of SwiftSearch, just replaced your folder with mine (v7.5.1 2019-07-06) and renamed the *.exe(s) as yours, and now all is working fine, running the x86 from System_Info_x86.exe, no file or folder is created on C:\Windows\Temp folder, but it runs fine now.

 

SwiftSearch Page.

 

Download page: https://sourceforge..../Version 7.5.1/

 

For your convenience I attached my copy of SwiftSearch (v7.5.1 2019-07-06) containing x86 and x64 versions.

 

EDIT: Forgot to comment also HP Diag is working fine.

 

alacran

Attached Files



#65 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 31 October 2021 - 08:37 AM

Thanks alacran for solving the issue of non-working x86 version of SwiftSearch  :) that was caused by using old version of SwiftSearch by me.

 

I will Update the Program Code as to use your supplied Updated SwiftSeach given in the Attachment of previous post.

 

:cheers:


  • alacran likes this

#66 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 31 October 2021 - 10:15 AM

Thanks alacran for solving the issue of non-working x86 version of SwiftSearch  :) that was caused by using old version of SwiftSearch by me.

 

I will Update the Program Code as to use your supplied Updated SwiftSeach given in the Attachment of previous post.

 

:cheers:

 

No problem, my friend, it was my pleasure.

 

It is always good when we help each other to solve an issue, improve some procedure or just help the other person notice something is not working fine, it is nice we can talk freely without hurting feelings, that's why reboot.pro is a so good forum.

 

alacran


  • antonino61 likes this

#67 antonino61

antonino61

    Gold Member

  • Advanced user
  • 1229 posts
  •  
    Italy

Posted 31 October 2021 - 10:24 AM

I do not see how hard feelings could possibly come into it, of course I do appreciate the absence of hard feelings, that is why I have always taken it for granted. So pls, when u do not understand my convoluted language, pls ask for clarification, and I will be willing to cooperate.

 

btw. everything working fine so far, with the only exception of the central application (hardlink list) which wants further coding, if I have understood correctly.



#68 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 31 October 2021 - 10:36 AM

Update System_Info-47

 

Download:  System_Info  from GitHub

 

File is is Encrypted with password = bootwimb

 

- Update program code for Added SwiftSearch version 7.5.1 as given by alacran here

- Hard Link List button still disabled (working on code that allows spaces in FileName and FilePath e.g. files in C:\Progam Files)


  • alacran and antonino61 like this

#69 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 31 October 2021 - 01:31 PM

System_Info v4.7 tested under Win10XPE_x86.iso

 

After building \System_Info\System_Info_x86.exe

 

SwiftSearch32.exe is working very fine.

 

 

System_Info v4.7 also tested under 7x64 OS

 

All is working fine, of course Windows Settings is greyed out as this is not present in 7 OS.

 

alacran


  • wimb likes this

#70 antonino61

antonino61

    Gold Member

  • Advanced user
  • 1229 posts
  •  
    Italy

Posted 31 October 2021 - 09:28 PM

oh, it's just come to my mind - One thing I think would stand us in good stead if it were on the sys_info panel is a menu.lst pointer, for quick modding or adjusting or updating or whatever, don't u think? I hope it is not hard to add.



#71 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 02 November 2021 - 08:32 AM

oh, it's just come to my mind - One thing I think would stand us in good stead if it were on the sys_info panel is a menu.lst pointer, for quick modding or adjusting or updating or whatever, don't u think? I hope it is not hard to add

 

UEFI_MULTI program is the way to add VHD Boot entries to menu.lst files.

Modifying existing entries is easily done with Notepad Or better with Notepad++

 

So I think there is no need to add Modify menu.lst as option to System_Info program


  • antonino61 likes this

#72 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 02 November 2021 - 08:34 AM

Update System_Info-48

 

Download:  System_Info  from GitHub

 

File is is Encrypted with password = bootwimb

 

- Hard Link List button is working now and allows spaces in FileName and FilePath e.g. files in C:\Progam Files

 

System_Info.png


  • alacran and antonino61 like this

#73 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 4 weeks ago

System_Info v4.8 tested under 10x86 OS

After building \System_Info\System_Info_x86.exe

Hard Link List is working fine. The process may take a long time, so it is better to be patient, I tested it making a list of Hard Links on C:\Windows.

 

Thanks wimb, now System_Info is completed and fully funtional from 7 to 11, on OSs and WinPEs, running on virtual or real drives. With the only exception of greyed options that are not available under certain scenarios.

 

NOTE: Hope wimb don't mind I attached System_Info_x86.exe (maybe useful for some future readers, that may not be able to build their own x86 *.exe in AutoIt), many if not all AV consider almost all AutoIt x86 programs as malware, so better disable your AV before extracting and create an exception for this program in your AV. (Just extact it next to \System_Info\System_Info_x64.exe).

 

File is Encrypted with password = wimb (the user name of program author).

 

alacran

Attached Files


  • wimb likes this

#74 wimb

wimb

    Platinum Member

  • Developer
  • 3473 posts
  • Interests:Boot and Install from USB
  •  
    Netherlands

Posted 4 weeks ago

Thanks wimb, now System_Info is completed and fully funtional from 7 to 11, on OSs and WinPEs, running on virtual or real drives. 

 

Thanks for testing version 4.8

 

System_Info_x86.exe without encryption would give false positive AV problem and that is why it is not included in System_Info-48-E.zip file.

Good that you supply it seperately, which can be useful to those taking special precautions in their AV software.

It brings me to the idea that such Encrypted System_Info_x86.exe can indeed be distributed in System_Info-48 folder without giving the AV problem.


  • alacran and antonino61 like this

#75 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 4 weeks ago

It brings me to the idea that such Encrypted System_Info_x86.exe can indeed be distributed in System_Info-48 folder without giving the AV problem.

 

Yes my friend, it will be good if you include your official x86 build in the download page, maybe as an optional additional download (as there are not many x86 users this days), just like you handle the addons for your other programs, nothing better than download directly from the author of the program, also you could do same thing with WOF_Compress_x86.

 

alacran


  • antonino61 likes this





Also tagged with one or more of these keywords: system, usb, gpt, mbr, bios, uefi

6 user(s) are reading this topic

0 members, 6 guests, 0 anonymous users