Jump to content











Photo
- - - - -

Windows PE 11 - 22621.1 WOW64 Support

winpe windows pe windows 11 pe wow64

  • Please log in to reply
No replies to this topic

#1 MetallicWheat

MetallicWheat
  • Members
  • 2 posts
  •  
    United States

Posted 17 February 2023 - 06:16 AM

Hey everyone, I'm working on a project to make my own Windows PE 11 Version.
I'm currently trying to get 32 bit apps to run on a 64 bit install.
I came across these two guides:
https://reboot.pro/i...showtopic=21197
http://mistyprojects...W64_WinPE10.htm
I followed the latter guide nearly identically

I'm using WinPE 11 22621.1 and for the system files my source is the 22621.1 ISO File

Heres the files I imported:
Entirety of SysWOW64 
Entirety of Sys32\catroot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} 

System32\wow64.dll 
System32\wow64cpu.dll
System32\wow64win.dll
The WinSXS Manifests and other dependencies from the winpe tweaks guide as well as en-us specific versions, 
loadwow64.exe
 
For the registry I imported the sample syswow64.reg listed in the winpe tweaks guide, And changed the BUILD.SPBUILD to 22621.1.
And the following registry hives
Wow6432Node Registry hive from 22621.1
Classes\Wow6432Node Hive from 22621.1
For the two wow6432node files there was 0 instances of C:\ or D:\ in the registry key which was odd.
all of windows\currentversion\sidebyside\ from 22621.1
all of Windows\CurrentVersion\SMI\ from 22621.1
deleted \Microsoft\Active Setup\Installed Components
 
The issue im facing is now, Every 32bit application, When I try to open it using command prompt none open, And when I use the file explorer in notepad>run as administrator I get the error code
"The application was unable to start correctly (0xc0000135)"

Has anyone encountered a similar error? Did I miss something in my original transfer?
 

 



#2 misty

misty

    Gold Member

  • Developer
  • 1065 posts
  •  
    United Kingdom

Posted 17 February 2023 - 06:46 AM

Try the following thread - Custom WinPe build using Microsoft tools only

With registry settings and file dependencies documented in Post #6

:cheers:

misty
  • MetallicWheat likes this

#3 Atari800XL

Atari800XL

    Frequent Member

  • Advanced user
  • 192 posts
  •  
    Netherlands

Posted 18 February 2023 - 07:07 PM

(sorry, deleted)



#4 Atari800XL

Atari800XL

    Frequent Member

  • Advanced user
  • 192 posts
  •  
    Netherlands

Posted 18 February 2023 - 07:09 PM

Misty, thanks for the link to the thread, I don't think I saw that before, will take a look at it tomorrow!!



#5 MetallicWheat

MetallicWheat
  • Members
  • 2 posts
  •  
    United States

Posted 20 February 2023 - 03:03 AM

Try the following thread - Custom WinPe build using Microsoft tools only

With registry settings and file dependencies documented in Post #6

cheers.gif

misty

Thanks Misty!

I added the extra files and the registry entries!
I successfully have wow64 support on WinPE 11!


  • misty likes this

#6 misty

misty

    Gold Member

  • Developer
  • 1065 posts
  •  
    United Kingdom

Posted 20 February 2023 - 07:41 PM

@MetallicWheat
Glad it worked. Thanks for reporting back.





Also tagged with one or more of these keywords: winpe, windows pe, windows 11 pe, wow64

2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users