Jump to content

- - - - -

Bug on packet lost going to the target !?

tftpd32 bug retry ignored

  • Please log in to reply
1 reply to this topic

#1 bgoas

  • Members
  • 2 posts

Posted 06 June 2016 - 03:39 PM


I just had a problem with TFTP32, both with a much older version and the last one from mid 2015 (on Windows 7 64 bits).


From wireshark captures, I can see that sometimes

- packet n (here 7124) went correctly to my device,

- ACK n was received correctly by TFTPD32

-  and packet n+1 was sent by TFTPD32 but not received by my device.


In that case, my device sends again the ACK n after its timeout, as specified by the protocol,

but TFTPD32 only says "Ack block 7124 ignored (received twice)" to each of the retry,

until my device stops asking, instead of sending the again the missing block (7125).


Can this bug be fixed? In my case there is a good reason why the ACK arrives twice!


Other TFTP softwares I tried don't fail on that case (I saw the dropped packet in wireshark, but the next block was sent again as needed).

But I would prefer keeping on using TFTPD32!


Best regards,


#2 bgoas

  • Members
  • 2 posts

Posted 08 June 2016 - 03:31 PM

There is another way to look at the bug, or maybe even a second bug:

the TFTP server should have sent its packet again after its timeout.

So it seems that the ignored ACKs also kill the timeout, and are not fully ignored.

I think it would have worked if they were completely ignored...

Also tagged with one or more of these keywords: tftpd32, bug, retry, ignored

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users