Jump to content











Photo

winpe msiscsi wont start error 5

iscsi winpe

  • Please log in to reply
3 replies to this topic

#1 inoone

inoone
  • Members
  • 2 posts
  •  
    Germany

Posted 23 September 2021 - 03:27 PM

i tried every thing

creating pe on different os es (win10 win11 server2022)

booting on physical, virtualbox, hyperv, vmware

 

net start msiscsi always gives me access denied error 5

set WindowsPE=C:\Program Files (x86)\Windows Kits\10\Assessment and Deployment Kit\Windows Preinstallation Environment\amd64\WinPE_OCs
Dism /Mount-Image /ImageFile:"C:\WinPE\media\sources\boot.wim" /index:1 /MountDir:"C:\WinPE\mount"
dism /image:C:\WinPE\mount /Set-AllIntl:en-US
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-WMI.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-WMI_en-us.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-NetFX.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-NetFX_en-us.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-Scripting.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-Scripting_en-us.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-PowerShell.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-PowerSHell_en-us.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-StorageWMI.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-StorageWMI_en-us.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\WinPE-DismCmdlets.cab"
Dism /Add-Package /Image:C:\WinPE\mount /PackagePath:"%WindowsPE%\en-us\WinPE-DismCmdlets_en-us.cab"


copy C:\windows\system32\iscsicpl.dll C:\WinPE\mount\windows\system32
copy C:\windows\system32\iscsicpl.exe C:\WinPE\mount\windows\system32
copy C:\windows\system32\en-us\iscsicpl.dll.mui C:\WinPE\mount\windows\system32\en-us
copy C:\windows\system32\en-us\iscsicpl.exe.mui C:\WinPE\mount\windows\system32\en-us
Dism /Get-Packages /Image:C:\WinPE\mount
Dism /Unmount-Image /MountDir:C:\WinPE\mount /commit
MakeWinPEMedia /iso C:\WinPE C:\WinPE\winpe.iso

what do i missing?


Edited by inoone, 23 September 2021 - 03:28 PM.


#2 Wonko the Sane

Wonko the Sane

    The Finder

  • Advanced user
  • 15923 posts
  • Location:The Outside of the Asylum (gate is closed)
  •  
    Italy

Posted 23 September 2021 - 04:02 PM

Maybe you miss a few files AND suitable Registry settings.

 

This is for older PE version (3.0):

https://www.gregorys...scsi-initiator/

 

but should put you on the right track.

 

:duff:

Wonko



#3 alacran

alacran

    Gold Member

  • .script developer
  • 2303 posts
  •  
    Mexico

Posted 23 September 2021 - 05:01 PM

@ inoone

 

Better use Win10XPE to build your WinPE: https://github.com/ChrisRfr/Win10XPE

 

alacran



#4 inoone

inoone
  • Members
  • 2 posts
  •  
    Germany

Posted 23 September 2021 - 05:33 PM

although i am using win 10
a gave this one a go
havent changed the situation

still error 5 access denied

also every where i see how to put it iscsi in there is no mention of registry tweaks
all the files mentioned i this tutorial are already there after the DISM commands
except the 4 copied by copy commands

did any one made a pe with iscsi support in the last time?
did microsoft maybe changed something?

"Better use Win10XPE"
on it to download
finger crossed

Edited by inoone, 23 September 2021 - 05:36 PM.






Also tagged with one or more of these keywords: iscsi, winpe

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users