Jump to content

seanpowell's Content

There have been 19 items by seanpowell (Search limited from 19-October 11)

Sort by                Order  

#207677 DiskMgr

Posted by seanpowell on 29 August 2018 - 12:57 AM in Project forge

Perfect!  Thanks so much!

#207670 DiskMgr

Posted by seanpowell on 28 August 2018 - 07:55 AM in Project forge

lol, at least it is not just me!

appreciate you spending the time to fix it - thanks

#207668 DiskMgr

Posted by seanpowell on 28 August 2018 - 07:46 AM in Project forge

the zip now unzips ok but when I extract and run diskmgrx64, it still doesn't remember the active row.  Does this work on your side?

#207666 DiskMgr

Posted by seanpowell on 28 August 2018 - 01:08 AM in Project forge

I think there was an error when creating the zip file...  I now get an error trying to unzip it, and when testing the zip archive with 7zip it reports "data error:diskmgrX64.exe "unexpected end of data"

#207655 DiskMgr

Posted by seanpowell on 27 August 2018 - 02:30 AM in Project forge

that's brilliant, thanks so much Erwan!


Half way there! :)   not to be a pain - which I probably am - but the 64x build doesn't "remember" which line is active when you alter a disks status, which was one of the tweaks you implemented into the 32x build.  Its always going to be the practitioners responsibility to make sure they change the status of the right disk but its really convenient when the active disk stays selected, rather than jumping back to the first line in the table.



#207620 DiskMgr

Posted by seanpowell on 21 August 2018 - 01:13 AM in Project forge

Hey Erwan,

I should have been more specific...  for the the two changes that I suggested on 4/5/2018 above, that you implemented into the 32x build on 25/5/2018, have you (or can you) implement those changes into the 64x build as well?  I have double checked this morning and the current download link includes the 32x file with the changes (ability to expand the window size and retains the current row of the table of disks when an operation is clicked) but the 64x build does not have these changes implemented.


thanks in advance, and apologies if my previous post was unclear.



#207611 DiskMgr

Posted by seanpowell on 20 August 2018 - 03:46 AM in Project forge

Hi Erwan,


Been a while since I've stopped by ReBoot but just wondering whether you were able to implement this on the 64x version as well?



#206854 DiskMgr

Posted by seanpowell on 29 May 2018 - 02:09 AM in Project forge

Hi Erwan,


Apologies for the delay in replying - I had some issues with my 32x build for some reason which gave me a bit of trouble in testing this, but I've fired it up now and the changes are perfect!  Absolutely spot on - can you replicate this to your 64x build when you get a chance please?


Thanks so much for doing this.



#206808 Mini-WinFE

Posted by seanpowell on 17 May 2018 - 02:28 AM in Projects

Having finally been motivated to redo my old win7 boot disk to a win10 x64 build, I've got encase8 working off my mini winfe based build.  Couple of minor issues but it is fully functional.  Very nice.

#206807 DiskMgr

Posted by seanpowell on 17 May 2018 - 01:17 AM in Project forge

re: above requests post...  disregard #3 - just realised you can right click on each line and see the disk info...  apologies, only found out through an errant right click!

#206775 MistyPE

Posted by seanpowell on 04 May 2018 - 09:50 AM in Projects

Hopefully this link works... 
InjectAdditionalFiles.script 1.0
Last Updated May 04 2018 09:46 AM

I make no claim that its well written, being my first winbuilder script.  "Functional" is what I'm aiming for here...  I won't take offense if anyone feels like tidying it up at some point.

#206774 InjectAdditionalFiles.script

Posted by seanpowell on 04 May 2018 - 09:46 AM in App Scripts

Posted Image

File Name: InjectAdditionalFiles.script
File Submitter: seanpowell
File Submitted: 04 May 2018
File Category: App scripts

Copies files/folders inside a user specified location and replicates them into a build. Similar to and based on the Add Custom Folders/Files script from the MistyPE/Mini-WinFE projects.

Click here to download this file

#206769 MistyPE

Posted by seanpowell on 04 May 2018 - 07:28 AM in Projects

Managed to tweak one of the existing scripts enough so that it did what I wanted (largely the existing "add Custom Files" script) - thanks to Misty for having a nicely set out script to follow.


Its probably not too elegant, but its doing the job.  Not sure why the dependencies.USER.ADDED.txt file didn't work for me, but think that gets me around the immediate problem.  



#206768 MistyPE

Posted by seanpowell on 04 May 2018 - 03:44 AM in Projects

thanks Alacran, sounds like an easy option where you just have a few missing files.


What I was hoping for was an option where I could create directory structure and just point a script at it and have it copy any files that exist there, across to the build (and create any necessary folders in doing so).  That way, I'd just create a \windows\system32 folder copy my dll's into that, any applications I could copy into a \Program Files (x86) folder, if I wanted a desktop shortcut I can just create it and copy it to Users\Public\Desktop etc.


I tried editing the txt file you pointed me to but couldn't get the files to copy across, and I can't see which script refers to this to debug any further.


I have tried prefixing the lines in my dependencies.USER.ADDED.txt file either just with a \ as the example entry shows, or specifying a full path on the C:\ and also omitting spaces in case that was an issue - eg, each of


\Tools\__Additional Files\Windows\System32\mfc140u.dll
However, I still don't get the required dll(s) copies across.
Can you point me to the script or any debug information where the dependency txt file should get processed so I can try and see why it is failing?
In the meantime I might try and edit one of the existing scripts to try and copy a whole directory structure (back to the original goal).

#206767 DiskMgr

Posted by seanpowell on 04 May 2018 - 01:33 AM in Project forge

Hi Erwan,

Had a couple of suggestions / requests for you to consider with this tool... 


The most important one to me, is whether you can set the active row in the table to remain when clicking the Offline/Online or RO/RW buttons.  At the moment, it jumps back to the first entry in the table, so if you want to say have the second disk writeable, and you click Online on it, then when you go to click RW, you have to move the bar back to the second disk so you don't accidentally enable write access on the first disk when it jumps back to the top of the table.  Its not a massive issue, but would be handy if it remembered which disk was selected.


The second one is whether you could make the window scalable so that users can increase the size of it instead of being fixed size.  I like to see all of the details in the Name column, but if I stretch that column out, then my Attributes column (which is the most important) disappears off the right side of the screen.  Might be easier here just to enable the Maximise button which is present but inactive (although minimise/restore works).


Thirdly, an additional option to see disk details to include things like model number and disk serial number would also be really useful.


thanks for considering.



#206763 MistyPE

Posted by seanpowell on 03 May 2018 - 05:03 AM in Projects

Hi there,

I can see the Add Custom Folder/Files option to add files/folders and have run a test with that however this script adds the files selected to the path \Programs\User.Added.Files.  Is there a simple way to add, for example, dll files that might be required to run applications that we want to include in to the \windows\system32 folder?


On a previous winpe project, I found a folder for custom files where I could copy in the files required, and the build process would mirror those files into the boot disk - so I used this to add missing dll files, short cuts on the desktop and start menu etc.  Can that be done through this project as it exists or would I need to write a new script to do this (or perhaps modify the existing Custom Folder/Files script)?



#186104 iso compiles but runs windows setup, not the project

Posted by seanpowell on 25 July 2014 - 07:55 AM in Support

ok, that did the trick - who knew!  I took the apostrophe out of the path location of winbuilder and it booted up correctly.  Didn't replace the background for some reason, but the only other thing I had specified for the initial attempt was ftk, which loads.  Thanks very much for the super-prompt assistance, both Peter and Misty.  I will try and add a few things in and play around with it a bit more... 

#186103 iso compiles but runs windows setup, not the project

Posted by seanpowell on 25 July 2014 - 07:37 AM in Support

Misty - I didn't think of the apostrophe as a potential cause of error - I did change folder names to remove spaces after seeing some other posts about that as a cause.  That will be a simple test - I will try it and post back...

#186099 iso compiles but runs windows setup, not the project

Posted by seanpowell on 25 July 2014 - 04:33 AM in Support

Hi there,

I am trying to compile an ISO of MistyPE's WinFE project using WinBuilder 082.  I have unselected all options other than wallpaper and ftk for this attempt.


My source is Win7 Ultimate 32bit.  The process completes ok and generates my iso which I have written to a usb using Rufus.  Testing it on boot up, it boots from the usb but loads to a Windows 7 setup screen as though it has recreated the source iso rather than building a new one from the project.  The logs are a little mysterious to me but I couldn't locate the cause in there.  I have also attempted using a Win7 64 bit and Win 8.1 64 bit source with the same result (ie, loads to windows setup).


A copy of the log is here - https://www.mediafir...37zua/Documents


Any help gratefully accepted.  If there is other information needed, please let me know.