Jump to content











pscEx's Content

There have been 1000 items by pscEx (Search limited from 12-August 10)



Sort by                Order  

#150727 RMPrepUSB - Bootable USB format utility

Posted by pscEx on 18 March 2012 - 10:31 AM in USB Drive Format Utilities

New version 2.1.644 Please try!
Also some new tutorials and Easy2Boot mnu files added.

:clap:

multiPE uses RMPartUSB to create bootable USB PEs.

Is there a new RMPartUSB included in RMPrepUSB?

Peter



#125506 RMPrepUSB - Bootable USB format utility

Posted by pscEx on 24 March 2011 - 11:20 AM in USB Drive Format Utilities

On my ASUS P5KPL-AM with LEXAR GEYSER JUMPDRIVE I use RMPartUSB.exe. No issues with the new beta.

Peter :cheers:



#150729 RMPrepUSB - Bootable USB format utility

Posted by pscEx on 18 March 2012 - 10:38 AM in USB Drive Format Utilities

Thanks, I'll try

Peter



#150740 RMPrepUSB - Bootable USB format utility

Posted by pscEx on 18 March 2012 - 03:02 PM in USB Drive Format Utilities

I tested the new RMPartUSB in multiPE. Runs well. :clap:
Will be included in next release.

Peter



#121426 FiraDisk (latest = 0.0.1.30)

Posted by pscEx on 04 February 2011 - 04:57 PM in FileDisks/RamDisks: Firadisk, etc.

[*]Allow disabling detection of GRUB4DOS and Memdisk by settings in registry. (not tested yet)

Sorry about my low knowledge about these themes. Can you explain to a fool, what it means practically for me?

Thanks.

Peter



#121433 FiraDisk (latest = 0.0.1.30)

Posted by pscEx on 04 February 2011 - 05:22 PM in FileDisks/RamDisks: Firadisk, etc.

@pscEx
Users may install both FiraDisk and WinVBlock and let only one driver see RAM drives.

Thanks!

Peter



#92326 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 February 2010 - 08:35 PM in Projects

Hi DaveXP!

From the past I have the opinion that you are experienced enough, to include a log in you support question :lol:

Unfortunatelly in the mean time I still have had no success in "Bring my Magic Crystal Ball to work"

Peter ;)



#89039 [NotActiveProject] Win7RescuePE

Posted by pscEx on 18 January 2010 - 04:32 PM in Projects

Hi Peter,

I got some errors while downloading the new files of nativeEX:
script.project failed the integrity check
Bochs 242 bios.bin was not downloaded
Bochs 242 vgabios-cirrus.bin was not downloaded
Seabios 043 bios.bin was not downloaded
Seabios bios.bin was not downloaded

I will start the project now.

cheers
pifpof


I think that depends on the current low availability of bootland.net because of DDOS.

I had the same troubles with other files.

But after several downloads I had all files.

So the filese themselves on the server should be ok.

Peter



#89038 [NotActiveProject] Win7RescuePE

Posted by pscEx on 18 January 2010 - 04:30 PM in Projects

I have had the same problem as well, I use the app scripts via SKYBEAM, if I add scripts to Win7RescuePE will NativeX pull those as linked as well or is this only for native Win7RescuePE scripts? If it will not pull them can I just add them to the nativeX instead of Win7RescuePE?

The complete Apps folder of Win7RescuePE is linked to nativeEx_Win7.

If you add any script to this folder (or subfolder) it will be available in nativeEx_Win7.

Peter



#89018 [NotActiveProject] Win7RescuePE

Posted by pscEx on 18 January 2010 - 09:18 AM in Projects

Run the nativeEx_Win7 project.

This project contains only nativeEx_Win7 core functionality.
All apps, drivers etc. are links to Win7RescuePE.
These links are allready in nativeEx_Win7.

You do not need to build any links or copy files from one project to the other.

BTW: Some minutes ago I uploaded some changes in nativeEx_Win. You should do a new download.

Peter



#93271 [NotActiveProject] Win7RescuePE

Posted by pscEx on 04 March 2010 - 08:57 PM in Projects

either it is the same or it is slightly modified :whistling:
it is not the same because it is slightly modified :cheers:
for me the origin script works perfectly ... and I'm not using wb080 because it causes problems for me with win7rescuepe and nativeEx

I already suggested Lancelot, to not "fix" "Bugs" on the fly, but to stay on wait positon and to decide whether a "Bug" is really a "Bug" or a "would be nice" feeling of a user.

You can get th link to the "(for you) working version" from Lancelot.
All previous versions are stored as backup.

Peter



#93396 [NotActiveProject] Win7RescuePE

Posted by pscEx on 05 March 2010 - 05:38 PM in Projects

it does, recently a homes32's shutdown utility/script added to project. Update your scripts.

When did Joshua decided to add?
I do not remember.

If it has been added by anybody else:

Who has the authority by Joshua to change his project?

We agreed in december of last year, that because of his absence real bug fixes are allowed to be made by some admins here.
But we NEVER appointed that any admin can continue "Project development"

If somebody wants to use homes32's (good :whistling: ) script, he can add in personal host's local project's copy.

But there is no necessarity and no right to any admin, to add this script into the project like the author.

To the "Changer": If you are ill for a while, and come back: Are you happy when you do not recognize your own project any more?

Peter



#88975 [NotActiveProject] Win7RescuePE

Posted by pscEx on 17 January 2010 - 05:21 PM in Projects

Afaik there are still some issues with shortcuts ... shortcuts from programs that run from ram are ok, but other shortcuts may disappear.
I think, Peter is on the right way with his project because there I never had this problem, he wrote a script to set the correct shortcuts:
http://www.boot-land...?showtopic=9753

Let me add a comment:

I made the mistake to include the "programs" folder into boot.wim.
In this 'wrong' builds all shortcuts worked.

After fixing "Programs" on CD / USB, there have still been some troubles with shortcuts.
That is fixed now, but not yet uploaded.

But there is an additional issue: Sample: In my configuration MMC shortcuts do not work allways.
Here in [process] the line RunFromRam,True was missing.
Edit:
Depending on the history before processing MMC.script, Therefore the default "False" is used and the shortcuts have been written to the wrong place.

Every script author should make sure that this definition is written as first [process] line.

Peter



#93748 [NotActiveProject] Win7RescuePE

Posted by pscEx on 08 March 2010 - 06:20 PM in Projects

this is not about the scripts psc, its about the loader...sure we do not want to remove joshuas name from anything...

I think that the peloader used in Win7RescuePE is composed by Joshua, or am I wrong?

Peter B)



#93432 [NotActiveProject] Win7RescuePE

Posted by pscEx on 05 March 2010 - 09:37 PM in Projects

...
I already explained you in detail on Icq and I wrote you if you want, it is better to open a topic and discuss on a seperate topic. Again Thanks for understanding.

As written many many many many many times before, these are only small fixes to avoid repeatedly posted issues IF YOU READ the topic. :cheers: :whistling: ;)

Independent of our ICQ discussions (which I started with a "Please: Try like i think "Not help on every request" only upload when there is a REAL bug") .
And independent how you understood my 'no': Nobody besides Joshua can give you the right to add a script to his project.

BTW: The number of 'many' has no influence on the fact that an admin is not allowed to add a script to the project of a member!

Peter



#93743 [NotActiveProject] Win7RescuePE

Posted by pscEx on 08 March 2010 - 06:04 PM in Projects

What's this nonsense about the little devil cursor?!
Never heared that any boss cared about stuff like that, on tools for internal use.
Tell your boss, it's eighter Win7RescuePE with devil or WinPE3 without. B)

:ranting2:

:ranting2:

The devil is something like the author's logo!
And I would NEVER remove it when I use his project, or use it as base for my own addons.

Peter



#87707 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 December 2009 - 11:35 PM in Projects

Configuration / System Locale

That looks like an issue of the project, or better of some internal language handlings.

IMHO the configuration Language is just used once to do some international settings like time format, currency etc.

I promis you: If this is solvable, we'll solve it!

Peter
(But give me some time to understand all of Billy's language .mui secrets)



#87630 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 December 2009 - 12:00 PM in Projects

I am getting the same sort of errors in script number 6.

So clearly there is a problem somewhere, the question is how to isolate the issue?
VW

Can you post a log?

Peter



#87553 [NotActiveProject] Win7RescuePE

Posted by pscEx on 22 December 2009 - 05:26 PM in Projects

Maybe the issue is here:
You have a working Win7RescuePE with a lot of apps.

The idea of nativeEx_Win 7, using Win7RescuePE is not:
  • Add some speed enhancements to Win7RescuePE
It is:
  • Import and use (successfully) "original" Win7RescuePE scripts
To do so:
  • Start with "no Apps"
  • Add one app after the other
    If anywhere there is an issue, we should try to fix the app script which causes the issue
Mary xmas to you and your family, too!

Peter :cheers:



#87547 [NotActiveProject] Win7RescuePE

Posted by pscEx on 22 December 2009 - 05:07 PM in Projects

Hi

I have tried to add NativeEx-Win7 to a Win7rescuePE following your sugestions
Now I can not delete NativeEx_Win7 Cache???

Started off with 58 mins then message access denied
try deleting workbench\nativeEx_Win7\Cache and i get a Cannot delete 1.0.0 Access is denied

I will delete files ,, this is just a FYI

Your post tells me that here something did not run as wanted.
Did you add nativeEx_Win7 project?
And did you run this project?

If yes, maybe there is an until now undetected bug in the project.
(If you cannot delete the cache, there is anywhere a file locked. Try to reboot and delete)

This topic brings me to think about "Remove ALL wim connections including registry, even if in use"

Peter



#87635 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 December 2009 - 01:55 PM in Projects

There is either some :) or a special constellation of your system.
I/O error 32 says "Sharing violation"

But this copy command is as usual as others which work.

The only thing we now can do is "Fishing in the dark" ...

Please change first that the build continues on errors.
So we can see whether there are more situations like this one.

In WinBuilder > Tools > Options > uncheck "Stop build on errors" in the lower right.

Peter



#87701 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 December 2009 - 11:01 PM in Projects

Here seems to be an until now unknown language issue.

Your source CD is Spanish (BTW: Why in Australia?)

You say that you define English in WinBuilder.
Is that by "Language" in "Tools"?
Then it has no influence on the build. It has only influence on the GUI appearance.

If you have an XXX language on the source CD, you cannot define to have an YYY language PE.
You only can define some options, e.g. a different keyboard layout.

Does your PE boot at all?

I'm worrying that to have an English PE, you need an English source CD.

(Maybe there are some options which are until now unknown for me and some other project authors. There are a lot of *.mui files in the soiurce CD ...)

Peter



#87774 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 December 2009 - 04:53 PM in Projects

Addon to my previous post:

Maybe that WinBuilder or a certain Script have troubles with special physical configurations.

Please tell me "everything" about HDD / removable drive / file system / compressed, ...
for the directories of %SourceDir%, %ProjectCache% and %TargetDir%.

Peter



#87771 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 December 2009 - 04:14 PM in Projects

Currently I cannot understand (yet).

I tried with the Win7 source you have.

One sample line:
You:
Posted Image I/O error 32: [FileCopy,"%b32%\*.bmp","%t32%\"]
Me:
Posted Image FileCopy - Copied [%BaseDir%\Workbench\nativeEx_Win7\Cache\Boot_2_en-US_0_6.1.7600.16385.0\Windows\system32\*.bmp] to: [%BaseDir%\Target\nativeEx_Win7\Windows\system32\]

Something is different. Maybe you have a corrupted CD. Maybe the cache directory is corrupted.

From the log I cannot see more information.

Unfortunatelly one rule is valid: As long as necessary files are missing, do not be astonished about a BSOD.

Maybe you try a different source CD and start with a fresh WinBuilder install directory.

Sorry that I cannot give the "final solution" here.

Merry xmas!

Peter

Edit:
I remember that several weeks ago I tried to install a (legally, from Microsoft) downloaded Win7 ISO, and the install failed telling me about missing files.
A new download could be used.

Maybe here is some similar ...



#94696 [NotActiveProject] Win7RescuePE

Posted by pscEx on 15 March 2010 - 10:28 AM in Projects

I facing error while running Win7RescuePE(v.13) build script., ..
attached the logs...
Please Help.. :cheers: ..

You are using WinBuilder 073 beta 3.

Currently actual is version 080.

Please download it and try with that.

Peter



#87835 [NotActiveProject] Win7RescuePE

Posted by pscEx on 25 December 2009 - 06:41 PM in Projects

From what I understand nativeEx is a set of tools that can be used for faster building,
nativeEx will pulling files from a working WinRescuePE

Just for the record to make clear:
nativeEx_win7 PRIMARILY is a method to run a win7 project without having a WAIK installed.
The nativeEx idea is "have everything from source CD"

"ONLY use the source CD / DVD to build a PE"

And therefore (rather actual now :dubbio: ...) it also does not have any files attached or downloaded to %tools%, which are not distributable.

To reach that goal, I replaced only two "ImageX using scripts" by my own "WimCaptEx using scripts".
And some adjustments in variables are done.

As a result: You can add WinRescuePE apps as links, without worrying about "ImageX" or "WimCaptEx" background.

The 'faster building' is my personal "profession"
And long time ago it has been the reason for me to leave "Reatogo" and go to "OpenBuilder"

As engineer, I cannot understand that during EVERY build process FileCopies, RegistryEntries etc. are done (which are to "200%" the same ones like yesterday, like the day before yesterday, and ...)
If to do this needs 5 seconds, ok. But if it needs several minutes ???

Therefore I prefer to haved "Cached results" in my projects, using an algorithm to maintain (automagically!) different cached files for different "Input and Output Combinations"

Peter



#95731 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 March 2010 - 07:35 PM in Projects

My Build PC is: Windows Vista Business SP1

Maybe here is the root5 of all evil.
I developp on XP 32 bit.
And maybe other hosts make troubles.
32 or 64 bit?
I have a test partition Vista SP(???) 64 bit.

But unfortunatelly I do not have 32 Vista bit to test.

Peter



#100197 [NotActiveProject] Win7RescuePE

Posted by pscEx on 15 May 2010 - 07:12 AM in Projects

The only script inside Win7RescuePE which uses wget.exe, is currently CCleaner.Script.

@Jonf:

The script should make sure that MSVCRT71.dll is on the host when using wget.exe

@Dréad:

I would be interested in knowing what caused the hang of WimInfo.exe. Then I could build a 'brake' into the app.

Peter



#100165 [NotActiveProject] Win7RescuePE

Posted by pscEx on 14 May 2010 - 08:55 PM in Projects

well teh build errored on wget.exe system error the program can't start becuase MSVCR71.dll is missing from your computer. try reinstalling the program to fix the problem.


At least were making progress.

That does not look well!

MSVCR71.dll is a fundamental M$ file. That one on my system has date of 2003!

What is your host OS?

Something NLited? or Warez? or did you have several crashes with lost files?

Peter



#100161 [NotActiveProject] Win7RescuePE

Posted by pscEx on 14 May 2010 - 08:30 PM in Projects

ok when setting it to open and not hide the cmd displays, and a window opens to click run, click run twice, getinfo works when clicking play, same prompts. I was right clicking and running as admin this whole time, and i also set permissions on the folder and subfolders for full access. What are those 2 prompts?

Step by step:
  • You changed the Hide to Open
  • You clicked the 'Get Info' button.
  • And a cmd window appears asking you to click 'Run' ?
Something like this is not programmed in WimInfo.exe.

Again: Do a fresh install into a new empty directory and try again.

Peter



#100156 [NotActiveProject] Win7RescuePE

Posted by pscEx on 14 May 2010 - 08:09 PM in Projects

wiminfo.exe applacation error. did not start properly. I get taht error when i try to shut down my system. i hit cancelshutdown. and a windows taht says information Getinfo wimfiles with returned 3221225794 check source directory

If it did not even come up with a cmd window, I assume that the wiminfo.exe is corrupted.

I suggest to re-download the whole project into a fresh folder.

Peter



#100217 [NotActiveProject] Win7RescuePE

Posted by pscEx on 15 May 2010 - 12:59 PM in Projects

SO, if a project includes wget in its tools directory it should also include msvcr71.dll. I've updated VistaPE CAPI.

Agreed!

Peter



#119948 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 January 2011 - 07:52 PM in Projects

First a quick and dirty reply:
I do not remember about issues like you are reporting.

Second:
Tomorrow I'm going to rebuild the project from scratch.
Let's wait for the result.

Peter



#144969 [NotActiveProject] Win7RescuePE

Posted by pscEx on 26 December 2011 - 05:02 PM in Projects

... project (win7PE_SE) has code to help detect which tools to use ...

Just for the record:
multiPE has also code to help...
In addition it has an option 'Auto' which makes the best (?) choice for the user.

Peter



#144911 [NotActiveProject] Win7RescuePE

Posted by pscEx on 25 December 2011 - 06:19 PM in Projects

Mounting *.WIM with ImageX is (with same parameters) independent from the Win7 project. Therefore Scott's statement is very propably valid also for Win7PE_SE.

BTW: In multiPE (Win7 track) I also recommend to use the initial Win7 source CD, no SP1.

Peter



#120195 [NotActiveProject] Win7RescuePE

Posted by pscEx on 23 January 2011 - 09:56 PM in Projects

Thanks for the answer.

It is the same error without ”Run ISO in VMware”

Anyway, I'm waiting soon for the new version of Peter. :whistling:

Sorry, I forgot to report:

I did a Win7Rescue minimum build (no additional apps).
Here the error did not appear.

Maybe Al_Jo's last answer is important. I have the 4 in my build, too.
But maybe there is only one special app needing the dll in question.
And here you have the (Sorry, German) "Schwarzen Peter". To find the app by adding / removing apps from the build, you can do as well as me.

Peter :cheers:



#100147 [NotActiveProject] Win7RescuePE

Posted by pscEx on 14 May 2010 - 07:15 PM in Projects

@Dréad:

You can give us some more info:

in the PreConfig.Script, in the section [Info], please change the two lines with
ShellExecute,Hide,...
to
ShellExecute,Open,...
Then post a screenshot of the cmd window when GetInfo hangs.
Or just catch the window as text and post here.

Peter



#100090 [NotActiveProject] Win7RescuePE

Posted by pscEx on 14 May 2010 - 10:04 AM in Projects

PS: How do you select a Install.wim and a Boot.wim if you can't run Get Info?

:cheers:

Out of what reason you can't run GetInfo (which is attached to WinRescuePE's PreConfig script) and then have to define the indexes in the SAME script?

If you can't run GetInfo, it makes no sence to try any build.

Peter



#87410 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 December 2009 - 04:38 PM in Projects

XP SP2

None that I am aware of. I am admin. LiveXP builds OK.

140GB
My WAIK is not in the default location, but I have updated the source. The win7 media is a mounted ISO. AV is disabled.

That tells no critical issues!

Can you spend some more patience and try the nativeEx_win7 project?
It has some fundamental own scripts, but uses many of Win7RecuePE scripts by links.
If you are interested, more about nativeEx_Win7

To download, add "nativeex.w07.net/win7" to the download server list.

Peter



#95727 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 March 2010 - 06:59 PM in Projects

you also have to download the win7rescuepe project

My Fault!!!!

I assume that also new members are on the level of my knowledge!

Sorry!

Peter

BTW: But to give me a SMALL excuse: Anywhere I already explained ...



#95708 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 March 2010 - 05:42 PM in Projects

@Clif:
I believe you that you may be a bit disappointed now.
But please believe me, too, that there are a lot of satisfied mambers.

So we have to find the reason for your "disappointment", or better said: "What causes that on your system"

I hope that you are not yet too sad and refuse any tests:

Can you try the nativeEx_win7 project?

It has it's own (WAIK free) core, but it links to Win7RescuePE (The 2 - Config script which causes your troubles, is also been processed).

Download it, and then UNCHECK all Win7RescuePE apps, drivers etc. Use just the plain project.

If we get the known troubles again, we have to search for the "bad boy" on your installation.
If that runs: Next step will follow.

Peter



#97323 [NotActiveProject] Win7RescuePE

Posted by pscEx on 08 April 2010 - 05:34 PM in Projects

Sporadically we have a lot of troubles in connecting to WinBuilder, any subdomain, not only this one.

Seems to depend on frequence DOS attacks.

There only patiece helps.

Peter



#97537 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 April 2010 - 02:15 PM in Projects

I uploaded the complete project to http://nativeex.boot...uePE_Upload.zip

Date is 2010-Jan-17, after my last change.

Peter



#97563 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 April 2010 - 06:13 PM in Projects

if u can, i need all scripts u have, thanks :cheers:

@asdfghjklo: I'm not sure what you hope to get besides the files inside the upload I made (see previous post).

@al-jo: It is very nice that you spend the time to upload the project step by step. We need such helpful members :)
Just a hint: Before you upload more scripts:

Download my uploaded project (Takes much less time than uploading everything item by item).

Compare and upload only the missing items.

Peter :cheers:



#97554 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 April 2010 - 05:10 PM in Projects

then the url in the first post should be corrected :cheers:

Done :cheers:

Peter



#97552 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 April 2010 - 04:59 PM in Projects

damn ...
@psc : can you upload your win7rescue-tutorial to another place?

It is still available at http://psc.boot-land...in7RescuePE.doc

Peter



#95700 [NotActiveProject] Win7RescuePE

Posted by pscEx on 24 March 2010 - 05:00 PM in Projects

Hey Guys,
1st time poster here so please bear with me. I'm seeing the exact same error as boandgo was seeing. I unchecked the "stop build on error" and I do get a cd image. However, when I boot it I get the wallpaper, and I get a mouse cursor for a moment.. then the system reboots. I'm going to post my log here, hopefully someone with more experience could take a look and guide me to something that I should change.

Thanks,
Clif

What you did, is understandable, but not the right way.

When you get an error during build, and build stops, then something serious occurred.
You cannot simply say "forget the error and continue".
(This is implemented for developers, where the just created scripts can have a couple of issues).

When in expanding some script attached files, an error occurs, usually there is something wrong with either:
  • The script itself. Then you should re-download the script
  • Your host hardware: Many possible reasons: Not enough space; Target not writable; ... This unfortunatelly you have to find out by yourself.

Sorry that I cannot give you the "Final Solution" here, but I do not mind to answer all questions (look into my signature about "stupid questions")

Peter



#87543 [NotActiveProject] Win7RescuePE

Posted by pscEx on 22 December 2009 - 04:38 PM in Projects

Today I had to fight with a new bug.

In Finalize\4-iso.script several times the WinBuilder command(?) "DeleteFile" is used.

But "DeleteFile" is no WinBuilder command. It should be "FileDelete".

I wonder how the wanted result has been reached with this bug.
Maybe the delete is not really necessary.
Maybe that explains some "unexplainable" results.

I'm going to fix on the server.

Peter



#78085 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 07:33 PM in Projects

im with you on this, but i have betas 7100,7200 and rtm all install fine but will not build the cd ive posted all logs and i can mount the wim and get you a list of its files if that helps any

Please try a build without PENetwork

Peter



#78083 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 07:28 PM in Projects

i am an msdn Developer that isnt a torrented anything its a straigt copy from my origial copy dvd

ok, understood.

But IMHO there is a different reason, not space in the path.
The space has been an issue long time ago. And it should be fixed since about 072.

Peter



#78081 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 07:22 PM in Projects

I know, Peter says it is not a problem, but try to use a folder without spaces. :)
C:\WinBuilder078SP1\

And after that try a non-torrent source CD :)

Peter



#78065 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 05:52 PM in Projects

If you compare the checksum why not?

That idea I haven't had before. :)
But I want to stay in my dinosour behavior with "trustable sources only".
Maybe that is the reason that I also in times before McAfee, Avast & Co, I never have had virus troubles.

Peter :)



#78088 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 07:45 PM in Projects

errors all fixed by moving build folder to root of hdd

Great for you, but as WB developer I now have some troubles / questions / doubts:

My build folder is: "V:\wb\wb debug" and it works fine in all cases.

What's the difference? :)

If the space under some conditions really causes troubles, I have to fix that.
Are you willing to help me?
Maybe we need a lot of tests. But that should PMed.

Peter



#87381 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 December 2009 - 01:23 PM in Projects

**I can help any trusted (well known) member if s(h)e decides to be an admin of rescue.w07.net server about maintance.

Actually today I found some bugs in locale.script which must be fixed.

If you PM me the FTP data, I'll try to be an acceptable Admin.

BTW: Joshua will come back. On Saturday I phoned with him.

Peter



#78146 [NotActiveProject] Win7RescuePE

Posted by pscEx on 12 September 2009 - 10:26 AM in Projects

I just copied my current working Win7RescueCD folder to:
C:\Benutzer and build again.
Build finished without errors.
I can't believe it, i get a black screen during booting. ;)
Houston , we have a problem!

Peter, remember my PM. ;)

Joshua

IMO not the 'Benutzer' is primarily responsible.

ctv99 has a xp host with fixed 'Documents and settings'.

It seems to be due to spaces, but not generally occurring when there is a space in the path.
As you remember, my path 'V:\wb\wb debug' works well.

Maybe the shell does something different when handling 'System' or 'Random User' directories.

Peter



#78109 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 09:29 PM in Projects

This has nothing to do with english source!
Foldername is always
C:\User
German windows shows only
C:\Benutzer
same for
C:\Program Files
German windows shows
C:\Programme

But it could be, that this translation is a problem???
I will make some tests this weekend. :)

Joshua

That's what I love with Billy the Door.

"I decide what the user needs and what the user wants to see"
"I know better than the user what the user wants"

If with a hex editor you look at the HDD: The folder is named "User".
Billy: "But I'm helpful and lie a bit when showing the folder name ..."

Great? In my eyes Bulls???

Peter



#78107 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 09:11 PM in Projects

The difference is incredible (or :) )

@ctv99

Can you please give some info about your drives C: and E:
  • Formatted with FAT / NTFS
  • NTFS Compressed (here could be interesting whether in an uncompressed drive %BaseDir% is compressed)
Thanks

Peter



#78060 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 05:33 PM in Projects

SourceDir : E:\Torrent\en_windows_7_ultimate_x86_dvd_x15-65921
my disk never boots up full clean download, it sits @ a blank screen

The name of the source dir gives me an assumption where you got the source CD from.

IMHO: I would never use a CD I got by torrent.

Peter



#77936 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 September 2009 - 08:20 PM in Projects

Fine that th issue is solved.

But for me one question is open:

Maybe Haighong enters his CP and tells us a 'Flag'

Peter



#77659 [NotActiveProject] Win7RescuePE

Posted by pscEx on 08 September 2009 - 02:04 PM in Projects

Yes, no time to do this:

I am working on that! ;)
But the day have only 24 hours. ;)

Joshua

If it is not sufficient, do like me:

Use also the 12 hours of the night!

Peter :(



#76745 [NotActiveProject] Win7RescuePE

Posted by pscEx on 01 September 2009 - 03:55 PM in Projects

Now the "Expert Fool" is waking up!

I added PENetwork (maybe it should be in recommended rather than in complete).

In the PE it found VMWare driver and tried to start.

BTW: Why is that driver in 'factory settings' included if in 'factory settings' there is no PENetwork to start the network services?

But my PE was emulated under VirtualBox. :whistling:

We have some nice tools like WB-internal 'Depends' or (right now only used in the nativeEx world, but here I have no doubts that it here works, too) Verify.Script.

This should say: If you have PENetwork and VirtualBox selectede, you also need the VirtulaBox NIC driver, etc..

Peter



#76740 [NotActiveProject] Win7RescuePE

Posted by pscEx on 01 September 2009 - 02:47 PM in Projects

After beeing very busy with WB 078 last weeks, I now found some time to test the project.

And, as known, I maybe a good programmer, but I#m additionally an 'Expert Fool'

  • Downloaded into a fresh directory.
  • Followed the instuctions on the project page
  • Choose German Win7 32 bit RC1
  • Went to the Configuration page
    ???? No idea what everything means
    Did not change anything
  • Clicked 'Play'
BOING: "You need to define a WAIK ..."
Did so, clicked 'Play' again. WinBuilder started and after a while, a PE ran into an emulator ;)

Strange background, but I'm sure that I find anywhere (wher???) a 'Classic' style following my preferences.

BIG QUESTION: German source CD, but everything in English : "Programs" etc...

Clicked 'Opera' in order to see my homepage >> No network connection ???

ShutDown >> worked, ok.

Overall judgement:

Already rather well constructed project, needs some adjustements to bring an "Expert Fool" to success in the first trial.

:whistling:

Peter



#75560 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 August 2009 - 07:05 PM in Projects

Here is a general problem, not only in WinBuilder, but also in other forums.

Somebody has a good and working idea how to suppress the symptons of an illness, rather than healing the illness itself.
(Sometimes this is called 'WorkAround')
He / She posts the suggestion, which is very welcome, and everybody uses the 'therapy'.

Unfortunatelly, most users accept the 'suppress the symptons' as 'final healing' and if the description 'how to heal the illness itself' is posted later, it is not of common interest, and therefore not implemented.

Crazy world! 'Let's bring it to work as fast as possible' development is preferred to 'Wait until all is working correctly' development. :D

(In 'my' nativeEx world, in some topics I already stopped to discuss here, but only silently uploaded corrections)

Peter



#77773 [NotActiveProject] Win7RescuePE

Posted by pscEx on 09 September 2009 - 06:24 PM in Projects

I think that it could be wise to check the indexes against source CD type and warn in certain situations.

Peter



#77776 [NotActiveProject] Win7RescuePE

Posted by pscEx on 09 September 2009 - 06:50 PM in Projects

Very good idea! :(
Now need to find a way, how to do that! :(

Joshua

In the English RC1 CD there is inside CD:\support\logging one and only one subfolder, named en-us
In the German RC1 CD there is inside CD:\support\logging one and only one subfolder, named de-de

No idea about other languages, inspite it is very propable that the same mechanism is used.
But maybe a beginning ...

Peter

EDIT: Sorry, I should read more carefully :(

The question was not the language, the question was the 'Enterprise' version.



#77898 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 September 2009 - 04:17 PM in Projects

Just to confirm trumpy81 :(

The WinBuilder variable %Wow64% is defined by calling 'IsWow64Process' in kernel32.dll and therefore is 'version - proof' since XP.

Not very propable, but folder names may change (without notice ;) )

Another congratulation to trumpy81:

To use no quotes is 100% correct ;)

Peter



#77846 [NotActiveProject] Win7RescuePE

Posted by pscEx on 10 September 2009 - 11:35 AM in Projects

I found a solution! ;)
Sometimes it is easy! :(
@all
download new: 0-preconfig.script test, and give feedback!

Joshua

The solution works!

But it is disappointing for a user to get during build the message
" ... Try different install.wim container ..."
He used factory settings! :(

An intelligent project should handle this.

What do you think about following test code
[variables]

 

 [process]

 Echo,%SourceDir%

 IniRead%SourceDir%\sources\product.ini,BuildInfo,Staged,%var%

 StrFormat,REPLACE,%var%,#$c,##$c,%var%

 Echo,%var%
With two different source CDs there are two different results:


Posted Image Q:\CDs Standard\W7_32_DE_RC1
Posted Image IniRead - [Q:\CDs Standard\W7_32_DE_RC1\sources\product.ini] Section [BuildInfo] Key [Staged] to variable: [%var%] with value [STARTER,HOMEBASIC,HOMEPREMIUM,PROFESSIONAL,ULTIMATE]
Posted Image StrFormat - converted [REPLACE(%var%,,,#$c)] to variable: [%var%] with result: [STARTER,HOMEBASIC,HOMEPREMIUM,PROFESSIONAL,ULTIMATE]
Posted Image STARTER,HOMEBASIC,HOMEPREMIUM,PROFESSIONAL,ULTIMATE

and

Posted Image Q:\CDs Standard\W7_32_DE_ENT_7600
Posted Image IniRead - [Q:\CDs Standard\W7_32_DE_ENT_7600\sources\product.ini] Section [BuildInfo] Key [Staged] to variable: [%var%] with value [ENTERPRISE]
Posted Image StrFormat - converted [REPLACE(%var%,,,#$c)] to variable: [%var%] with result: [ENTERPRISE]
Posted Image ENTERPRISE

Now there is only necessary:
StrFormat,POS,%var%,ENTERPRISE,%pos%

 If,NOT,%pos%,EQUAL,0,Set,%container%,?

 Else,Set,%Container%,?
and use %container% when mounting the WIM.

Peter



#77777 [NotActiveProject] Win7RescuePE

Posted by pscEx on 09 September 2009 - 06:59 PM in Projects

Just downloaded Windows7-Enterprise-German, and looked at both .wims with GImageX

Where now to download this?

I think the download time slot ended around aug-20?

Peter



#78149 [NotActiveProject] Win7RescuePE

Posted by pscEx on 12 September 2009 - 10:41 AM in Projects

The problem is in boot.wim.
If i change it with boot.wim from other build, it works.
Now i have to compare the two versions. ;)

Joshua


;)

ctv99 uses in working and non-working build the same source CD and same indexes of the WIMs.
In gis case really only %BaseDir% is different.

Peter



#78100 [NotActiveProject] Win7RescuePE

Posted by pscEx on 11 September 2009 - 08:22 PM in Projects


working debug log

The difference is incredible (or :) )

For 95% are not the project's scripts but WinBuilder responsible.

Please give me some time for tests.

Peter



#85702 [NotActiveProject] Win7RescuePE

Posted by pscEx on 01 December 2009 - 05:52 PM in Projects

i had to risk my life, i had to stop my antiviral protection (damned Jaclaz gonna kill me... well i don't use antivirus so may be not ;) ), i had to fight against malwares but ... here is the tutorial to build your seven rescue CD (made by joshua).


WIN7RESCUEPE TUTORIAL

Hope this will help some of you. :clap:

Until we have a better solution, it is online at
http://psc.boot-land...in7RescuePE.doc

Peter :clap:



#85593 [NotActiveProject] Win7RescuePE

Posted by pscEx on 30 November 2009 - 06:14 PM in Projects

Just to give some stuff to think about:

Linked to nativeEx_Win7 project, I copy the peloader (by Joshua) to my target.
In the past never some problems.

Since about two weeks, after an update of the database avast tells me that in that UNCHANGED file there is a virus.

A mail to avast about false positive did not bring any response.

My afraid is: In some months also my programs (and I'm sure that I never tried / will try to build a virus, I do not even know the HowTo) any sequence in my exe is recognized by an over-sophisticated scanner as virus.

And that is the 'begin of the end' of freeware.
And if one looks at e.g. the new Google OS, maybe there is some intention to create Orwell's 1984 Big Brother ...

... since we found your virus/malware/Trojan ridden forum.

If you worry about your PC's health, be on the safe side, and leave this virus ridden forum.
To discuss something, could be done by different formulations.

Peter



#84530 [NotActiveProject] Win7RescuePE

Posted by pscEx on 16 November 2009 - 08:18 PM in Projects

Hmm, what I mean is I don't want to have to use PENetCfg to be able to access my network. I want the drivers to be loaded by the OS instead. Basically, when the OS is loaded, I should be able to double click the Network icon on the desktop and see the computers that are sharing files, etc. over the network.

If you do not want to use e.g. Holger's (or similar) method, unfortunatelly there is only one way:
You have to write your own script by:
  • Installing one possible driver after another
  • Capturing the changes
  • Convert the changes into a WinBuilder script
  • Add this sript to your project
And if you start your PE on a host where you did not yet capture the driver's installation before: UNKNOWN NETWORK DRIVER!

Do you want to go through all of these disappointments, or do you preferr to try Holger's method?

Peter



#78151 [NotActiveProject] Win7RescuePE

Posted by pscEx on 12 September 2009 - 10:58 AM in Projects

I also uses the same source CD and same indexes of the WIMs.
I mean, the problem is in the boot.wim builded with winbuilder when folder C:\Benutzer is used!

Joshua

Sorry for the misunderstanding!

Peter



#87084 [NotActiveProject] Win7RescuePE

Posted by pscEx on 18 December 2009 - 08:27 AM in Projects

Avast also gives a virus warning.

But I think that it is a false positive. Some weeks ago I also uploaded to virustotal with the result:

9 of 41 tests brought suspection to a virus.

But interesting: The 9 AVs could not agree to the name of the virus. Besides 1 duplicate ALL names are different.

And that for me is more an assumption than a detection of a virus.

Peter



#87377 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 December 2009 - 01:06 PM in Projects

During Copy Files I get some dialog boxes like the following:

I/O error 32: Filecopy,"%b32%\odbc*.dll","%t32%\"
I/O error 32: Filecopy,"%i32%\SystemProperties*.exe","%t32%"
I/O error 32: Filecopy,"%i32%\wmd*.dll","%t32%"
but no errors are reported in the logs.

OOPS!
That is serious and IMO not WinBuilder related.
The dialogbox messages a host I/O issue.

What is your host OS?
Error 32 is "Sharing Violation": Any idea about access restrictions in your host?
Target drive has sufficient space?

Peter



#87370 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 December 2009 - 12:06 PM in Projects

I figure that to edit this I need to go to the Source tab of the relevant script, but I can't locate these sections in any of the scripts ;)

As "library" script it is not shown in the project tree.
Open "locale.script" in the project dir with an external editor.

Peter



#87363 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 December 2009 - 11:27 AM in Projects

Am not too concerned about TimeZoneInformation and have looked to see whether I could simply disable this option. But have not been able to, and it stops the build.

You can adjust WinBuilder to continue at errors:
  • Click the "Tools" button
  • Click the "Options" tab
  • Uncheck "Stop build on error" in the lower right.
Peter

BTW: There are some syntax errors in the script:
replace in the [uk] and [russian] sections
RegWrite,HKLM,0x3,"Tmp_setupreg_hiv\ControlSet001\Control\TimeZoneInformation","DaylightStart","00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"

RegWrite,HKLM,0x3,"Tmp_setupreg_hiv\ControlSet001\Control\TimeZoneInformation","StandardStart","00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00"
by
RegWrite,HKLM,0x3,"Tmp_setupreg_hiv\ControlSet001\Control\TimeZoneInformation","DaylightStart",00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00

 RegWrite,HKLM,0x3,"Tmp_setupreg_hiv\ControlSet001\Control\TimeZoneInformation","StandardStart",00,00,00,00,00,00,00,00,00,00,00,00,00,00,00,00
(do not set the binary data into a single quote pair!)

Peter



#84316 [NotActiveProject] Win7RescuePE

Posted by pscEx on 13 November 2009 - 07:37 PM in Projects

Welcome back at home :drunk:

Peter



#85782 [NotActiveProject] Win7RescuePE

Posted by pscEx on 02 December 2009 - 11:29 AM in Projects

Can you check if they are clean, so we can add a service note to post 1.


Before I uploaded, I checked with virustotal.com:

40 scanners think that the file is clean.

Peter



#78765 [NotActiveProject] Win7RescuePE

Posted by pscEx on 17 September 2009 - 11:41 AM in Projects

@Joshua!

It might depend on how System,RebuildVars work.

It only rebuilds the LOCAL variables.

It does not detect changes in the current program and project variables.

If you changed a project variable with PERMANENT and want to get knowledge to the next local 'Button Click', you have to use
AddVariables,%ProjectDir%\script.project,Variables

Sample from my new OpenWIMs.Script
[CheckSource]

AddVariables,%ImageIndexScript%,Variables

If,Not,%SourceDir%,EQUAL,%LastSource%,Begin

  Exec,%ImageIndexScript%,CheckSource

  AddVariables,%ProjectDir%\script.project,Variables

End

Peter



#78169 [NotActiveProject] Win7RescuePE

Posted by pscEx on 12 September 2009 - 02:36 PM in Projects

;)
I caught the space - ;)

I moved my %BaseDir% around my PC:

German XP XP3, therefore 'documents and settings' >> 'Dokumente und Einstellungen'

%BaseDir%:
  • C:\Dokumente und Einstellungen\Neuer Ordner: works
  • C:\Dokumente und Einstellungen\Default User\Neuer Ordner: works
  • C:\Dokumente und Einstellungen\All Users\Neuer Ordner: works
  • C:\Dokumente und Einstellungen\Peter\Neuer Ordner: black screen
  • C:\Dokumente und Einstellungen\Peter\Desktop\Neuer Ordner: black screen
  • C:\Dokumente und Einstellungen\Administrator\Neuer Ordner: black screen
It looks like imagex has some troubles, if %baseDir% is under the profile directory of an existing user!

Peter



#78218 [NotActiveProject] Win7RescuePE

Posted by pscEx on 12 September 2009 - 09:27 PM in Projects

Thank you!

It is nice to sometime get positive results, not only support questions!

Good luck for the future (and when you have had success with including your driver, post and tell other users)
And if you do not have success, do not worry to ask here.

Peter :)



#79963 [NotActiveProject] Win7RescuePE

Posted by pscEx on 26 September 2009 - 08:23 PM in Projects

You need to update script for virtual box...

Yet again, SUN has changed (with version 3?) the registry entry for where the path is found.

I also know from trying to mess with it before that this is also a fairly OLD version, since the one Peter has in the "nativeEX" project is at v24 (it also has the issue)

The correct path for v3.06 is (remove the "xVM ")

RegRead,HKLM,"SOFTWARE\Sun\VirtualBox","InstallDir",%VBPath%


May I introduce myself ...
I'm the 'Peter' you mention,
and here my post about a VirtualBox.script change, dated Sep 13th
http://www.boot-land...?...ost&p=78250

And if you download from nativeEx server: there IS version 25, dated Sep 13th

Peter :cheers:

EDIT: Cross posting / editing :cheers:

EDIT again:
@Joshua, what do you think about using version 25, too? :(



#79211 [NotActiveProject] Win7RescuePE

Posted by pscEx on 21 September 2009 - 07:28 AM in Projects

Three smaller bugs in 3-Basic-files.script:

Maybe they are already fixed (I'm changing something for nativeWimEx, and therefore did not download for a while)
If,NotExistDir,"%tx%\Manifests",DirMake,%tx%\Manifests"
Missing quote

In [CopyFonts] the source of fonts should be %bw% rather than %iw%

In CreateDirs one directory is forgotten:
If,NotExistDir,"%tw%\Fonts",DirMake,"%tw%\Fonts"

BTW: [CopyFonts] is executed twice.

Peter



#79948 [NotActiveProject] Win7RescuePE

Posted by pscEx on 26 September 2009 - 06:49 PM in Projects

Hallo Joshua!

Until now your project for me is :cheers:

Here my new report:

I downloaded the 'recommended' version and did a build.

You know that I'm sad. I only changed what I know that I have to change: Source CD path and WAIK path.
I did not look into any other scripts (I think that is the usual behaviour of an unexperienced user)

Suggestion #1: Before you upload, please clear the suggested sources / WAIK paths. It is very confusing for a new user to see that.
(I use my tool genUpdateswhich does EVERYTHING with starting two batches. I'm sure we can adapt it for you)

Suggestion #2: Use this tool, too

Build: Successful
Emulation in VirtualBox: Started successful
Trying PENetwork: No Driver found

Suggestion #3:
It increases the size of the PE only by some kb, and it increases the time of build only by some seconds:
Include VMWare / VirtualBox net drivers in the 'factory settings'

To make clear for some users who do not 'read careful':

Project built w/o issues
Emulation ok

Over all: :( (the Until now :cheers: did not change)

BTW: Suggestion #4: Try to find a way to explain new users to first choose SourceCD and WAIK directory

Peter



#79710 [NotActiveProject] Win7RescuePE

Posted by pscEx on 25 September 2009 - 08:45 AM in Projects

If,ExistDir,"%BootSRC%\Windows",ShellExecute,Hide,"C:\Program Files\Windows AIK\Tools\Servicing\dism.exe"," /Unmount-Wim /MountDir:%BootSRC%#$q /discard"

Maybe it could work when you fix the syntax error: /MountDir:#$q%BootSrc%#$q

Peter



#79414 [NotActiveProject] Win7RescuePE

Posted by pscEx on 22 September 2009 - 05:43 PM in Projects

WimInfo.exe is a tool from Peter! I told him this error a few days ago, and he is working on it! :loleverybody:

Joshua


Sorry! I not really was working on it. I just postponed and then forgot! ;)

Now there is version #5, which hopefully fixed the issue.

Peter



#120030 WinVBlock

Posted by pscEx on 22 January 2011 - 06:49 PM in FileDisks/RamDisks: Firadisk, etc.

Very funny! :unsure:
in most forums I always prefer to register as a male to have a normal and appropriate response, Here, too, I started a few years ago as male and only a few months ago I uploaded the picture and added the first name Sarah.
But apparently I was wrong
I do not like to stand out especially in such a forum that intended for men and appears here as a computer freak from outer space

Sorry, Sara - PMedia!
I did not want to critisize your account declarations.

I wanted to critisize the forum's admin procedere:
When a member declares something (in this case gender=male) there is NEVER a reason to "correct" this "automatically" due to some assumed facts.
I assume that you did not get a PM / e-mail by forum administration asking you for male / female. The admins just decided spontaneously after "situation".

Peter



#119903 WinVBlock

Posted by pscEx on 21 January 2011 - 12:49 PM in FileDisks/RamDisks: Firadisk, etc.

@Sha0!

Many thanks for your explanation for driver-fools like me :cheers:

I learned a lot from it.

Peter :cheers:



#119924 WinVBlock

Posted by pscEx on 21 January 2011 - 03:33 PM in FileDisks/RamDisks: Firadisk, etc.

Beecause she is a Lady, and it is such a rare thing among us geeks to have a female member that at the time it was chosen as a distinctive sign, and a special "Group" was created for them.

See me confused :cheers:
sara.gif
:cheers: ?

Maybe we create a group incognitolady

Peter



#115782 [Topic Closed] XBOOT vs 1.0.0 beta5

Posted by pscEx on 05 December 2010 - 10:03 PM in XBOOT

Just for the record:

This functionality is contained in nativeEx_easyPE since several month.
You just define your ISOs:
multiboot_main.gif
Then in PEFactory define whether you want to have ISO or USB, and just click the "(Re)Build PE" button.
multiboot_PEF.gif
In case of ISO it runs into your choosen Emulator, with an ISO like this:
multiboot_ISO.gif
In case of USB the only upcoming dialog is (can be switched off!) to confirm to repartition your USB drive.
multiboot_USB.gif
As a result, you get the USB stick:
multiboot_USB_DIR.gif

BTW1: @Wonko: This does not need any .NET and propably will also run on a W2000 host (provided WinBuilder can).
BTW2: The Avira ISO is created from rescue_system-common-en.iso and contains only the functionality to boot the ISO (only 26 MB compared with 77).
The actual VDFs can be downloaded after boot.
multiboot_USB_AVIRA.gif

Peter



#66290 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 28 April 2009 - 07:14 PM in Win7PE

He always encourage me to be second type of people.

You caused me to read more careful again, and I saw the difference:

prayed for whom filled the water in

Now I understood.

Thanks

Peter



#66152 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 27 April 2009 - 09:05 PM in Win7PE

I have still never been able to get a successful build from this project. I have tried about every combination of sources and apps and Winbuilders and even machines on which to run Winbuilder. But every time when it boots all I end up with is a black screen and a cursor.

Is there anyone out there that might have a solution or even an idea for me? Thank you.

Brian

Look at my posts #169 and #173 and try that.

This will finally start the PE in an emulator.

Going to the 'real world' maybe we have to add some drivers.

Good luck!

Peter



#66115 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 27 April 2009 - 05:35 PM in Win7PE

Reason for not attaching log was in previous post - "something about file was larger than available space - odd when log is only 2kb"

Maybe you did not zip. I cannot remember that anywhen a zipped log has been too big.

Peter



#67671 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 15 May 2009 - 06:53 PM in Win7PE

Did you try with this one; uncomment with following line in file.script?

##DirDelete,"%TargetDir%\windows\System32\de-DE"

I'm going to test

Peter :D



#78485 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 14 September 2009 - 09:23 PM in Win7PE

Just to show where I'm working in my new WimEx project:
Current dev stage, but seems to work
The variables are not yet defined.
Attached File  GetDism.zip   1.15KB   27 downloads
Peter



#66006 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 26 April 2009 - 08:31 PM in Win7PE

Dear All, :)

I've tried as much as I can for my project.
It has Win7 explorer shell as main shell and Qdir + BSexplorer shells are for emergency. :)
Restart, Turn off, Computer, Control Penel are prettily working in start menu.
Desktop background is black but you can change it in ControlPenel\change DesktopBackground as solid Color, sorry not working image as default.
DirectX11 script is included but not sure because not tested well.
DotNetFrame script is from VistaPE and it works some part of it, please try to use and report errors here as some experts can help you. It takes about 400mb of space, so compare your time and space.
FireSharing script is included but not working yet, as left for some experts here, :)
Control Penel is working parts of it, but I left for ControlPenel master, :) you know who he is and you know who you are. (Ludovici :( )
I've included some scripts from here and there and all credits are for whom did it.
For rest of scripts, I left for Script Master Max_Real Qnx, is it possible? :) :(
Many thanks to all other Experts (booty#1, guru, Nuno, MedEvil, Paraglider, NightMan, Jaclaz, and so on) as well as all members of this forum.
Hope it is a good fun for testing it. (Please forgive me if I left expert names, because there are so many experts here.) :( :)

You can download from Hereor add server in your builder. win7pe.winbuilder.net/projects

@Nuno
I've edited my first page as you would like me to do so, and thank to MedEvil for your advice. I hope you like it. :( :(

B Regards,

yahooUK

Thanks, yahoouk! :(

Unfortunatelly I have a lot of download issues.

first: win7pe.winbuilder.net/projects is really a win7pe.winbuilder.net/Projects (and the server reacts case sensitive)
second: If I define this server and try to download, I get a lot of error messages about "could not download' and "failed integrity check"

"could not download" maybe also a ucase / lcase discrepancy between updates.ini and the real name on the server
"failed integrity check" tells about a serious file compare problem. On the server there is a different file md5 than reported by updates.ini.

I do not want to agress you, but: Did you, and if yes, how?, actualize updates.ini on the server?

For the mean time, just to go further, I suggest, that you also upload a .ZIP of the complete project.

Peter :)



#73030 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 29 July 2009 - 08:17 PM in Win7PE

Actually, I've changed the Install.wim container to 5.
Because 5 means Ultimate edition for 32bit.
If you are using 64bit, changed it to 4, might be Ultimate, not sure because I don't have 64bit one.
If you are using containter 2, there is no gpedit.msc there.
I intend to change background image so I have added gpedit.msc.
You can comment it out, it is harmless to your build.

Thanks,

yahooUK

Maybe you give some explanations in the appropiate GUI, what the result of choosing which container?

gpedit.msc: As far as I see, this is a real candidate for
If,EXISTFILE,<blabla>\gpedit.msc,Copyfile ....

Peter



#68244 Win7PE with Winbuilder 74 & 76

Posted by pscEx on 25 May 2009 - 08:03 AM in Win7PE

Boy, I can't build Win7PE to save my life. Downloaded everyting using WinBuilder 077 beta 2 (076 won't download from the Win7 server). Built with WinBuilder 076, on Vista Ultimate x86, latest WAIK installed, building from Windows 7 RC1. But it never copies the BootWimSource! Then all sorts of horrible stuff happens.

To get more information, in '0 - Preconfig' add check for exitcode in MountWin7-imagex
&#91;MountWin7-imagex&#93;

Echo,&#34;Mounting Windows Win7 files with imagex.exe...&#34;

ShellExecute,Hide,&#34;#$q%IMAGEX%#$q&#34;,&#34;/mount #$q%SDIR%\sources\boot.wim#$q %pScrollBox1% #$q%BootSRC%#$q&#34;

If,Not,%ExitCode%,EQUAL,0,Message,&#34;Mount returned with %ExitCode%&#34;,INFORMATION

##

ShellExecute,Hide,&#34;#$q%IMAGEX%#$q&#34;,&#34;/mount #$q%SDIR%\sources\install.wim#$q %pScrollBox2% #$q%InstallSRC%#$q&#34;

If,Not,%ExitCode%,EQUAL,0,Message,&#34;Mount returned with %ExitCode%&#34;,INFORMATION

##
Whenever the exitcode is not zero, something has been wronfg during mount.

Code 2 means, that the mount directory already exists from a previous pass. I don't know whether then there are unpredictable results.

Peter